Cinema 4D / BodyPaint 3D Program Documentation Reference
Function available in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

CINEWARE in After Effects

With CINEWARE in After Effects, Cinema 4D scenes and animations can be loaded directly into an After Effects composition where it can be viewed and rendered within After Effects.

CINEWARE Settings

What you should know about the CINEWARE workflow

In the newest version of Adobe After Effects, complex 3D elements, scenes and even animations can be loaded from MAXON Cinema 4D into an After Effects composition. The unique integration of these applications lets After Effects users create impressive motion graphics compositions even faster and easier than before.

To ensure optimal ease of use, the powerful Cinema 4D render engine CINERENDER was integrated into After Effects in a way that makes it possible to easily and directly render Cinema 4D layers loaded into the composition. This eliminates the need to switch back-and-forth between applications or, depending on the production workflow, make repeated requests for 3D data.

Getting started in the fascinating world of 3D is simple. If you do not yet own a full version of Cinema 4D you can take your first steps in 3D using the Cinema 4D Lite version included in After Effects.

For comprehensive, professional work in 3D we recommend the Cinema 4D Broadcast or Cinema 4D Studio versions.

All product information is available at www.maxon.net.

Loading and editing MAXON Cinema 4D files

Existing Cinema 4D files (.c4d) can be loaded as assets directly in the Adobe After Effects project window and placed in the composition as a Cinema 4D layer. The parameters of Cinema 4D layers will be displayed as ,CINEWARE’ effects in the effect window. Additional effects can be added as usual to the Cinema 4D layer. These will affect the rendering generated by the CINERENDER render engine.

If no Cinema 4D file exists, a file can be created via the After Effects File | New |MAXON Cinema 4D Layer menu. Use the same command in the After Effects Layer menu if you want to create a new Cinema 4D layer in an existing composition.

If a full version of Cinema 4D is not installed on your computer, Cinema 4D LITE, which is included in After Effects, will open. After a new scene has been created it can be saved via the File | Save as … menu and then imported into After Effects. Alternatively, a .c4d file can be dragged and dropped into After Effects for even easier opening.

To make changes to a Cinema 4D file that has been imported into After Effects, select the asset or Cinema 4D layer and select Edit | Edit Original … (Ctrl|Cmd + e). The Cinema 4D Project file will be opened using the version of Cinema 4D that is installed on your computer, where it can also be edited.

Efficient workflow
Projects that have been modified and saved in Cinema 4D will automatically be updated in After Effects.

Configuring the display / render settings

The integration of the Cinema 4D render engine CINERENDER makes it possible to render Cinema 4D layers directly in After Effects. This means that After Effects users maintain complete control of all 3D elements in their composition through to the final render. The render settings are controlled by the CINEWARE effect settings.

Note that each Cinema 4D layer basically has its own render and display settings. All instances of a Cinema 4D file loaded into the composition will automatically have their render and display settings synchronized unless the Synchronize C4D Layer control, at the top of the control panel, is set to off.

Each rendered frame will be cached to speed up workflow. When using reduced or automatic resolutions, the Cinema 4D render results will also have a correspondingly reduced resolution.

To ensure a faster workflow, the Render Settings can be set to Software while you continue to work on the composition. Textures will be displayed in low resolution and shaders will be evaluated to a correspondingly lesser degree.

Options are also available for deactivating textures and shaders Software Rendering deactivates textures and shaders; Draft Rendering only deactivates textures) and for preventing pre-calculations for dynamics or particle simulations. These options should, however, be enabled for final renderings or when caching simulations (baking) in the Cinema 4D scene.

See also Dynamics Caching and Particle baking.

Rendering speed can also be greatly increased by caching the textures using the Keep Textures in RAM option. If the Cinema 4D Project file does not contain a simulation, the No pre-calculation option should be enabled, which can greatly increase the interactive speed.

Working with cameras and Cinema 4D scene elements

Just as in After Effects, any number of cameras with different settings, including animation, can be added to the Cinema 4D file. To ensure a proper integration between the two applications, the camera movements must be synchronized. This is done in the CINEWARE Project Settings menu.

Here you can define if an existing Cinema 4D camera or an After Effects camera should be used.

Four options are available:

The option Cinema 4D Camera will use the currently active Cinema 4D scene camera. Use the Select Cinema 4D Camera option to select an existing Cinema 4D camera. Note that only cameras already present in the Cinema 4D scene can be selected.

The next two options let the After Effects user create cameras. The difference between the options is the coordinate system used. The origin of the coordinate system used by Cinema 4D lies at the center of the scene and its axes are oriented into 3D space in positive and negative directions. In After Effects, a coordinate null point lies in the top left corner of the composition.

This is why the CINEWARE settings offer two methods with which to work with cameras in After Effects. If the Comp Camera option is selected, the coordinates for After Effects and Cinema 4D will be the same. Because this can be slightly confusing for long-term After Effects users, the Centered Comp Camera option can be used to align both coordinate systems.

If the Extract function is used to extract a Cinema 4D camera to After Effects it is recommended that the Comp Camera option be used. Otherwise the view will be offset as a result of the deviating coordinate system.

Layers

Cinema 4D has a comprehensive layer system that can be used to organize complex 3D scenes. This layer system is not designed to create a stacked layer hierarchy as in After Effects but rather to group scene elements for easy and efficient access. Individual parts of a scene can, for example, be hidden and unhidden, if necessary. These Cinema 4D layers can be activated or deactivated individually in After Effects. Only active Cinema 4D layers will be rendered in the composition's Cinema 4D layer. This makes it possible to use a single Cinema 4D file multiple times in a given composition as its own Cinema 4D layer and display specific elements of the scene.

For example, 3D background and foreground elements can be separated and stacked in the After Effects composition or combined with footage in After Effects.

Note that all Cinema 4D elements that do not lie on a Cinema 4D layer can be activated or deactivated using the Default Layer option in Set Layers. This option is not visible if using Cinema 4D R15 or earlier to render, instead all Cinema 4D elements that do not lie on a Cinema 4D layer will always be active in every Cinema 4D layer.

Multi-passing

Multi-passing for 3D is the process of rendering an image as separate image elements instead of rendering all elements together as a single image.

These elements are brought together in compositing where these separate image elements can be edited, adjusted or modified in one of several ways, including color correction. A typical example of multi-pass rendering would be to output different surface reflections (diffuse, specular, shadow, etc.) separately and bring them together in After Effects with different modes.

A composition can be quickly constructed using the CINEWARE Add Image Layers option. Several Cinema 4D layers will be created, each of which will contain a single active render element. The Set Multi-Pass option lets you define what will be displayed on a given Cinema 4D layer.

To create additional layers for individual render elements, a layer can be duplicated and the desired element can be added using the aforementioned option.

Multi-passing is also used to output object passes, which are used as Luma Mattes for separation correction of individual elements in After Effects. Note that at least the Standard Draft render mode must be activated in order to generate individual passes. Additional passes can only be output via the Compositing tag.

To configure object passes, the corresponding objects in Cinema 4D must have a Compositing tag assigned to them with the desired group ID. The Multi-Pass option must also be enabled in the Cinema 4D render settings with the desired object passes defined. Since After Effects displays the names of the passes, it is recommended that the passes already be named in Cinema 4D.

However, please note that Cinema 4D post effects and the separation of individual lights (light multi-passing) are not yet supported in this integration.

To achieve an optimal result when working with multi-passes, it is recommended that Adobe After Effect's project settings be set to Linear Workflow (linearized Working Space) and that a 32-bit float color depth be used, if possible, otherwise artifacting may occur.

Exchanging scene information

In order to align camera animations or scene lighting between Cinema 4D and an After Effects composition, cameras and lights, including animations, set in the Cinema 4D scene can be transferred to After Effects at any time. All comparable camera and light properties will be aligned. Clicking on the Extract button in the Cinema 4D Command menu will create the corresponding elements in the After Effects composition.

Note that only those lights will be transferred that have the Export to AFX option enabled in their General tab's settings in Cinema 4D. This option is enabled by default for every Light object and every camera in Cinema 4D.

After Effects cameras with existing animations can also be transferred to the Cinema 4D scene. This can be done using the Merge option in the Command menu.

Use the File | Export | MAXON Cinema 4D Exporter command to save a .c4d file - in which cameras, lights, text and Shapes (the last two will be transferred to Cinema 4D as Extrude objects) and NULLs will be included - from After Effects for use in Cinema 4D

Using references

A Cinema 4D layer in After Effects is a 2D layer. To effectively place 3D layers from After Effects in a composition it can help if information regarding the position of Cinema 4D objects as color surfaces / solids is made available. For this to occur, polygon objects or layers in the Cinema 4D scene must have an External Compositing tag assigned to them. The Solid option can be enabled and a size for the color surface in After Effects can be defined.

Use the CINEWARE Extract function to import the corresponding data.

To avoid problems when importing Cinema 4D scenes into After Effects, the Save Polygons for Melange and Save Animation for Melange options should be enabled in the Cinema 4D Edition | Preferences | Filesmenu.

Overview of individual parameters

In the following you will find a brief explanation of the CINEWARE settings.

Options

Cinema 4D Render Path

If you want to use a different renderer than the CINERENDER provided, i.e., a new or different Cinema 4D version, enter the path to the corresponding Cinema 4D executable file (*.exe or *.app).

Note that the other Cinema 4D versions must be licensed when using them to render!

Cinema 4D Executable Path

This path only serves to define the Cinema 4D version that should be used for editing Cinema 4D files. Assuming you have a new Cinema 4D version installed and want to use it to edit a file, all you need to do is enter the path to the corresponding Cinema 4D executable file (*.exe or *.app).

TCP

This is where the communication port between CINEWARE and the integrated Cinema 4D renderer (CINERENDER) is defined. If this setting must be changed for any reason, After Effects will need to be restarted.

Synchronize AE Layer

Decides whether the layer should mimic its render and project settings in all other layers for the c4d file in this composition. Equally it decides whether or not other layers can change this layer's settings. Note, this parameter is only visible when there is more than one instance of the c4d file in the compostion.

RELEASE 17

Live Link

After Effects Live Link is a function that lets you synchronize the After Effects and Cinema 4D timelines, i.e., if the Timeslider is moved in Cinema 4D, the slider in After Effects will also move and vice-versa. This is useful when switching back-and-forth between After Effects and Cinema 4D because the project will always be at the same location in the timeline.

This function is not yet supported in After Effects but the button will automatically be enabled as soon as it is! Also note that it no longer works with the integrated Cinema 4D Lite and only with a stand-alone version of Cinema 4D R17 or higher.

Enable

This button is only made available if a Cinema 4D version that supports Live Link is defined in the Options menu’s second link. Otherwise the button will remain inactive.

Cinema 4D will be started if you click on Enable (if it’s not already running) and the same *.c4d file will be loaded with which After Effects is currently working. The timesliders in both applications will be synchronized, which means that they will both lie on the same frame.

Click on Disable or close Cinema 4D if you want to break the link.

Render settings

Because render times can increase dramatically for complex scenes, CINEWARE offers three different render modes:

Software

For the most part, the display reflects that of the Cinema 4D Viewport and serves to preview the scene. Shaders and multi-passes will not be displayed.

Standard (Draft)

Display without antialiasing and can be used as the preliminary stage to final rendering.

Standard (Final)

Renders the scene using the render settings defined for the Cinema 4D scene.

OpenGL

Renders the scene using OpenGL. Shaders and multi-passes will not be shown.

Software - Draft - Final

Display

Defines the type of display. Either the original Cinema 4D settings will be used or the display will be reduced to Wireframe or Box to permit more fluid work.

No Textures/Shader

Disables the display of textures for quicker navigation.

No Pre-Calculation

Disables the rendering of dynamic, cloth and particle simulations as well as MoGraph simulations in order to increase display speed. Hence, the displayed results of these processes will not be accurate. This option should not be enabled for final rendering - or simulations should already be cached in the Cinema 4D file.

Tip
This option should never be enabled for final rendering because particle effects, many MoGraph functions, dynamics and cloth will not be displayed or rendered correctly.

For best render results in After Effects, Linear Workflow should be enabled in the After Effects project settings and Bit Depth should be set to 32-Bit Float.

Keep Textures in RAM

Speeds up rendering by caching textures so they do not have to be re-rendered (Drawback: Modifications made to textures will not be displayed).

Render Server

Purge Memory

After prolonged use the render server can become slower as it stores the scenes being processed. If the rendering seems slower or less responsive this button can be used to flush the memory of the render server (this option is not visible if using Cinema 4D R15 or earlier to render).

Project Settings

Camera

Defines the camera that will be used to display the Cinema 4D layer.

Cinema 4D Camera

The default - and active - camera in the Cinema 4D scene.

Select Cinema 4D Camera

Lets you select a camera from the Cinema 4D scene.

Centered Comp Camera

This camera uses the After Effects coordinate system.

Comp Camera

Equal coordinates for After Effects and Cinema 4D will be displayed. Because the Cinema 4D coordinates differ from the After Effects coordinates, After Effects users will have to switch their train of thought. This option must be used if a Cinema 4D camera is extracted because the After Effects view would otherwise switch to the Cinema 4D scene.

Set Camera

If a Cinema 4D scene contains cameras in addition to the default camera, these can be selected using the Set Camera button.

Cinema 4D Layers

If a Cinema 4D scene contains layers, this is where they can be selected. Only those Cinema 4D scene elements that are assigned to this Cinema 4D layer will be used. This makes it possible to display individual object groups in After Effects on Cinema 4D layers.

Synchronize C4D Layers

If multiple instances of a Cinema 4D file are present in a composition in which layers are used, the Synchronize C4D Layers option might be displayed. If enabled, all of an instance’s selected AE layers will be synchronized according to their visibility (as it’s defined in Cinema 4D).

Set Layers

This is where layers in the Cinema 4D scene can be selected.

RELEASE 17

Set Take

CINEWARE supports the important Set Take function in Cinema 4D. If Takes are used in the imported Cinema 4D file you can click on this button and then create a Take for this instance. Details about the Take function can be found here.

If a renderer other than the standard AE renderer (one that does not support Takes), this button will remain disabled.

Multi-Pass (Linear Workflow)

Cinema 4D Multi-Pass

Enabling the Cinema 4D Multi-Pass option makes it possible to define individual passes for the Cinema 4D scene. These are pre-defined, even if the Multi-Pass option has not yet been enabled in the Cinema 4D scene.

Special passes such as Object Channel must be set up in the Cinema 4D scene and enabled in the Render Settings (Multi-Pass) menu.

Set Multi-Pass …

Here individual passes can be selected to be used in the Timeline. Note that post effects (e.g., Hair, Sketch and Toon, etc.) are not supported.

Defined Multi-Passes

The multi-passes defined in Cinema 4D can be extracted to the Timeline by enabling the Define Multi-Passes option in CINEWARE and by clicking on Add Image Layers.

In other words, only those multi-passes that were defined in the Cinema 4D Render Settings will be extracted.

Add Image Layers

If the Add Image Layers button is clicked without first enabling the Define Multi-Passes option, all existing multi-passes will be extracted to the Timeline.

Post effects and light passes are not supported by multi-passes.

Commands

Comp Camera into Cinema 4D

Merge

The active composition camera in After Effects will be added to the Cinema 4D scene. This can also be an animated camera.

Cinema 4D Scene Data

Extract

All cameras and lights in a given Cinema 4D scene, including their animations and properties, will be transferred to the After Effects composition as layers in the Timeline. In addition, Cinema 4D timeline markers will be assumed in the After Effects timeline.

Polygon objects that have an External Compositing tag assigned to them will be placed as NULL layers as position references in the composition or generated as color surfaces.