Reference Cinema 4D Cinema 4D Prime XPresso XPresso Editor
Function available in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Menu

File

Load XGroup, Save XGroup As

Load XGroup imports a previously saved XGroup into the selected XGroup. If no XGroup is selected, the XGroup is loaded directly into the XPresso Editor. Once loaded, the XGroup uses its standard size setting, i.e., its contents will be hidden. To show the contents, right-click (Windows) or Command+click (Mac OS) the XGroup and choose either View / Extended or View / full-screen from the context menu.

Save XGroup As saves the selected XGroup. If no XGroup is selected, the entire contents of the XPresso Editor will be saved.

Close

This command closes the XPresso Editor. To reopen it, double-click an XPresso tag in the Object Manager.

Edit Menu

Undo, Redo

Use Undo to undo the last change you made in the XPresso Editor; select Undo repeatedly to undo changes one by one. Select Redo to redo the last undo.

Cut
Copy
Paste

The Cut command moves the selected nodes or XGroups (including their wires) to the clipboard. The Copy command copies the selected nodes or XGroups (including their wires) to the Clipboard. The Paste command copies the nodes or XGroups that are stored in the clipboard to within the currently selected XGroup. If no XGroup is selected, the elements are placed directly within the XPresso Editor.

Delete

Deletes the selected nodes or XGroups.

Select All
Deselect All

These commands select or deselect all nodes and XGroups.

Enable, Disable

If you disable a node or XGroup that is between two enabled nodes or XGroups, no values will be passed through. In effect, the enabled elements will be disconnected from each other. Nodes and XGroups with missing or disabled parameters have a yellow title bar.

Using these commands, you can switch nodes and XGroups on or off so that you can test parts of an expression in isolation without having to disconnect wires. Select the elements that you want to switch off then choose the Disable command. To switch the elements on again, select them and choose Enable.

Layout Menu

Inputs

The Inputs setting determines whether inputs appear at the left edge or right edge of nodes and XGroups. Since the outputs always appear at the opposite edge to inputs, there is no separate setting for outputs.

Connections

Connection types from left to right: Direct, Straight, Normal, Curved.

The Connections sub-menu controls the appearance of wires: Direct, Straight or Normal. For example, if you choose Direct, each wire is displayed as a single, straight line.

Show Status Bar

Enable this option to display the XPresso Editor’s status bar. The status bar appears at the foot of the XPresso Editor and, when you hover over a port with the mouse pointer, provides useful information such as the port’s name.

Reset To Default

This command resets the XPresso Editor to its default layout. The Connections setting is set to Normal and the Inputs setting to At Left.

View Menu

Zoom

To magnify the contents of the XPresso Editor, choose a zoom factor from this sub-menu. Alternatively, click and drag on the zoom icon situated in the top-right corner of the XPresso Editor.

Show AllDisplays the entire expression in the XPresso Editor.

Show Selected

Selecting this command will zoom or re-position the view so that all selected Nodes are displayed.

Align To Upper Left

Moves the entire expression to the top left corner of the XPresso Editor. No zooming takes place.

Center Nodes

Moves the center of the expression to the center of the XPresso Editor. No zooming takes place.

Align To Grid

Aligns the nodes and XGroups to the XPresso Editor’s grid.

Custom Menu

The commands in the Custom menu relate to plugins. For example, if purchased and installed, from this menu you can access the settings of Thinking Particles.

In addition, on this menu you will find the commands for opening the XPresso Pool and XPresso manager. Since these two windows are integrated into the XPresso Editor by default, you will only need to use these commands if you have undocked the windows and closed them.

Calculate Menu

Start XPresso Calculation

Choose this command if you want to test an expression. All nodes and connections will be calculated once only. Check the result and correct or refine the expression accordingly.

Animation Refresh

When this option is enabled, the expression is recalculated for each frame of the animation. This ensures that all data coming into the expression, such as the position of objects, is up-to-date.

Live Refresh

This option determines whether the expression is calculated in real-time while a parameter is being changed (option enabled) or after the parameter has been changed (option disabled). For example, suppose an expression makes a dog follow his owner. If Live Refresh is enabled, the dog will follow his owner while you drag the owner to a new position in the viewport. If, on the other hand, the option is disabled, the dog will wait for the mouse button to be released before catching up with his owner.

Performance View...

The darker the Node, the longer it will need to calculate.

Selecting this option opens a small dialog window. Enabling the Performance View will display the required calculation time for each Node (i.e., the most calculation-intensive Nodes will have a red title bar). This function can be used to locate Nodes that will take long to calculate so they can be replaced with optimized Expressions.

Enable Performance View

Enables the Performance View function.

Mode

Select whether the Node’s calculation time should be displayed in milliseconds (Time) or according to the number of calculation operations per pass (e.g., animation frame).

Intensity

Use this setting to define the intensity with which the Nodes’ tile bar will be colored. The darker the color, the more render time the Node requires. Increasing the Intensity value will cause the Nodes to turn red correspondingly faster.

To be more precise, this is where you enter a limit value. If, for example, you enter 50ms and a Node requires 50ms or more to render, it will be colored bright red. If the Node requires less time it will be colored correspondingly less red.