Cinema 4D / BodyPaint 3D Program Documentation Tutorials Mechanical Modeling Tutorial Subdivision Surfaces Modeling A Working Example of Subdivision Surfaces Modeling
Function available in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Modifying the sphere’s surface structure

We will start by manually creating just such a mix. First, copy the Sphere Object (Ctrl/Cmd + drag & drop in the Object Manager). Leave the Type option set to Standard for one sphere and set the second sphere to Hexahedron. Rename your objects accordingly. To rename an object, simply double-click on its name in the Object Manager and enter the new name. The image below illustrates the difference between the two sphere types.

Make both spheres editable, switch to Points mode and select the Rectangle Selection tool. Using the Rectangle Selection tool (Selection menu) will make it easier to select and delete points on the lower hemisphere. Make sure that the selection tool’s Only Select Visible Elements option is disabled in the Attribute Manager. Select the Sphere (standard) object in the Object Manager and delete all points under the first ring below its centerline. This is best done in the front or side viewport. Next, select the Sphere (hexahedron) object and delete the points of its upper hemisphere. The result should reflect the upper illustration in the image below. To better illustrate this, we turned off the opposing object’s visibility.

Note: An object’s visibility can be turned on or off using the small gray circles to the right of each object’s name in the Object Manager. The top circle turns the object’s visibility off or on the viewport and the bottom circle turns the object’s visibility off or on for rendering. The default (or automatic) status is gray. Clicking on a circle once will turn it green (always visible); click the circle twice to turn it red (always off); clicking a third time will return the circle to its default (automatic) state.

As you can see, the hexahedron sphere does not have an even edge after the points were removed, and the number of points along the edge does not match that of the Sphere (standard) object. This will make fusing these objects more difficult. Switch to the Loop Selection tool (menu Select) so we can select the points along the Sphere (hexahedron) object’s irregular edge and reposition them by using the Set Point Value command and setting their Y Size value in the Coordinate Manager to 0. The result can be seen in the lower half of the image below.

Scaling selected points

Using the Loop Selection tool, select the first ring of points above the Sphere (standard) object’s centerline (as illustrated in the image below). In the Coordinate Manager, highlight the X Size value and copy it to the clipboard (Ctrl/Cmd + c).

The selection’s values

Next, select the Sphere (hexahedron) object in the Object Manager - the points along its top edge should still be selected. In the Coordinate Manager, paste the previously copied value into the X Size and Z Size fields (Ctrl/Cmd + c). Confirm your entries by clicking on the Apply button. Now the outer radius of these points on both spheres should be identical. Now do the same for the Y Position value.

Scaling the Sphere (hexahedron) object’s points along the Y axis has caused the sphere to lose its perfect circular shape. Even though the deviance is very minor it should still be corrected. In order to establish a reference for this corrective procedure we will use the Cinema 4D Snapping function. To start the procedure, select the Sphere (standard) object and convert the current point selection (Convert Selection) to an edge selection. Alternatively you can press the Ctrl/Cmd key when switching from Points mode to Use Edge Tool mode.

Converting edge selections to Splines

Edge selections bear the advantage that they can be converted to Splines. To do so, use the Edge to Spline command in the Structure menu (Mesh | Commands). Once the command has been executed a new linear Spline object will automatically be created as a Child object of the Sphere (standard) object. In order to make this newly created Spline perfectly round, select it and set its Type option to Bezier in the Attribute Manager and setting the mode for intermediate points to Natural. The soft tangents that are automatically generated will make the Spline perfectly round - now we can snap the points along the edge of the sphere to the points of the Spline.

Snap function

Now we will make use of the Cinema 4D Snap function. This function can be activated in one of several ways. Select Enable Snap from the Snap menu or from the Icon Palette on the left side of the interface. The Snap Radius value defines the distance from the elements at which snapping will take place. The option lets you select between three modes:

In our case we can leave Type set to Auto, and select the Spline Snap command. Disable all additional snapping options to avoid any unintentional snapping.

Another method of defining a snapping mode is to press the p key on your keyboard. This will open a snapping menu from which you can select a type of snapping or completely disable the Snap function, as shown in the image below.

You can also see the advantages of Backface Culling (Viewport menu: Options). Only those polygons facing the user (i.e. you) are visible. We no longer need the top half of the sphere so it can now be deleted. Before doing so, drag the Spline Child object out of the Sphere (standard) object’s hierarchy! Otherwise the Spline will be deleted as well. Now select the Sphere (hexahedron) object, make sure you are in Points mode, and move the points along its top edge towards the Spline object - until they snap into place. After doing so, don’t forget to disable the snapping function for the Move tool again.

Adding thickness to an object

Basically every object has thickness (volume). Even a sheet of paper has a certain thickness. A uniform thickness can be created from a polygonal body using the Extrude tool. Switch to Polygons mode and make sure no polygons on the hemisphere are selected. We want the Extrude tool to include all of the hemisphere’s polygons. Next, select the Extrude tool (Mesh | Create Tools) and enable its Create Caps option - this makes sure that the original polygons are maintained and that a voluminous body emerges. An Offset value of 3 should be enough for our object. Since the extrusion will take place along the surface’s Normals, the overall size of the hemisphere will increase in relation to the Offset value. Click on the Apply button to extrude the object.

Finally, create a Subdivision Surface object i.e., from the menu Create | Generators and make the hemisphere a Child object. In the image below you can see what the result should look like, including the Extrude tool’s parameter settings. Also, we have reached the point in our project at which we can rotate the hemisphere to a more appropriate position for a chair.

Shaping the front edge

If you take a closer look at the hemisphere’s opening you will see that the edge is still a little sharp. This is due to the fact that the polygons that run along the edge are relatively large and therefore do not have a point density sufficient enough for the Subdivision Surfaces to create a more rounded edge.

We will fix this by rounding of the edge. We will use the Loop Selection tool to select the edge, as shown in the image below. After selecting the edges, activate the Bevel tool from the Mesh | Create Tools menu and set its Offset value to 0.4. After clicking on Apply you will have the finished outer shell of our designer chair. Later we just have to create its pedestal. First, though, we will add the inner lining and padding.

Continue …