Cinema 4D / BodyPaint 3D Program Documentation Tutorials Mechanical Modeling Tutorial Subdivision Surfaces Modeling A Working Example of Subdivision Surfaces Modeling
Function available in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

The Back Cushion

Click on the following link to open the scene file for this tutorial:

We will now create a cushion at the back of the chair to add a little more comfort. Again, we will use the Split tool to create a new cushion object. At the left of the image below you will see which polygons we selected to create our back cushion. Note that the seam between the two padding halves is not included. We will close this gap using the Stitch and Sew tool (Mesh menu). With the Stitch and Sew tool a connecting surface can be created between opposing points. A point is clicked upon and dragged to the next, fusing these points. This process is illustrated at the center of the image below.

Note
The new object created using the Split tool was temporarily removed from the Subdivision Surfaces object’s hierarchy.

Next, extrude the cushion as shown at the right of the image below. A Subdivision value of 1 should be enough.

The back cushion’s seam

This cushion will also be given a seam that runs around its perimeter. Switch to Polygons mode, select the cushion’s top half and add a Selection tag (Select Set Selection). The Polygon Selection Tag can be seen next to your object in the Object Manager (orange triangle). This tag enables us to, for example, restore the selection saved to it at any time or make it invisible in the viewport. The surfaces selected are shown in the image below.

Select the Selection tag in the Object Manager and click on the Hide Polygons button in the Attribute Manager. This will expose the top edge of the bottom half of the cushion. Select this edge using the Loop Selection tool in Use Edge Tool mode, as shown at the left of the image below. Select the Extrude tool. When in Edges mode, the Extrude tool offers additional parameters from which to choose. The Var value defines the angle in which the extruded edges will be moved in relation to the surrounding polygons. Our Edge Angle value in combination with a negative Offset value extrudes the edges into the cushion, as shown at the center of the image below. This extrude will later server to pinch the smoothed Subdivision Surface objects at this location.

The image shows the edge at the left selected via the Loop Selection in Use Edge Tool mode. Activate the Extrude tool anew, which will make additional options available because we are currently in Edge Mode mode. The Edge Angle value can be used to define the angle in which the extruded edges should be moved in relation to the surrounding polygons. An Edge Angle value of 90° in conjunction with a negative Offset will move the new edges towards the inside of the cushion, as is shown at the center of the image above. This will later re-direct the Subdivision Surfaces-smoothed shape towards the inside of the cushion. If we proceed according to the same principle with the top cushion it should suffice for the indication of a seam.

Switch back to Polygons mode so we can unhide the polygons we previously hid. Use the Select menu’s Unhide All command to unhide the hidden polygons. Switch to the Selection tag and click on the Select and Hide Others button. This will hide the lower half of the cushion. Use the Loop Selection tool in Use Edge Tool mode to select the bottom edge of the polygon selection, as shown in the image below.

Apply the Extrude tool with the same settings as for the lower half of the cushion. Switch to Polygons mode and again select the Unhide All command from the Select menu. Drag the split object back into the Subdivision Surfaces object’s hierarchy and it should resemble the example at the left of the image below. The center example shows a selection of polygons that can be slightly moved towards the front of the chair to add more padding to the rear cushion, if desired.

Continue …