Cinema 4D / BodyPaint 3D Program Documentation Tutorials Materials & Texturing Tutorial Basic Surface Properties
Function available in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Defining Materials

Materials are created and managed using the Material Manager.... The Material Manager is located below the editor window in the standard layout. All materials and material groups for a given scene are displayed here as an icon. Clicking on an icon will make that material’s properties available for editing in the Attribute Manager. To make editing a material even more convenient, double-click on the material’s icon to open a separate Material Editor window. This window can be scaled and positioned independently from the main GUI. The image below shows a material’s properties as they are displayed in the Attribute Manager (left) and the Material Editor (right).

To create a new Material, select the New Material command from the Material Manager’s Create menu. A new material can be created even faster by simply double-clicking on an empty area of the Material Manager. By default, a new material’s icon will appear as gray sphere with a medium-sized specular highlight. This depiction is designed to give you an impression of how light affects the material. Of course this depiction can differ from how the material looks on an object since lighting, the type of rendering and the shape of the surface itself can influence how a material looks on an object. Therefore, it is always recommended that a test render be done to see what the material really looks like.

Using Existing Materials

In the course of a project, numerous materials will be used to simulate various types of surfaces. Once a material has been created it does not have to be re-created for use in another scene. To load a material from another scene, select the Load Materials... command from the Material Manager’s File menu.

Furthermore, included in Cinema 4D are numerous everyday materials that can be loaded into a scene via the Load Material Preset command in the Create menu. Additional files can be found in the Content Browser (Window menu), which can be loaded via double-click or drag & drop. In the image below is an example of a glass material in the Content Browser.

Grouping Materials

Materials can be grouped into layers in order to better organize a scene containing many materials. For example, all materials of a given object or materials with specific characteristics can be grouped (e.g., all wood, metal or cloth materials).

An active material can be assigned to a layer using the Attribute Manager’s Layer option (Basic tab). Also, the Material Manager’s Function menu offers the Add to new Layer and Remove from Layer commands.

These groups can then be manipulated, e.g., renamed, made visible or hidden in the Material Manager, via the Layer Manager which can be opened via the Window or the previously mentioned Function menu.

Displaying Materials

Numerous options are available for defining a material’s preview icon via the Material Manager’s Edit menu. For example, materials can be displayed as icons next to each other (Material) or as a list (Material list). Additional options are available that are useful when working with textures, i.e., bitmap graphics within a material channel. Each of these options contains a Layer Manager and are used particularly when working with BodyPaint 3D when painting directly onto an object. For example, individual material channels can be filled with various bitmaps to create complex compositions, as is done in Adobe’s Photoshop. The list of materials in the Layer Manager bears the advantage that all bitmap layers in the material channels can be viewed at a single glance.

A material’s preview icon can also be scaled in the Material Manager. Four options are available in the Edit menu, ranging from Mini Icons to Large Icons.

Various examples of preview icon display modes

Naming and Optimizing Materials

As with objects, it makes sense to name materials according to their use or effect. To name a material simply select it in the Attribute Manager and type in the desired name into its Name field in Base tab of the Attribute Manager. A material can also be renamed by double-clicking its name beneath its preview icon in the Material Manager.

In order to delete a material from the Material Manager, simply select in and press the del or Backspace key on your keyboard. Materials not assigned to an object in the scene can be deleted automatically via the Function menu’s Remove Unused Materials command. This menu also contains a command for deleting duplicate materials.

It can occur that the preview icons of complex materials, e.g., those containing numerous shaders or bitmap graphics, display incorrect previews of the respective material. For example, modifying a texture path can lead to that texture no longer being found but nevertheless being displayed by the preview icon.

In such an event you can refresh the preview icon’s image manually in the Material Manager by selecting the Render Materials or the Render All Materials from the Function menu.

Continue …