Cinema 4D / BodyPaint 3D Program Documentation Tutorials Mechanical Modeling Tutorial Modeling with Polygon Tools
Function available in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Polygon Tool Basics and Modeling a Lamp Base

In addition to using Splines and Generator objects to model, the modification of geometry using polygon tools is also very effective. These tools can be found in the Mesh and Tools menus. Depending on the type of tool, Cinema 4D’s operating mode can play a large role in how which parameters of a particular tool are made available. For example, different parameters will be made available for the Bevel tool depending on whether you are in Use Edge Tool mode or in Use Polygon Tool mode. Other tools are only made available when in a specific mode.

Also note that many tools can be restricted to specific point, edge or polygon selections. Hence, it is often necessary to select the element to be edited before a particular tool can be used. The Select menu offers numerous selection tools for easy selection.

Standard Selection Methods

A variety of selection tools are available, depending on which part of an object you want to select. Activating the Move, Scale or Rotate tool will let you select an element in your scene by simply clicking on it. This can, however, be quite a laborious process when working with a scene with many objects. You also risk moving, scaling or rotating the element ever so slightly using this selection method, e.g., if you hold the mouse button down too long.

This is something that can’t happen when using the Live Selection tool. When selected, a selection area will be activated around the cursor. The size of this selection area can be adjusted using the Radius value in the Attribute Manager.

The Rectangle Selection tool is better suited when selecting across larger areas. A rectangle can be drawn around the desired elements by clicking and dragging in the viewport. Depending on whether the Tolerant Edge/Polygon Selection option is enabled in the Attribute Manager a selection will have to either lie completely or partially within the selection area.

Alternatively a polygon selection can also be used with which an area can be "framed” via multiple mouse clicks. The Lasso Selection tool works in a similar fashion only that you must click + drag with the mouse in the viewport.

Only Select Visible Elements

Special attention has to be paid to this option for all selection tools. If enabled, only visible elements can be selected. This means that, when making a selection in the front view, no elements on the reverse side of the object will be selected. Hence, it is important to enable or disable this option accordingly.

Set (save) Selection

Depending on the complexity of an object selecting specific regions/elements of that object can be quite a lot of work. Therefore, the Set Selection function was created to let you save (set) a selection. All you have to do is select the desired elements on the object and call up the Set Selection command from the Select menu. A new tag will automatically be created in the Object Manager next to the object. This new tag contains several options for the selection. A material or Deformation can be assigned to a particular section. We will go into detail about this in the corresponding section.

Selecting and Deleting Elements

In order to better demonstrate the most important commands and functions we will accompany our explanation with the modeling of a simple table lamp. We will start with modeling the base of the lamp, which will be created using a hemisphere. First, create a Sphere object (Create | Object | Sphere). Since we will be making this sphere editable in order to modify it we will increase its subdivision (Segments value) so it looks good when rendered close up. Set the Segments value to 71 and make it editable (c key or the Make Editable command).

Switch to the Use Point Tool mode and activate the Rectangle Selection tool. We will now delete the lower part of the sphere. Before doing so, make sure the Only Select Visible Elements option in the Attribute Manager is disabled! In the side or front view, drag the selection tool and select all relevant points to delete, as illustrated in the image below. After the points have been selected, press the Del key or Backspace key on your keyboard.

Make sure your cursor is lying over a viewport window when the Del key is pressed. If, for example, the cursor is lying over the Object Manager window the entire Sphere object will be deleted!

We have deleted all points of the Sphere object below the second row beneath its centerline. We kept the two rows of polygons below the centerline so the spherical shape can be tapered a little near the bottom.

When using the above-described method to select and delete polygons in Use Polygon Tool mode, be aware of the fact that the corner points of these polygons will not automatically be deleted as well. Points are self-contained elements within Cinema 4D. The Optimize function’s options can be used to make sure points are deleted (Tools menu: Optimize... command).

Closing Holes with N-gons

Holes created when polygons are deleted can be closed again using the Close Polygon Hole command. This is how we will close the hole at the bottom of our Sphere object. Switch to the perspective view and rotate the view so the bottom edge of the sphere is completely visible. Select the Close Polygon Hole command (Mesh menu) and place the cursor over the edge of the hole to be closed. The edge will be highlighted and the new surface will be indicated over the hole, as illustrated in the image below. A single click will then create the new surface and close the hole. As a rule this surface will be made up of a single polygon, called an N-gon.

An N-gon surface bears the advantages that it is displayed much more simplified and clearly in the Wireframe display mode and can be easily modified using polygon commands. The disadvantage to N-gons is that they are not good for use as curved 3D elements. Hence, N-gons are excellent for creating partial regions that lie entirely on a single plane.

Alternatively the Close Polygon Hole tool can be used to create triangles or quads via the Attribute Manager. Converting N-gons to triangles or quads can also be done using the Remove N-gons command (Tools menu).

Converting an N-gon to triangles or quads can also be done using the Remove N-gons command in the Mesh| N-Gons menu.

Basic Tool Settings

Many tools have parameters that can be modified interactively until the desired result is achieved. Often, if a value is modified manually, the Assign button must first be pressed before the modification takes effect. If the Realtime Update option is enabled any number of subsequent changes can be made using the active tool. Switching to a different tool or pressing the New Transform button will confirm all changes made. A tool can be applied multiple times with various settings. The interactive nature refers only to the last modification applied by a given tool.

Extrude Inner Tool

If often occurs that individual surfaces or entire polygon groups have to be scaled down, for example when tapering a profile. In such cases, the Extrude Inner tool can be used (Mesh menu). This tool can be used interactively in the viewport or via manual entries in the Attribute Manager.

Select the surface we just created to close the hole in our sphere and activate the Extrude Inner tool. Click anywhere in the Viewport and drag the mouse to the left or right to scale the selected polygon down or up. Alternatively, the Attribute Manager’s Offset value can be modified manually. As you can see, new polygons are automatically created along the edge of the selected polygon. Since the Extrude Inner tool’s N-gons option was left disabled, several small polygons were generated around our selected object. To increase the subdivision simply raise the Subdivision value.

If the Extrude Inner tool is simultaneously applied to multiple objects the Maximum Angle value will come into play. If the Preserve Groups option is enabled the selected surfaces will only then be modified as a whole if the surface angle between them is less than the Maximum Angle value. The Var. value is used to vary the Offset value when multiple surfaces are modified simultaneously.

Loop and Ring Selection Tools

Many polygon tools can be applied to more than just a single surface or edge - they can also be applied to groups of such. When selecting such rows or groups of elements the Loop Selection and Ring Selection tools can be very helpful. These tools can be found in the Select menu. After one of these tools has been selected place the cursor over an object’s edge to receive a preview of a contiguous selection. The Loop Selection tool will look for neighboring points, edges or surfaces that lie in the direction of the selected edge. The Ring Selection tool will look for parallel structures. These tools let you easily define rings or bands of points, edges or polygons that run in a circular fashion. Once you have found a selection preview that suits your needs simply click with the mouse to confirm your choice. This is illustrated in the image below, in which the Loop Selection tool was used while in Edges mode. We will use this tool to select the lower outer edge of our Sphere object. You can also use the Ring Selection in conjunction with the Move, Scale or Rotate tools by double-clicking on the desired edge loop.

The Attribute Manager offers additional settings for controlling your selection. The Stop at Boundary Edges option prohibits the tool from searching for additional elements to be selected once the preview has reached an open edge of the object. The Select Boundary Loop option limits the selection to bordering elements. Finally, the Greedy Search option forces the tool to search only for elements that lie within a spatial layer.

Trimming Edges

Practically no object in the real world has a perfectly sharp edge. The ability to add curvature to edges is why polygon primitives’ edges are so practical in the modeling process. Adding curvature to the edges of objects that have already been made editable on the other hand is more problematic. It is especially difficult to add curvature to areas with a higher subdivision or those with subordinate surfaces (e.g., those generated after a Boole object has been applied). Fortunately, our object has enough room around the edge we just selected to create a curvature. We will stay in Edges mode and select the Bevel tool from the Mesh menu. This tool is very powerful and lets you round edges and polygons, reshape them and add mitering. The Bevel tool can be adjusted interactively with the mouse or numerically using the available settings. We want to round the selected edge so leave the Bevel Mode set to Chamfer and define a Subdivision value that creates enough intermediate edges to create a rounded surface. The Offset value defines how far the edges will be moved. Leave the Shape option set to Round, which will create a simple rounded surface. You can also shape the rounded surface using splines by selecting either the User or Profile option. The Depth and Tension values can be used to control the shape and direction of the chamfering.

As long as the Bevel tool remains active you can change values as you like to achieve the desired result. As you can see in the image below, we applied a Subdivision value of 4 and an Inner Offset value of 3.5.

Normals

Even though polygons contain no thickness they do have a front and back side. In order to denote the difference, selected polygons will be colored either orange (front) or blue (back) in the viewport. A single "Normal” stands perpendicular to the surface of each polygon. A Normal is a unit vector, displayed as a short white line on active surfaces in the viewport. Cinema 4D uses these vectors to calculate, among other factors, the brightness of a given surface according to the light cast upon it, or how materials appear on that surface (materials can also be applied to the front or back of a polygon, if desired).

Normals affect the modeling process in that their orientation is taken into account by tools for moving surfaces. These include the Extrude and Bevel tools. A positive Offset value, for example, will result in surfaces being moved in the direction of the Normal.

This is why, as a rule, objects are modeled so all surface Normals face from the object surface outward, thus producing only orange-colored surfaces when selected. If you select several polygons and see that some are colored blue instead of orange you can reverse the direction of these blue polygons’ Normals by selecting Align Normals from the Tools menu. You can also select individual polygons or specific groups of polygons and apply the Reverse Normals command.

Trimming Polygons

The Bevel tools also works in Polygons mode. Switching to this mode will make other options available in the Attribute Manager. The added value is used to move the selected surfaces in the direction of their Normals. This, combined with the Offset value, which is generally used to scale selected surfaces down, results in a curved edge, as illustrated in the image below.

This curvature can be fine-tuned using the Subdivision value and reshaped via the Path curve. As is possible with the Extrude Inner tool, groups of polygons can be modified individually or contiguously, various settings can be applied and N-gon surfaces generated.

Extruding Polygons

One of the most-used tools is the Extrude tool (Mesh menu). With this tool, selected polygons can be extruded in the direction of Normals, thereby extending the object’s surface. As illustrated in the image below, we will use this method to extend the bottom of our lamp base. We will do this in Polygonsmode. The Extrude tool can be applied interactively by clicking and dragging in the viewport or its settings can be modified manually in the Attribute Manager. The Offset value defines the amount of movement (is the same as the Bevel tool’s Extrude setting). You can also add subdivision to the newly created polygons or generate N-gons, as is also possible with the Extrude Inner tool.

If you want to execute a simple extrusion, as is the case here (no Subdivisions, no N-gons, no Caps and the groups are preserved), it can be done quickly selecting the desired surfaces or edges with the Move, Scale, or Rotate tool active and performing the extrude. Simultaneously press the Ctrl/Cmd key while using the Move, Scale or Rotate tool. If the Scale tool is active the result will reflect that of the Extrude Inner tool. Generally speaking, this method of extruding is similar to the simply copy function, e.g., of objects or materials, only that it is being done with components of a given object.

If multiple polygons are extruded simultaneously the Preserve Groups option will ensure that the Maximum Angle value is taken into account in the process. Surfaces that lie at an angle to each other greater than the Maximum Angle value will then be calculated separately.

Enabling the Create Caps option will ensure that the surfaces’ original cap surfaces are maintained. This method can, for example, be used to extrude a polygon to create a cube that is closed on all sides.

Combined Extrusion

Creating new structures from a given surface is often done by combining the Extrude and Extrude Inner tools. We will use this method to create a gooseneck for our lamp base, which will later hold the actual lamp. Our Sphere object’s surface structure is very well suited for this task because it already contains a circular pole. Select the surfaces as illustrated in the image below. We will extrude these to form a cylinder at the top of the Sphere object. The radius is a little large so we will use the Extrude Inner tool to scale them down. An Offset value of 1 should do. As always it looks more realistic and simply better when curvature is used instead of hard edges.

Switch to the Bevel tool and move the surfaces to an Extrusion value of 1 in the direction of the Normals. Simultaneously, the Offset value will be automatically set to 1 as well. Finally, adjust the curve as shown in the image below.

Converting Selections

Due to their increased size, polygons are most often easy to select. Points or edges on the other hand can be much more difficult to select. Fortunately, Cinema 4D lets you easily switch between selection types. To do so, simply press the Ctrl/Cmd key when switching modes. If, for example, you have polygons selected and you want to select the corner points of these polygons instead, simply press Ctrl/Cmd + Points (icon). Alternatively you can select the Convert Selection command from the Select menu. In the dialog window that opens you have various options for converting selected elements. The original selection will be maintained - the previously selected polygons will be selected when you switch back to the Polygons mode.

Proceed as described above and switch to the Points mode for our lamp base. The reason for this is that we want to adjust the position of the points for our next modeling step.

Setting Point Values

What you probably didn’t notice after our last extrusion was the fact that the surfaces are now ever so slightly off-center. These surfaces’ Normals are pointing in a slightly tapered direction. Since our next extrusion will cover a much larger distance, this discrepancy must definitely be corrected. Otherwise the surfaces would drift farther apart the longer the extrusion is made. The image below shows a close-up of the area in question. You can clearly see how the surfaces are leaning and the raised center point (pole). Selecting the Set Point Value command (Mesh menu) will make settings available in the Attribute Manager that allow you to reposition these points. Points can, for example, be repositioned at specific coordinates, be centered on a plane or be repositioned randomly (e.g., for creating a crumpled surface - hence the Crumple options…).

In our example we will only concentrate on the Y coordinates. Therefore, select Center for the Y setting in the Attribute Manager and leave all other settings as they are. Click on the Apply button and you will see how all points now lie on the same plane and the Normals point up vertically. Now we can proceed with our next extrusion.

Continue …