--- title: "Data Exchange" url: "https://help.maxon.net/c4d/en-us/Content/html/IMPORT_EXPORT.html" section_path: "Operation > Data Exchange" description: "The ability to load and save 3D elements, animations, or even materials into native Cinema 4D or third-party formats is an essential capability of Cinema …" --- # Data Exchange The ability to load and save 3D elements, animations, or even materials into native Cinema 4D or third-party formats is an essential capability of Cinema 4D for processing data from other programs or passing data to other applications. This page presents the most important information regarding this topic. ## Importing and exporting data When using third-party formats, it may happen that the existing objects, animations or materials are modified. This affects materials in particular since each 3D software and each renderer have different philosophies for interpreting shaders, lights and cameras. The most prevalent problems occur when importing and exporting geometry since they can include vector data that is universal. This primarily affects the scaling factor of the data, the orientation of the axis system in space but also how Cinema 4D Generators are handled. You will therefore find defaults for all supported file formats under [Edit>Preferences>Import/Export](https://help.maxon.net/c4d/en-us/Content/html/PREFSIMEXPORT-PREF_IMEXPORT_MAIN_GROUP.html.md). Note also [these tips](https://help.maxon.net/c4d/en-us/Content/html/12345.html.md) for displaying imported objects in Cinema 4D. By default, however, these file settings are also displayed again each time a foreign format is imported or exported, if the options for *Show Import Dialog* or for *Show Export Dialog* are activated in the *Import/Export* section of the *program preferences*. The actual export is initiated via *File>Export*. Here you will also find a list of the supported formats.\ If you only want to save individual objects, e.g., to save a 3D model for 3D printing in the STL format, this object can be selected and used directly in the Objekt-Manager via *File>Export Selected Object As ...*. However, no materials will be included. Note that you do not have a separate import command to open supported foreign formats. Cinema 4D automatically recognizes foreign formats via .*File>Open* The same applies if you drag a file from the Explorer/Finder into Cinema 4D. This will also automatically open the respective file if it's supported. If the *Merge on Drag & Drop* option is enabled in the *Import/Export* menu of the *Preferences* menu, files that are dragged into the Cinema 4D Viewport can also be added to an open project. Alternatively you can use the *Add Project...* command in the *File* menu. ## Saving Cinema 4D files An active project can be saved as a Cinema 4D file via *File>Save Project* or *Save Project As ...*. No external components of this project such as sound files, caches, textures, etc., will be integrated into the Cinema 4D file formal and will remain at the location at which they were saved. To save such a project so it can be properly archived or opened at a different workstation, the *File>Save Project Incl Assets* should be used. This will gather the scene components in a single directory.\ If the project uses different [Takes](https://help.maxon.net/c4d/en-us/Content/html/54507.html.md), these can be saved separately using the *File>Save all Takes Incl. Assets* command. A selection of Takes can be archived using the*File>Save Marked Takes incl. Assets* command. If you only want to save individual objects, e.g., to save a 3D model for use as an external reference, this object can be selected and the *File>Save Selected Object As ...* command in the [Object Manager](https://help.maxon.net/c4d/en-us/Content/html/5743.html.md) can be applied. The same command can also be found in the *File* menu. ## Loading Cinema 4D files To load a scene in Cinema 4D file format (.c4d), you can use *File>Open Project ...* or *File>Add Project ...*. The latter can also be found in the [Object Manager](https://help.maxon.net/c4d/en-us/Content/html/5743.html.md) under *File>Merge Objects...*. If the desired project was recently saved, this file can also be opened via *File>Open Recent*. Alternatively, files can be loaded directly by dragging them from the Finder/Explorer into the Cinema 4D Viewport. ## Loading and saving materials Materials can be saved and loaded independently of other scene components. This is helpful if, for example, you save a material library and often load it to different projects. You will find the respective commands for saving materials in the [Material Managers](https://help.maxon.net/c4d/en-us/Content/html/5808.html.md) *Create* menu under *Save Materials as ...* or *Save All Materials as ...*. In the same menu you will also find the *Load Materials...* command which can be used to load the materials of a specific Cinema 4D file. Note that this includes Cinema 4D files that contain additional objects. In any case, only the materials will be loaded from these files. ## Import Substance 3D Designer materials Adobe Substance 3D Designer lets you develop parametric materials that can also be used in Cinema 4D. For this, an import function is available under *Extensions>Substance Engine*. You will find more information on this topic [on these pages](https://help.maxon.net/c4d/en-us/Content/html/55382.html.md).\ There is also a direct connection to *Adobe Substance 3D Sampler*. [On this page](https://help.maxon.net/c4d/en-us/Content/html/Substance_Connect.html.md) you will find an explanation and an example of how to use it. ## Outsourcing objects and materials. XRefs can be used if multiple persons are working on a given project or existing objects and materials should be reused in a new project. These objects create a connection to a saved Cinema 4D file and include it as a reference in the current project. All necessary commands can be found under [Create>XRef](https://help.maxon.net/c4d/en-us/Content/html/45148.html.md). If you use Redshift to render, a special [Redshift Proxy](https://help.maxon.net/c4d/en-us/Content/html/ORSPROXY.html.md) object can be used. This can also reference a saved scene with objects and materials. However, the file must be saved in the special *Redshift Proxy* format (.rs). This can be created by saving the project via *File>Export>Redshift Proxy (\*.rs)*. This saved data can then be integrated into a project via *Create>Redshift Proxy*. ## Direct software support Meanwhile, other programs belong to the MAXON family, such as **ZBrush**, or **Move by Maxon**. For these programs, separate connectivity is available, respectively, which works both ways, i.e., from the respective app to Cinema 4D and vice-versa. Compared to the classic export and import, these workflows bear the advantage that no date has to be reinterpreted or gets lost. - The *GoZ* functionality can be used to send objects directly to ZBrush and from there back to Cinema 4D. Additional information can be found [here (GoZ functions)](https://help.maxon.net/c4d/en-us/Content/html/71679.html.md) and [here (GoZ preferences)](https://help.maxon.net/c4d/en-us/Content/html/PREFSGOZ-PREFS_GOZ_GROUP.html.md). - With the *Moves by Maxon app*, movements can be captured and objects can also be scanned in three dimensions using a mobile iOS device. Cinema 4D can establish a direct connection with the mobile device and obtain data directly. [More information can be found here](https://help.maxon.net/c4d/en-us/Content/html/71881.html.md). ## Cineware Cineware is a freely available Cinema 4D technology that enables other programs to directly use the Cinema 4D data format and display textured objects. The programs that currently support Cineware directly include *Adobe After Effects*, *Adobe Illustrator,* *Vectorworks*, *ArchiCAD*, *Allplan* and the *Unreal Engine*. When exchanging information between Cinema 4D and these applications, certain rules can be established, e.g., if Generators should be converted automatically or the resolution in which shaders should be converted to bitmaps. For this you can use the *Cineware* options in the *Scene Settings* menu. *Save for Cineware...* in the *File* menu can be used to save the opened project, which can then be loaded via the Cineware application in the third party application.\ Visit [https://help.maxon.net/cw/en-us/](https://help.maxon.net/cw/en-us/) for the latest information on Cineware connections.