--- title: "Basic Properties" url: "https://help.maxon.net/c4d/en-us/Content/html/VPPREVIEWHARDWARE-ID_VIDEOPOSTPROPERTIES.html" section_path: "Render Menu > Render Setting > Viewport Renderer > Basic Properties" element_id: "VPPREVIEWHARDWARE" group_id: "ID_VIDEOPOSTPROPERTIES" description: "The Basic tab's settings define the effects should be used when the scene is rendered and the Filter tab's settings define what exactly will be shown." --- ## Basic Properties The Basic tab's settings define the effects should be used when the scene is rendered and the Filter tab's settings define what exactly will be shown. ### Effects Parameter ID: `VP_PREVIEWHARDWARE_ENHANCEDOPENGL` Use this setting to enable or disable effects in the Filter tab. Note that several effects also have settings in the Viewport's **Effects** menu (Options / Configure) that are also included by the Viewport Renderer. ### Transparency Parameter ID: `VP_PREVIEWHARDWARE_TRANSPARENCY` See [Transparency](https://help.maxon.net/c4d/en-us/Content/html/45030.html.md). ### Shadows Parameter ID: `VP_PREVIEWHARDWARE_SHADOW` ### Shadowmap Size Parameter ID: `VP_PREVIEWHARDWARE_SHADOW_MAP_SIZE` · Range: [32..4096] ### Alternative Shadow Filtering Parameter ID: `VP_PREVIEWHARDWARE_ALTERNATIVESHADOWMAPPING` Details pertaining to shadow display in the Viewport can be found under [Shadows](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md). ### Post Effects Parameter ID: `VP_PREVIEWHARDWARE_POSTEFFECT` See [Post Effects](https://help.maxon.net/c4d/en-us/Content/html/45030.html.md). ### HQ Noises Parameter ID: `VP_PREVIEWHARDWARE_NOISE` See [HQ Noises](https://help.maxon.net/c4d/en-us/Content/html/45030.html.md). Use this option to enable or disable tessellation for the respective objects (see also [Viewport Tessellation](https://help.maxon.net/c4d/en-us/Content/html/MMATERIAL-ID_MATERIALGROUP_EDITOR.html.md)). ### SSAO Parameter ID: `VP_PREVIEWHARDWARE_SSAO` Use this option to enable or disable an fast approximation of Ambient Occlusion (see also [SSAO](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md)). ### Reflections Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS` Defines whether or not reflections should be output. See [Reflection Preview](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md) for details. ### Environment Override Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS_ENV_OVERRIDE` Here you can load a texture for the sky reflection. For details see [Environment Override](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md). ### Rotation Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS_ENV_ROTATION` · Range: [HBP °] Here, the Sky object for **Environment Override** can be rotated in any direction. ### Screen-Space Local Reflections Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS_SSR` Here, a simplified object reflection can be activated. For details see [Screen-Space Local Reflections](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md). ### Distance Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS_SSR_ITERATIONS` · Range: [1..1024] This setting defines the distance to which reflections should be taken into consideration. For details see [Distance](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md). ### Pixel Thickness Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS_SSR_GEOMETRY_THICKNESS` · Range: [0..100000m] For details see [Pixel Thickness](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md). ### Half Resolution Parameter ID: `VP_PREVIEWHARDWARE_REFLECTIONS_SSR_HALF_RES` This option can be used to increase the display speed, albeit with reduced quality. For details see [Half Resolution](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md). ### Depth of Field Parameter ID: `VP_PREVIEWHARDWARE_DEPTHOFFIELD` Defines whether or not depth of field should be rendered. See [Depth of Field](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md) for details. ### Anti-Aliased DOF Parameter ID: `VP_PREVIEWHARDWARE_DEPTHOFFIELD_ANTIALIASED` Defines if the depth of field should only affect the pixels or the sub-pixels required for anti-aliasing (for details see [Anti-Aliased DOF](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW-BASEDRAW_GROUP_EFFECTS.html.md)). ### Ignore Hidden Polygon Selections Parameter ID: `VP_PREVIEWHARDWARE_IGNORE_HIDDEN_POLYGON_SELECTION` You can use [Hide Selected](https://help.maxon.net/c4d/en-us/Content/html/5651.html.md) to hide polygons that will then be hidden in the Viewport. This is often desired while working on the scene but not when the scene is rendered. If this option is enabled, these hidden selections will still be rendered (as is the case with the other renderers as well). ### 32-bit Framebuffer Parameter ID: `VP_PREVIEWHARDWARE_32BIT_DEPTH` If this option is disabled, a 16-bit frame buffer will be rendered internally, which can result in imperfections (color jumps in slowly changing color gradients, i.e., banding, among other things) in the display. In such cases it can be useful to enable this option (which will also require additional render time and graphics card memory). ### Anti-Aliasing Parameter ID: `VP_PREVIEWHARDWARE_ANTIALIASING` Depending on the graphics card and driver used, different levels of anti-aliasing are available here (see also *[Antialiasing](https://help.maxon.net/c4d/en-us/Content/html/PREFSOPENGL-PREF_OPENGL_MAIN_GROUP.html.md)*). . ### Supersampling Parameter ID: `VP_PREVIEWHARDWARE_SUPERSAMPLING` If **Transparency** is enabled, the Viewport antialiasing will not work on some systems. To make sure that the Viewport Renderer still delivers acceptable results (or if the anti-aliasing settings are not far-reaching enough), Supersampling can be used to render the respective sub-pixels. Note that higher values will slow the process down accordingly because the sub-pixels will be rendered per pixel, regardless of any transparency. Why Brute Force? Because rendering is done straightforward without any attempts to save render time. With a setting of 4x4 at 100 x 100 pixels, an image will be rendered internally at a resolution 4 times larger (i.e., 400 x 400) and will in the end be compressed to 100 x 100 via a filter. ### Copy Effects from Viewport Parameter ID: `VP_PREVIEWHARDWARE_COPY_VP_EFFECTS` There is a series of effects that can be used to influence the Viewport display quality (e.g., transparency and Shadows): You can find these in the Viewport's Options/Effects menu (or in the [Viewport Configure](https://help.maxon.net/c4d/en-us/Content/html/DBASEDRAW.html.md) menu's Filter tab. The Viewport Renderer also has these (and more) settings in its Basic menu. Click on the Copy Effects from Viewport button to copy these settings over instead of having to set them all again manually. The Basic menu's settings can be used to define the effects with which the scene should be rendered, and the Filter menu's settings define what will be shown.