--- title: "Distribution" url: "https://help.maxon.net/c4d/en-us/Content/html/OMOGRAPH_FXSCATTER-MG_SURFACE_SCATTER_DISTRIBUTION_GROUP.html" section_path: "MoGraph > Generators > Scatter Object > Distribution" element_id: "OMOGRAPH_FXSCATTER" group_id: "MG_SURFACE_SCATTER_DISTRIBUTION_GROUP" description: "In this settings section, you specify the type of distribution and the surface on which the copies are to be placed. You’ll also find all the basic …" --- ## Distribution In this settings section, you specify the type of distribution and the surface on which the copies are to be placed. You’ll also find all the basic options here for controlling, for example, the number of copies generated or the areas where they are created using maps and selections. ![Image: subgroup.gif](https://help.maxon.net/c4d/en-us/Content/Resources/Images/subgroup.gif)\ General ### Mode Parameter ID: `MG_SURFACE_SCATTER_MODE` ![Renderings of a landscape with scattered trees. On the left side the mode Area Weighted was used, on the right a simple Grid based scattering is shown.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Mode_01.png) On the left, a tree asset was distributed across a landscape using Area Weighted. On the right, the Surface Grid mode was used. Use this to select the method by which positions for the distributed objects should be determined: - *Surface Grid*: Distributes instances using a uniform grid pattern over the target surface. - *Spline Projection*: In this mode, you can use a spline along which instances are placed. This mode offers special distribution functions that are available only for spline projections. For optimal performance, the spline should be drawn or rotated so that the curve lies in the same spatial plane as the object on which the scatter distribution is to be created. For a typical landscape, for example, the spline should be drawn in the top-down view. ![Examples of using the Spline Projection mode to scatter objects along a spline on another surface.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Spline_Mode_01.png) On the left is the result of a spline projection, in which tufts of grass are placed along a Flower spline on a landscape. This highly precise placement can then be further modified using the settings in the “Variation” tab of the Scatter object (demonstrated on the right side). - *Area Weighted*: Distributes instances randomly while considering polygon surface area. As a result, smaller polygons automatically generate fewer instances than larger ones. This ensures that the density of instances remains consistent even on surfaces that contain polygons of vastly different sizes.\ This provides a natural-looking placement of the instances without any further intervention. By changing the **Random Seed** value, you can also trigger a recalculation of the random placements if you are not satisfied with the original arrangement. - *UV Grid*: Distributes instances based on the UV layout of the target object (see following examples).\ Similar to *Surface Grid*, the instances are also placed in a regular grid here; however, the spacing between the instances varies depending on the size of the UV polygons. ![Examples of using the mode UV Grid to distribute the instanced objects with the Scatter Generator.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Mode_02.png) Here are two examples of UV Grid mode. The left column shows the UV coordinates for the landscape on which the tree instances are distributed. The larger the UV polygons, the more densely the instances are placed there. With very small UV polygons, it’s also possible that no instances will be created there at all, as is the case, for example, in the circular area of the lower example. ### Spline Parameter ID: `MG_SURFACE_SCATTER_SPLINE_LINK` When using the **Mode** *Spline Projection* option, you can specify here the spline object along which the instances should be placed. To do this, simply drag the corresponding spline object from the *Object Manager* into the linking field. ### Object Parameter ID: `MG_SURFACE_SCATTER_TARGET_OBJECT` Here, assign the object on whose surface the instances are to be placed. It must therefore be an object that contains polygons. To assign it, you can simply drag the corresponding object from the *Object Manager* into this field, or click the eyedropper icon to the right of the **Object** entry and then click on the corresponding object in the *Object Manager* or directly in the *3D Viewport*. If you made a mistake, you’ll find a small drop-down menu on the right side of the linking field that allows you, among other things, to *Clear* assigned links or select linked objects and display them in the *Object Manager*. ### Selection Parameter ID: `MG_SURFACE_SCATTER_SELECTION` If you do not want to use the entire surface of the assigned object, you can link a saved polygon selection here. To do this, first create a polygon selection on the object for the areas where instances are to be placed. Then use Select > Store Selection to create a Polygon Selection Tag on the object. You can assign a custom name to this tag in the *Attribute Manager*, which is especially useful if you’re using multiple selection tags on this object. Finally, drag the *Polygon Selection Tag* from the *Object Manager* into the **Selection** field. ### Max Count Parameter ID: `MG_SURFACE_SCATTER_MAX_COUNT` · Range: [0..2147483647] This value controls the maximum number of instances that should be created. However, the actual number generated may be much lower, for example, when filters or restrictive selections are used. This is because the number of positions specified here is always calculated for the entire target object, even if only a small portion of it is to be used due to an assigned **Selection**. The advantage is that even if the assigned selection or filter settings are changed later, this does not result in new positions for the instances. The actual number of instances generated is displayed at the bottom of this settings page in the **Information** section. If the value there is lower than the one specified here under **Max Count**, you can conclude that settings on the Scatter object are reducing the originally intended number of instances. ### Random Seed Parameter ID: `MG_SURFACE_SCATTER_RANDOM_SEED` · Range: [0..10000000] The *Scatter* object also uses random calculations, for example, to place instances in *Area Weighted* **Mode**. Changing the seed value causes these random calculations to be recalculated. ### Use Defomed Points Parameter ID: `MG_SURFACE_SCATTER_DEFORMED_POINTS` If the object onto which the projection is to be made is deformed, select this option so that the actual surface can be analyzed. Otherwise, the projection will be made onto the object's original shape only, without taking the deformation into account. ### Projection Plane Parameter ID: `MG_SURFACE_SCATTER_PROJECTION_PLANE` This setting is only visible for **Mode** *Surface Grid* and allows you to select the plane onto which a perpendicular projection of the placement grid should be made. The axis pairs provided refer to the object coordinate system of the assigned **Object** and not to the direction of the world axes. ### Invert Parameter ID: `MG_SURFACE_SCATTER_PROJECTION_PLANE_INVERT` This allows you to reverse the projection direction. For example, if you use *XY* as the **Projection Plane**, the default projection is in the direction of the positive Z-axis. When the **Invert** option is enabled, this direction is reversed, and the projection is in the direction of the negative Z-axis. ### Scatter Map Parameter ID: `MG_SURFACE_SCATTER_SCATTER_MAP` ![Example of using a Vertex Map to limit the scattering area.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Scatter_Map.png) On the left is a top-down view of the landscape with a vertex map overlaid. Based on the values in this vertex map, the number of placed instances can be selectively reduced. Only areas with a vertex map value of 1 (shown here in yellow) retain the original density of instances (see right side). Using Tools > Paint Tool, you can create a vertex map by painting over the polygon object, which assigns values between 0 and 1 to each point on the surface. By default, these values are displayed in the viewport as a red/yellow color gradient, as shown in the figure above. Only the areas assigned a value of 1 (yellow) will have the original density of instances. Red areas with a vertex map value of 0 will remain free of instances. Areas with intermediate values in the vertex map will contain correspondingly adjusted numbers of instances. The information from a vertex map is stored as a tag on the object, similar to the polygon selections discussed earlier. To use the vertex map, simply drag its tag into this **Scatter Map** field. To remove an already assigned vertex map, simply delete its name from the field. Be sure to check out the **Density Map** as well, which can have a similar effect but focuses more specifically on the spacing between instances. ### Projection Axis Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_AXIS` This setting is only available in *Spline Projection* **Mode** and determines the global direction along which instances projected along the spline should be mapped onto the surface. For example, if a spline were drawn over a landscape, *-Y* would be the correct choice here, since the instances need to be shifted downward onto the landscape. Alternatively, after expanding the **Projection Axis** menu, a separate **Object** can also be used. In that case, the axis direction specified under **Projection Axis** is referenced relative to that object’s local axis system. For example, you can use a simple *Null* object here and then adjust the projection direction precisely by rotating it. ### Object Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_CUSTOM_OBJECT_LINK` Here, you can optionally assign any object whose local axis directions will then be used relative to the **Projection Axis** to project the spline shape. ### Mode Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_MODE` Here, you can choose how the instances should be placed along the spline curve. Please note that the **Max Count** setting also plays a role, as it generally defines the maximum density of instances on the surface. If the **Max Count** is set too low, it may not be possible to create all the instances specified by the **Count** or **Step** settings: - *Count*: The separate **Count** value can be used to specify the desired number of evenly spaced points along the projected spline. This means that the distances between the instances are all the same. - *Step*: In this mode, you specify the number of instances indirectly, since the **Step** value determines the desired spacing between the instances along the spline. This allows you, for example, to place streetlights or trees at equal intervals along a street. - *Random*: The positions of the instances are calculated randomly along the spline. A **Count** value is available to specify the desired number. The calculation of the positions is based on the **Random Seed** value, which can be found at the bottom of this settings page. If you change that seed value, a new random distribution of the instances will be calculated. - *Points*: In this case, instances are assigned only to the actual points of the spline being used. The sections of the curve between these vertices therefore remain unassigned. It is not possible to specify a custom number of instances. To do so, you must edit the number of points on the spline itself. ### Step Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_STEP` · Range: [0..+∞m] For **Mode** *Step* with *Spline Projection* enabled, you can specify the desired spacing between instances along the spline curve here. ### Count Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_COUNT` · Range: [0..2147483647] This setting is available only for *Spline Projection* **Mode**. Here, you can specify the desired number of instances for the *Count* and *Random* **Modes**. Always keep in mind that the upper limit on the number of instances that can be created is determined by **Max Count**. Therefore, adjust the value there accordingly if you need higher **Count** values. ### Per Segment Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_PER_SEGMENT` This option is only relevant if the spline being used (**Mode** *Spline Projection*) consists of multiple segments. In that case, you can specify for the *Count*, *Step*, and *Random* **Modes** whether the **Count** or **Step** values should apply to the entire spline or separately to each segment. For example, if **Per Segment** is enabled for the *Step* **Mode**, an instance would be placed at the first point of each segment, and the calculation of distances would begin from there. Otherwise, an instance is placed only at the starting point of the first segment, and the **Step** distance is then calculated from there across all subsequent segments. ### Range Start Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_RANGE_START` · Range: [0..100%] ### Range End Parameter ID: `MG_SURFACE_SCATTER_SPLINE_PROJECTION_RANGE_END` · Range: [0..100%] When using *Spline Projection* *Mode*, you can use this setting to limit the use of the spline curve. Only when **Range Start** is set to 0% and **Range End** to 100% is the entire spline used for placing the instances. If **Range Start** is set to 0% and **Range End** to 50%, for example, only the front half of the spline would be used. If your spline contains multiple segments, the setting of the **Per Segment** option also plays a role.\ In our example with the value pairs 0% and 50%, if we were using a spline with multiple segments, the first half of each segment would be assigned instances. ![Image: subgroup.gif](https://help.maxon.net/c4d/en-us/Content/Resources/Images/subgroup.gif)\ Density ### Density Map Parameter ID: `MG_SURFACE_SCATTER_DENSITY_MAP` This feature provides an effect similar to that of an assigned **Scatter Map**. However, rather than restricting the areas where instances are placed, it primarily controls the density of the placed instances. A vertex map can also be assigned for this purpose. Only in the areas with a value of 1 (marked in yellow) is the originally calculated density of instances retained. Surface areas with lower vertex map values receive a reduced density. The distances between the instances are therefore greater in those areas. > **Important:** **Please note:** > > An important difference between the **Scatter Map** and the **Density Map** is that a change to the **Density Map** can cause all placed instances to shift in order to adjust the distances between them as desired. A subsequent change to the **Scatter Map**, on the other hand, can only alter the visibility of instances in the affected areas. The placement of all instances remains unchanged. ![Image: subgroup.gif](https://help.maxon.net/c4d/en-us/Content/Resources/Images/subgroup.gif)\ Relax ![Example of scattered instances on a landscape object. On the left is the original placement, on the right the resulting placement after some Relax iterations.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Relax.png) On the left, you can see a dense distribution of spheres across a landscape, distributed using the Area Weighted method. The right side shows the result after new positions were determined using **Relax**. These settings can be used to influence the initial placement of the instances by adjusting the calculated positions to create more harmonious spacing between them. This makes it possible, for example, to reduce overlaps and intersections even when instances are placed close together. The original number of instances remains unchanged. ### Relax Parameter ID: `MG_SURFACE_SCATTER_RELAX_ENABLE` Enable this option to make the original placements of the instances more harmonious. This can be particularly useful for the *Area Weighted* **Mode**, in which positions on the surface are determined randomly rather than in a regular grid. ### Relax Distance Parameter ID: `MG_SURFACE_SCATTER_RELAX_DISTANCE` · Range: [0..+∞%] This percentage value controls the radius within which the original positions are evaluated. The larger the radius selected, the more evenly the newly determined positions can be calculated. However, this also results in a correspondingly greater change to the original placement. Please note that the intensity of the effect also depends significantly on the number of **Relax Iterations**. ### Relax Iterations Parameter ID: `MG_SURFACE_SCATTER_RELAX_ITERATION_COUNT` · Range: [0..2147483647] When relaxing the instance positions, you can imagine the original distances between them as small springs that either push the instances away from each other or pull them toward each other. Since the goal of the *Relax* function is to achieve the most homogeneous distribution possible of the distances between the instances, these pushing and pulling forces must be brought into equilibrium. This requires several computational passes—known as *Iterations*. More iterations lead to more uniform and precise placements, but also take correspondingly longer to compute. ### Remove Ovelapping Parameter ID: `MG_SURFACE_SCATTER_RELAX_REMOVE_OVERLAPPING` ![Example of scattered instances on a landscape object. On the left is the original placement, on the right the resulting instance distribution after intersections have been removed.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Remove_Overlap.png) On the left, you can see a dense distribution of spheres across a landscape, distributed using the Area Weighted method. To the right of that is the result after removing the instances that fall short of a certain minimum distance from their neighbors. This function removes instances that have been placed too close together and can therefore reduce visible overlaps and collisions between the instances. No actual collision calculation takes place; instead, the following distance value is used for this purpose. Since the detected instances in an overlap are deleted, the original number of instances is reduced accordingly.\ The number of remaining instances can be found in the **Information** section at the bottom of this settings page. ### Overlap Threshold Parameter ID: `MG_SURFACE_SCATTER_RELAX_REMOVE_OVERLAP_DISTANCE` · Range: [0..+∞m] This is the smallest distance between adjacent instances that is still permitted. If two instances are closer together than this, one of them is removed. ![Image: subgroup.gif](https://help.maxon.net/c4d/en-us/Content/Resources/Images/subgroup.gif)\ Display ### Viewport Mode Parameter ID: `MG_SURFACE_SCATTER_VIEWPORT_MODE` ![Comparing the available display options for the viewport offered on a Scatter Generator.](https://help.maxon.net/c4d/en-us/Content/Resources/Images/2027-0_Scatter_Generator_Display_Options.png) From left to right: Points, Bounding Boxes and Objects displayed in the 3D viewport. This mode determines how the distributed instances are displayed in the viewport. Especially when working with a large number of instances, the simplified dot or bounding box representation can help you continue to work smoothly in the editor while still getting a sense of the density and placement of the instances. During rendering, the complete instance geometries are always visible. - *None*: The distributed instances remain invisible in the viewport. This ensures that the object on which the instances were placed remains fully visible, and interaction in the viewport is minimally impacted. This mode is useful if you have already verified the placement and density of the instances in the other modes or through test renders, and therefore do not need to see the instances displayed continuously in the editor. - *Points*: The positions of the instances are indicated by small dots. Since no other geometry is displayed, this mode has only a very minor impact on interactivity in the editor. However, the orientation or size of the instances cannot be viewed in this mode. - *Bounding Box*: Instances are represented by simple cubes that reflect their maximum dimensions. This allows you to examine the placement, orientation, and dimensions of the instances without having to display their full geometry. - *Object*: The full geometrie of the instances is drawn. This mode therefore has the greatest impact on the drawing speed in the viewport. > **Note:** **Good to know:** > > The *Scatter* object also responds to the **Level of Detail** setting, which you can find in the Viewports Options menu. There, you can choose between *Low*, *Medium*, and *High*. Only the *High* setting displays the full number of instances in the viewport. At the other levels, only a fraction of all instances is displayed. > > For even more control over the level of detail, you can also assign a [Display](https://help.maxon.net/c4d/en-us/Content/html/TDISPLAY.html.md) tag to the *Scatter* object via Tags > Render Tags > Display in the *Object Manager* and enable the **Level of Detail** option there. You'll find a percentage value there that lets you specify exactly how many instances you want to display in the viewport. ![Image: subgroup.gif](https://help.maxon.net/c4d/en-us/Content/Resources/Images/subgroup.gif)\ Information ### Total Count: Parameter ID: `MG_SURFACE_SCATTER_INFO_CLONE_COUNT` Here you will find the actual number of instances displayed. This number may be lower than the specified **Max Count** because viewport display options, such as *Level of Detail* or the use of a **Scatter Map**, can reduce the originally specified number of instances.