Referenz Cinema 4D Cinema 4D Prime Pipeline-Menü Substance
Funktion verfügbar in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Substance Asset Manager

Der Substance Asset Manager enthält und verwaltet alle geladenen Substances als Assets. Sie können hier Listeneinträge per Drag&Drop verschieben und auf die gewohnte Art selektieren (Ctrl/Cmd, um einzelne Einträge zur Selektion hinzuzufügen bzw. davon auszunehmen, Shift um ganze Bereiche zu selektieren, Entf., um diese dann zu löschen). Per Doppelklick auf einen Asset-Namen kann das entsprechende Asset umbenannt werden.

Assets können per Drag&Drop aus dem Asset-Manager hierhin gezogen werden (dabei werden automatisch nötige Verknüpfungen erstellt):

Bei Erstellen von Materialien über Drag&Drop wird jeweils ein Material gemäß dem hier beschriebenen Auto-Modus erzeugt.

Assets können aus dem Asset-Manager in eine Preset-Bibliothek gezogen werden (die Substance-Datei wird dabei mit gespeichert) und von da aus auch wieder in den Asset-Manager geladen werden.

Beim Selektieren von Assets werden deren Eigenschaften im Attribute-Manager (dieser hat einen eigenen Anzeigemodus für Substances) angezeigt.

Sie finden links neben dem Asset-Namen eine Aktivierungsbox. Hiermit können Sie das entsprechende Asset mit seinen aktuellen Einstellungen einfrieren. Das ist dann sinnvoll, wenn Sie mit der Szene arbeiten und sie verhält sich aufgrund von Substance-Engine-Berechnungen zu langsam (haben Sie z.B. animierte Asset-Parameter und arbeiten mit der Zeitleiste, müssen bei jedem Bilderwechsel alle Asset-Texturen neu berechnet werden, was sich zu einer zähen Angelegenheit entwickeln kann; deaktivieren Sie dann die Assets).

Ist ein Asset deaktiviert, können Sie zwar seine Parameter ändern und diese werden auch gespeichert, allerdings werden diese erst dann zur Substance-Engine weiter gereicht, wenn Sie sie wieder aktivieren.

Beachten Sie, dass Sie zum Rendern (besonders bei Asset-Parameteranimationen) diese Assets wieder aktivieren.

Rechts neben den Asset-Namen finden Sie eine Vorschau der Texturen, die Sie im Attribute-Manager auch in größerer Auflösung betrachten können.

Durch Klick auf die Spaltenüberschriften kann die Liste alphabetisch geordnet werden (in diesem Fall können die Listeneinträge nicht mehr per Drag&Drop verschoben werden). Erneute Klicks sortieren in die andere Richtung bzw. stellen die Sortierung wieder ab.

Datei-Menü

Lade Substance...

Hiermit laden Sie ein neues Asset in Cinema 4D (alternativ können Sie auch entsprechende Dateien per Drag&Drop in den Substance Asset Manager ziehen). Eine entsprechende Substance-Datei muss die Dateiendung *.sbsar aufweisen. Je nach Substance-Engine-Voreinstellung wird wird dann auch direkt ein verknüpftes Material erstellt.

Für relative und absolute Pfade des Substance-Dateien gilt ebenfalls das hier beschriebene.

Substances aus Verzeichnis laden...

Mittels dieses Befehl können Sie Substance-Assets eines ganzen, auswählbaren Verzeichnisses (ohne darin enthaltene Unterverzeichnisse) laden.

Substances neu laden

Haben Sie eine Datei mit Assets geöffnet und eine der Substances wird im Substance Designer geändert und publiziert, so rufen Sie diesen Befehl auf, um die Substances neu zu laden.

Bearbeiten-Menü

Ausschneiden

Diese Funktion entfernt die selektierten Elemente und kopiert sie in die Zwischenablage. Die Elemente können mit der Funktion Einfügen wieder aus der Zwischenablage zurückgeholt werden.

Kopieren

Diese Funktion kopiert die selektierten Elemente in die Zwischenablage. Von dort kann die Kopie beliebig oft mit der Funktion Einfügen zurückgerufen und ins Projekt eingefügt werden.

Einfügen

Diese Funktion fügt die in der Zwischenablage abgelegten Elemente in das Dokument ein.

Hinweis
Bei dem aktiven Dokument muss es sich nicht notwendigerweise um dieselbe Szene handeln, aus der das Objekt ursprünglich stammt.

Löschen

Hiermit löschen Sie die selektierten Assets. Alternativ können Sie auch die Entf.-Taste drücken.

Unbenutzte Substances löschen

Dieser Befehl löscht alle Substances, mit denen kein Material verknüpft ist.

Alles selektieren

Hiermit werden alle geladenen Assets selektiert.

Alles deselektieren

Dieser Befehl deselektiert alle Assets.

Von aktiven Materialien selektieren
Von markierten Materialien selektieren

Diese Funktion selektiert alle Assets, deren verknüpfte Materialien im Material-Manager selektiert bzw. markiert (markierte Materialien sind mit einem gelben Rahmen versehen, d.h. ihr zugehöriges Objekt ist selektiert) sind.

Von aktiven Objekten selektieren

Hier werden alle Assets selektiert, die per Material den selektierten Objekten zugewiesen sind.

Selektiere Materialien
Selektiere Objekte

Hiermit selektieren Sie alle Materialien bzw. Objekte, die mit den aktuell selektierten Assets verknüpft sind.

Alle aktivieren
Alle deaktivieren

Hiermit können sämtliche Assets aktiviert bzw. deaktiviert werden. Was das bedeutet finden Sie hier erklärt.

Programm-Voreinstellungen...

Rufen Sie hiermit die Substance-Engine-Voreinstellungen auf.

Erzeugen-Menü

Erzeuge Standardmaterialien

Voreinstellungsgemäß wird beim Erstellen eines Assets das zugehörige Cinema 4D-Material nach folgender Zuordnung gleich mit erstellt:

Substance AusgabekanalCinema 4D Materialkanal
Diffuse Farbe
Basecolor * Farbe
Emissive Leuchten
Reflection Reflektivität
Environment Umgebung
Bump Relief
Opacity Alpha
Specular Reflektivität/Glanzlicht - Standard
Height Displacement
Normal Normale
Ambient Occlusion Diffusion

* Falls kein Diffus-Ausgabekanal existiert oder wenn der Befehl Erstelle metallische Materialien aufgerufen wird.

Sie können mit diesem Befehl jederzeit ein neues Material mit den erwähnten zugewiesenen Kanälen erzeugen.

Erstelle metallische Materialien
Erstelle glänzende Materialien

Substance Designer geht grundsätzlich von 2 Methoden aus, wie physikalisch basiertes Rendering, Texturen betreffend, auszusehen hat.

Zum einen gibt es, wie Substance Designer das nennt, den Metallic/Roughness-Workflow, der mindestens die charakteristischen Ausgabekanäle (Texturen) "Base color", "Metallic" und "Roughness" aufweist.

Der andere ist der Specular/Glossiness-Workflow, der mindestens die charakteristischen Texturen "Diffuse", "Glossiness" und "Specular" bereitstellt.

Beide Workflows vertrauen auf Funktionalitäten, die der Cinema 4D Reflektivitäts-Kanal bereit stellt.

Die beiden Befehle Erstelle metallische Materialien und Erstelle glänzende Materialien laden zusätzlich zu den bei Standardmaterialien beschriebenen Ausgabekanälen folgende:

Damit wird gewährleistet, dass das gerenderte Ergebnis möglichst ähnlich (identische Ergebnisse sind eher selten zu erwarten) zu denen des Substance Designers gerät. Sehen Sie diese Aufteilung durchaus als Startpunkt an, von dem ausgehend Sie weiter arbeiten. Beispielsweise können Sie, wie schon unter Weitere Unterschiede zum alten System erwähnt, den Farb-Kanal deaktivieren.

Duplizieren

Duplizieren Sie hiermit die selektierten Assets.

Duplizieren mit Materialien

Duplizieren Sie hiermit die selektierten Assets samt zugehörigen, verknüpften Materialien.

Preset-Menü

Die hier aufgeführten Befehle gelten nicht für die Cinema 4D Content Browser Presets, sondern sind Substance Asset Presets (das sind Dateien mit der Endung *.sbsprs). Es handelt sich dabei um Parameter-Presets, die sowohl von Substance Designer als auch von Cinema 4D erzeugt werden können. Sie können damit Asset-Einstellungen zwischen verschiedenen Applikationen transferieren ohne deren spezifisches Dateiformat laden zu können/müssen.

Am sinnvollsten ist dabei natürlich die Verwendung von Presets mit den dazu passenden Assets. Aber keine Sorge, auch "artfremde" Presets werden verarbeitet:

Substance Preset zuweisen

Weist ein Substance Preset allen selektierten Assets zu. Parameter, die nicht im Preset enthalten sind, werden auf den voreingestellten Wert zurück gesetzt. Befinden sich unter den selektierten Assets Multi-Graphen, wird ein Dialog zum Auswählen des Graphen eingeblendet. Parameter im Preset, die nicht im Asset enthalten sind, werden ignoriert.

Substance Preset hinzuladen

Weist ein Substance Preset allen selektierten Assets zu. Hierbei werden allerdings alle Asset-Parameter, die nicht im Preset enthalten sind, unverändert gelassen. Parameter im Preset, die nicht im Asset enthalten sind, werden ignoriert.

Exportiere Substance Preset

Hiermit exportieren Sie für jedes selektierte Asset eine Preset-Datei. Es werden dabei nur von den voreingestellten Werten abweichende Parameter rausgeschrieben.

Festplatten-Cache-Menü

Beim Laden einer Szene müssen zunächst alle Asset-Texturen neu erzeugt (und im RAM abgelegt) werden. Je nach Anzahl und Texturauflösung kann das sehr lange dauern. Um diesen Vorgang abzukürzen, können die Texturen per Befehl in einem Verzeichnis "substance_cache" am Szenenspeicherort abgelegt werden.

Je nach Texturauflösung können diese Texturen sehr viel Speicherplatz beanspruchen (Tip: in den Substance-Engine-Voreinstellungen kann die Texturen-Erzeugung mittels komprimierter PNG oder JPEG-Bitmaps definiert werden)!

Hinweis:
Die Verwendung des Festplatten-Caches kann zu unerwarteten/falschen Ergebnissen führen, wenn ein Substance Asset beispielsweise von Substance Designer geändert wurde (Sie sollten dann den Befehl Substances neu importieren (Datei-Menü) aufrufen. Passen Sie außerdem mit dem vorübergehenden Deaktivieren des Festplatten-Caches in den Programmvoreinstellungen auf. Auch dabei kann die Synchronisierung von Einstellungen und Cache verloren gehen.

Selektierte cachen

Hiermit cachen Sie alle selektierten Substances.

Alle geänderten cachen

Hiermit werden nur gegenüber den gecachten Assets geänderte Texturen zwischengespeichert (bei Parameteränderungen werden aktualisierte Texturen nicht automatisch zwischengespeichert).

Alle cachen

Hiermit werden die Texturen aller Assets nach einer Sicherheitsabfrage zwischengespeichert.

Cache für Selektierte löschen
Cache für alle löschen

Mittels dieser beiden Befehle können die zwischengespeicherten Texturen (allerdings nur für das in den Voreinstellungen definierte Dateiformat) für die selektierten bzw. alle Substances gelöscht werden.