Cinema 4D/BodyPaint 3D Programmdokumentation Referenz Cinema 4D Cinema 4D Prime
Funktion verfügbar in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Mesh-Menü

Allgemeines

Die Funktionen aus dem Mesh-Menü beziehen sich überwiegend jeweils auf die in der Ansicht selektierten Elemente (Punkte, Kanten, Polygone) von den im Objekt-Manager aktiven Objekten. Dazu müssen die zu bearbeitenden Objekte polygonal sein (wandeln Sie Grundobjekte mit dem Befehl Grundobjekte konvertieren um; Menü Mesh / Konvertieren). Untrügliches Zeichen dafür, dass ein aktiviertes Objekt polygonal ist: Im Struktur-Manager werden Punkte bzw. Polygone listenmäßig angezeigt.

Die allermeisten Werkzeuge sind daher auch nur in den entsprechenden Modi zugänglich (Werkzeuge-Menü: Modus/Punkte, Kanten, Polygone).

Für die meisten Werkzeuge gilt darüber hinaus: Sind keine Elemente selektiert, wirkt das Werkzeug auf alle Elemente der im Objekt-Manager selektierten Objekte. Versteckte Elemente (siehe Selektierte verbergen) werden dabei größtenteils nicht modifiziert. Einige Werkzeuge wie Messer, Bevel usw. können ohne vorherige Selektion direkt ein Element (z.B. eine Kante) "greifen" und bearbeiten.

Cinema 4D ist dabei intelligent genug, zu erkennen, welche Werkzeuge in welchen Modi nicht funktionieren. Diese werden dann ausgegraut und sind somit nicht anwählbar.

Das Bearbeiten von mehreren Objekten gleichzeitig ist möglich. So ist es z.B. kein Problem, 2 selektierte Polygone auf zwei verschiedenen Polygon-Objekten gleichzeitig zu extrudieren. Dazu müssten Sie zuerst beide Polygon-Objekte im Objekt-Manager selektieren, dann die zu extrudierenden Polygone auswählen und schließlich das Extrudieren-Werkzeug aufrufen.

Hinweis:
Für alle Werkzeuge, die eine Option haben, mit der man die Wirksamkeit auf unsichtbare Elemente ausschalten kann (z.B. Messer), gibt es im Befehle-anpassen-Manager einen Befehl namens Wechseln Nur Sichtbare. Verleihen Sie diesem Befehl ein Tastaturkürzel, um die Option für das aktuelle Werkzeug kurz und schmerzlos jeweils in das Gegenteil zu verwandeln.

Bei den interaktiven Werkzeugen kann, solange die Maustaste noch gedrückt ist, mittels Druck der "Escape"-Taste die gerade vorgenommene Manipulation zurück genommen werden.

Sie können auch verschiedene Objekttypen miteinander agieren lassen. So können Sie Spline- und Polygonpunkte gleichzeitig verschieben oder einen Splinepunkt mit Hilfe des Verschmelzen-Werkzeuges mit einem Polygonpunkt verschmelzen (die beiden Punkte werden dann deckungsgleich gemacht).

Die meisten Werkzeuge funktionieren interaktiv. Darüber hinaus haben viele Werkzeuge einstellbare Parameter im Attribute-Manager. Hierfür gilt: Solange das Werkzeug aktiv ist, können alle Parameter/Optionen verändert und deren Auswirkungen in Echtzeit in der Ansicht beobachtet werden. Sie müssen also nicht irgendwelche Dialoge quittieren, die den Workflow unterbrechen.

Hinweis:
Beachten Sie auch die Sculpting-Pinsel, die auch auf ganz normale Polygonmeshes wirken (ohne spezielle Sculpting-Unterteilung).

Das Arbeiten mit Tastaturkürzeln beim Modellieren

Ein typischer Arbeitsablauf ist beispielsweise der Folgende:

Sie wählen einige Polygone aus, bearbeiten diese mit dem Extrudieren- Werkzeug, wechseln zurück zur Selektion und wählen die nächsten zu bearbeitenden Polygone aus.

Im Zusammenhang mit Tastaturkürzeln kann das auf 2 verschiedene Arten erledigt werden. Zuerst die althergebrachte Methode (bei Cinema 4D-Versionen <13):

Das Mesh-Kontextmenü

Je nach definiertem Modus (Punkte, Kanten, Polygone) erscheint beim Rechtsklick auf ein Objekt ein kontext-sensitives Menü, das aus diversen Befehlen des Mesh-Menüs besteht.

Befehlsoptionen

Einige Befehle (überwiegend aus den Mesh-Menüs) haben mehrere Optionen. Oft ist es störend, wenn diese bei jedem Befehls-Aufruf erscheinen. Dafür gibt es das oben markierte Icon im Menü rechts neben einem solchen Befehl. Beim Klick darauf erscheinen die Befehlsoptionen, die dann definiert werden können und dann bei JEDEM Befehlsaufruf berücksichtigt werden.

Im Befehle-anpassen-Manager gibt es eine Option, mit der Sie festlegen, ob beim Befehls-Aufruf (nur über Tastaturkürzel) das eben beschriebene Prinzip oder das altgewohnte (<Cinema 4D R13; Einblenden der Optionen bei jedem Aufruf) Verhalten zum Einsatz kommt.

RELEASE 20

Generell gibt es einige, kleinere Neuerungen im Bereich des Modellieren:

  • Optimierungen beim Speicherbedarf, Geschwindigkeit
  • Optimierungen beim Löschen von N-Gon-Punkten
  • Der Umgang mit UV-Koordinaten beim Pose-Morph-Tag im Zusammenhang mit den Befehlen Normalen ausrichten und Normalen umdrehen wurde verbessert
  • Einige Grundobjekte (Kugel, Pyramide, Platonischer Körper) haben keine UV-Poygonüberlappungen mehr. Beim Laden alter Objekte gibt es einen Button, mit dem Sie auf das neue Verhalten umschalten können.
  • Bei einigen Werkzeugen (Extrudieren, Matrix-Extrude, Innen extrudieren) wurden Dinge wie UV-Interpolation und Werteverteilung für neu erzeugte Punkte bei Tags (z.B. Vertex-Farbe) verbessert.
  • Beim Arbeiten mit dem Struktur-Manager gibt es jetzt Automatismen, die den richtigen Komponentenmodus aufrufen.

Hand-, Kopf- und Figurmodelle der untergeordneten Abschnitte © Bunk Timmer.