Cinema 4D/BodyPaint 3D Programmdokumentation Referenz Cinema 4D Cinema 4D Prime Bild-Manager
Funktion verfügbar in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Datei-Menü

Öffnen...

Hiermit können Sie alle von Cinema 4D lesbaren Bild- und Videoformate in den Bild-Manager einlesen. Selbst Videos mit Sound sind möglich.

Alternativ können Bild- und Videodateien per Drag&Drop außerhalb von Cinema 4D bzw. aus dem Content Browser hineingezogen werden.

Bei der Auswahl eines Bildes einer Bildsequenz (also Bilder, deren Dateinamen durchnummeriert sind, s. Name) über Öffnen wird noch ein kleiner Dialog vorgeschaltet:

Typ

Sie können hier entscheiden, ob die gesamte Bildsequenz bzw. Teile davon (Animation) oder nur ein einziges (Einzelbild) geladen werden soll.

Pixelverhältnis

Beim Einladen von Bildsequenzen, die selbst kein normales, quadratisches Pixelverhältnis haben (solcherlei Informationen sind normalerweise nicht in den Dateien selbst enthalten), können Sie ein solches hier einstellen. Wenn Sie dann im Bild-Manager unter Hauptmenü: Ansicht die Option Pixelseitenverhältnis anzeigen auswählen, werden die Bilder passend verzerrt.

Von/bis

Wenn Sie bei Typ Animation ausgewählt haben, können Sie hier genau festlegen, welcher Bildbereich geladen werden soll.

BPS

Wenn Sie bei Typ Animation ausgewählt haben, geben Sie mit diesem Wert die Bilderrate vor, mit der die Sequenz im Bild-Manager abgespielt werden soll.

Funktion verfügbar in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D
Speichern als...

Mittels dieses Befehls werden einzelne Bilder oder auch komplette Bilderfolgen (je nachdem, was Sie im Tab "Verlauf” selektiert haben) abgespeichert. Der Bild-Manager kann somit auch als Videokonvertierungswerkzeug verwendet werden, mit dem Sie Videos in anderen Auflösungen, Codecs und Formaten speichern können. Anamorphe Videos werden ebenfalls unterstützt.

Bei Aufruf des Befehls öffnet sich ein Dialog, wo Sie weitere Einstellungen vornehmen können.

Beachten Sie, dass beim Abspeichern von Videos diese mit sog. "Codecs" (z.B. H.264) komprimiert werden, worunter zwangsweise die Bildqualität leidet. Im professionellen Bereich werden Animationen daher meist als unkomprimierte Einzelbildfolge (z.B. TIFF) herausgerendert und als Grundlage für die weitere Bearbeitung in Videokompositionsprogrammen (z.B. Adobe After Effects etc.) eingeladen. Diese Programme beherrschen meist ausgefeiltere Videokompressionsmethoden (z.B. "2-Pass-Verfahren") um optimale Videoqualität zu erzeugen (von der Fähigkeit, durch Multi-Pass-Verarbeitung weit reichende Manipulationsmöglichkeiten der verschiedenen Rendereffekte wie Schatten, Schärfentiefe etc. zu haben, mal ganz abgesehen).

Dieser Workflow hat außerdem den Vorteil, dass Sie die gerenderte Sequenz nach wie vor unkomprimiert in bester Qualität vorliegen haben und Sie auch verschiedene Codecs mit dem Originalmaterial ausprobieren können (bereits komprimierte Videos mit anderen Codecs erneut abzuspeichern, ist aus Qualitätsgründen nicht zu empfehlen).

Als Faustregel:

  • Sollen Animationen in Drittprogrammen weiterverarbeitet werden, so speichern Sie in unkomprimierten Einzelbildfolgen (oder als Video ohne Kompressionscodec, wobei sich allerdings riesige Videodateien ergeben).
  • Zu Testzwecken oder bei keiner nachfolgender, weiterer Bearbeitung können Sie einen verlustbehafteten Videokompressionscodec verwenden.

Typ

Je nachdem, was Sie im Tab "Verlauf” selektiert haben, erhalten Sie folgende Auswahlmöglichkeiten:

Einzelbilder

Hierbei wird nur ein einziges Bild gespeichert (unabhängig davon, wie viele Bilder/Sequenzen Sie im Verlauf selektiert haben).

Animation

Sofern Sie mindesten 1 Bild bzw. Verzeichnis einer Bildersequenz (also keine Einzelbilder) im Verlauf ausgewählt haben, ist diese Option auswählbar. Sie geben dann mittels der Parameter "Von" und "bis" den Bildbereich der Sequenz an, der als Animation gespeichert werden soll.

Ausgewählte Bilder

Diese Option speichert die selektierten Bilder (egal, ob Einzelbilder, komplette Bildsequenzen oder die Bilder ausgewählter Verzeichnisse) als Animation (also mit fortlaufend nummerierten Dateinamen in Falle von Bilderfolgen) ab.

Format/Optionen

Wählen Sie hier ein Bild- oder Videoformat aus. Details zu diesen Formaten und deren Einstellungen finden Sie im Anhang.

Farbtiefe

Siehe Farbtiefe.

Name

Siehe Name.

Stereo

In den Rendervoreinstellungen können im Tab "Stereoskopie" für ein stereoskopisches Bild fogende Bilder gerendert werden:

  • linke Kamerasicht (Einzelkanal 1)
  • rechte Kameransicht (Einzelkanal 2)
  • daraus generiertes stereoskopisches Bild (Kombiniertes stereoskopische Bild)
  • Monobild (Monobild)
  • beliebig viele Kameransichten zwischen linkem und rechtem Kameraauge (Einzelkanal X).
  • zusätzlich gibt es im Tab "Stereoskopie" die Option Interaktives Kombinieren, die dann hier ebenfalls gewählt werden kann.

Das sind eine ganze Anzahl Ansichten (die es dann logischerweise jeweils für jedes Bild einer Animation gibt). Je nachdem, welche dieser Ansichten Sie abspeichern wollen, kann das hier ausgewählt werden (voreingestellt ist die im Tab "Stereoskopie" ausgewählte Option).

Von bis

Sollten Sie bei Typ Animation definiert haben, kann hier der Bildbereich angegeben werden, der abgespeichert werden soll.

BPS

Hiermit geben Sie die Bilderrate der als Video abzuspeichernden Bilderfolge an.

Zurücksetzen

Setzt die Speichereinstellungen Format, Farbtiefe und BPS auf die entsprechenden Werte der im Verlauf vorhandenen Bilder zurück, d.h. beim anschließenden Speichervorgang werden keine Bilder umgerechnet, da das Speichern in unverändertem Format/Farbtiefe geschieht.

DPI

Siehe Auflösung.

Ebenen

Diese Option ist nur bei vorhandenen Ebenen bzw. ebenenfähigen Bildformaten wie PSD, B3D oder TIF auszuwählen.

Bei aktivierter Option werden stets alle vorhandenen Ebenen (Multi-Passes, Alpha-Kanäle etc.) gespeichert.

Ist die Option deaktiviert, passiert je nachdem, was im Tab "Ebenen" aktiviert ist:

  • Bild bzw. Multi-Pass: das auf eine Ebene reduzierte Bild wird gespeichert.
  • Einfacher Pass: Es wird ausschliesslich die selektierte Ebene gespeichert.

Alpha-Kanal

Sollte das zu speichernde Bild einen Alphakanal enthalten, entscheidet diese Option, ob er beim Speichern mit abgelegt wird oder nicht.

Sound

Beim Speichern in ein Videoformat definiert diese Option, ob die Soundspur dem Video mitgegeben werden soll. Das funktioniert natürlich nur, wenn eine Bildsequenz inkl. Sound vorliegt. Dafür gibt es 2 Wege:

  • Sie laden ein Video samt Sound in den Bild-Manager ein.
  • Sie rendern eine Animation inkl. Soundspur.

Die Bilderrate muss dabei genau der ursprünglichen Bilderrate entsprechen, ansonsten kann kein Sound abgespeichert werden.

AB Vergleich speichern

Wenn AB Vergleich aktiviert ist und Sie 2 Bilder zum Vergleichen markiert haben, kann dieses Vergleichsbild, wie es im Bild-Manager angezeigt wird, auch als Bilddatei abgespeichert werden. Bilder mit mehreren Ebenen werden dabei auf eine reduziert.

Filter

Sollte im Tab "Filter" ein Filter aktiviert sein, so sorgt diese aktivierte Option dafür, dass der Filter auch auf die zu speichernden Bilder angewendet wird. Bei deaktivierter Option bleibt der Filter unberücksichtigt.

Beachten Sie, dass der Filter nur auf das gerenderte Originalbild wirkt und nicht auf evtl. vorhandene Multi-Passes. Da die Multi-Passes dann auch nicht mehr zum Bild passen, werden diese weggelassen.

Skalieren

Möchten Sie Bilder in einer anderen Auflösung oder Pixelverhältnis abspeichern, so können Sie diese Option aktivieren.

Ursprüngliches Pixelbreiten/-höhenverhältnis beibehalten

Ist diese Option aktiviert, werden Höhe bzw. Breite proportional geändert. Sie können also nicht nur die Höhe bei gleichbleibender Breite ändern.

Pixelbreite/-höhe

Geben Sie hier die Auflösung der auszugebenden Bilder in Pixel an.

Seitenverhältnis
Anzeige Breite/Höhe

Normalerweise beträgt das Seitenverhältnis 1, womit das Bild bzw. Video in der Ursprungsauflösung angezeigt wird. Für z.B. anamorphe Videos kann hier ein anderer Wert eingetragen werden. Steht hier z.B. 2, wird ein Video in 800x600 Pixeln Originalauflösung verzerrt abgespielt, nämlich in 1600x600 Pixeln (diese Information wird dann bei Anzeige Breite/Höhe eingeblendet).

Warnfeld

In diesem Feld erscheinen Warnungen, wenn z.B. ein Videoformat nicht kompatibel zum eingestellten Bildverhältnis ist (in diesem Fall wird der Export übrigens fehlschlagen oder Cinema 4D ändert selbstständig die Pixelabmaße zum nächsten, möglichen Wert; das wird ebenfalls dort angegeben).

Rendern abbrechen...

Mit diesem Befehl wird die aktuelle Bild-/Animations-Berechnung abgebrochen. Evtl. Bild-Teilberechnungen bleiben erhalten, es kann allerdings nicht exakt an dieser Stelle weiter gerechnet werden. Ein Bild muss immer als ganzes neu berechnet werden.

Das Schliessen des Bild-Managers hat übrigens nicht zwangsweise einen Abbruch des Rendervorggangs zur Folge. Nach einer Sicherheitsabfrage kann im Hintergrund weiter gerendert werden, ohne dass der Bild-Manager geöffnet oder sonst ins Layout eingeklinkt sein muss.

Zuletzt geöffnete Dateien

Sie finden hier eine Liste der zuletzt im Bild-Manager geladenen Bilder inkl. Speicherpfad.