NEU IN R20

Referenz Cinema 4D Cinema 4D Prime Material-Manager Material-Nodes
Funktion verfügbar in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Der Material-Node-Editor

Allgemeines

Der Node-Editor ist die zentrale Instanz beim Erstellen und Bearbeiten von Material-Nodes (im Folgenden einfach "Nodes" genannt). All das, was Sie in der Node-Ansicht sehen, muss mit einem Node-Material (beachten diesen Hinweis) verknüpft sein, d.h. um Nodes erzeugen und bearbeiten zu können, muss ein Node-Material selektiert sein. Der Node-Editor zeigt stets das aktuell selektierte Node-Material an.

Es sei zu Beginn darauf hingewiesen, dass Nodes eine nicht ganz unkomplizierte Materie sind und in ihrer ganzen Breite nur mit einem guten Maß an Wissen über Shading- und Rendertechnik allgemein genutzt werden können. Allerdings sind viele Dinge auch ziemlich simpel, indem Sie z.B. eines der vorgefertigten Materialien, wie z.B. das Übermaterial verwenden, das Sie fast so einfach wie ein herkömmliches Material bedienen können (und trotzdem z.B. einen einzigen Bild-Node in diversen Materialkanälen verwenden).

Der allgemeine Datenfluss ist immer von links nach rechts. Ganz rechts mündet alles immer im Material-Node (ohne Material-Node kein funktionierendes Material; pro Material immer nur 1 Material-Node).

Den Node-Editor öffnen sie z.B.:

Die Node-Ansicht

Navigation:

Sie können in der Node-Ansicht wie vom Editor und anderen Managern gewohnt, mit folgenden Hotkeys navigieren (s.a. Befehle im Menü "Ansicht"):

Nodes erzeugen

Sie können z.B. folgendermaßen Nodes erzeugen:

Beachten Sie, dass nicht alle Ausgangs-Ports mit allen Eingangs-Ports verbunden werden können. Zwar werden viele Datentypen automatisch konvertiert, allerdings gibt es hierfür Grenzen (so kann z.B. kein ShadingContext- mit einem BooleDatentyp verbunden werden). Cinema 4D zeigt Ihnen dann an, ob die Verbindung möglich ist: solange Sie über dem zu verbindenden zweiten Port schweben, wird die potentielle Verbindung entweder hell (möglich) oder dunkel/gepunktet (unmöglich) dargestellt.

Nodes verschieben

Nodes können jederzeit mit der Maus angefasst und verschoben werden. Mehrere selektierte Nodes werden als ganzes verschoben. Nähern Sie sich dabei den Rändern der Node-Ansicht, beginnt die Node-Ansicht zu scrollen.

Nodes verbinden

Damit Daten von einem Node zum nächsten fließen können, müssen diese verbunden werden: Dazu können Node-Ausgänge (rechte Node-Seite) des einen Nodes mit Node-Eingängen (linke Node-Seite) eines anderen Nodes verknüpft werden. Dazu:

Es gilt dabei:

Nodes selektieren

Sie können Nodes durch Rechteckselektion (einfach ein Rechteck im Node-Editor beginnend im leeren Raum aufziehen) oder Anklicken selektieren. Es arbeiten wie immer die Tasten Shift (zur Selektion hinzunehmen) und Ctrl (von der Selektion ausnehmen). Im Menü "Bearbeiten" finden Sie noch einige Selektionsbefehle mehr (wie z.B. "Verbundene selektieren).

Selektierte Nodes zeigen ihre Einstellungen im Attribute-Manager und dem Infobereich an.

Nodes löschen

Selektierte Node können durch die Rückschritt- bzw. Entf.-Taste gelöscht werden.

Node-Ansicht-Titel

Sie finden ganz oben in der Node-Ansicht folgende Elemente (von links nach rechts):

Der Navigator

Sie finden den Navigator rechts unten in der Node-Ansicht. Er ist ein verkleinertes Abbild der gesamten, aktuellen Node-Konstellation und dient der Orientierung und schnellen Navigation in komplexen Node-Schaltungen. Das hellgraue Rechteck zeigt den sichtbaren Ausschnitt der Node-Ansicht. Sie können diesen Ausschnitt verschieben, indem Sie in den Navigator klicken und mit gedrückter Maustaste ziehen. So ist schnelle Navigation in andere Bereiche möglich.

Es werden folgende Nodes besonders angezeigt:

Die Eingangs- und Ausgangsgruppenbereiche

Sie finden links ("Eingang") und rechts ("Ausgang") in der Node-Ansicht 2 dunkle Streifen. Sie können Ports mit diesen Streifen verbinden, indem Sie eine neue Verbindung in einem leeren Bereich der Node-Ansicht fallen lassen. Sie erstellen damit Verbindungen/Ports nach außen. Das macht bei einzelnen Nodes wenig Sinn, aber wenn Sie z.B. Gruppen ineinander verschachteln, können Sie hiermit einen Port erzeugen, der als Gruppenport (wie unten in der Abbildung rechts) angezeigt wird. D.h. Sie können selbst bei einer Gruppe in einer Gruppe einen bestimmten Node-Port auf unterster Ebene von außen füttern (oder auch als Ausgang nach außen führen).

Node-Ports in Gruppen können nach außen geführt werden.

Beim Verknüpfen eines Ports mit einem Eingangs- oder Außenbereich öffnet sich ein kleines Menü (s. Abbildung links unten) mit folgenden Einträgen:

Teile der eben beschriebenen Funktionalität (Eingänge erzeugen) sind auch per Port-Kontextmenü mittels Befehl machbar.

Allgemeines zu Nodes

Nodeaufbau und -darstellungsarten (es ist auch möglich, nur verbundene Ports anzuzeigen).

Der zentrale Bestandteil des Material-Node-Systems ist – logischerweise – der Node. Ein Node hat Eingänge, in die Daten von anderen Nodes fließen, die vom Node dann spezifisch verarbeitet werden und als Ergebnisse an seinen Ausgängen wieder herausfließen. Ein- und Ausgänge haben Ports, über die Verbindungen zu anderen Nodes geknüpft werden können. Es gilt grundsätzlich: Ein Eingangsport kann nur eine Verbindung haben, ein Ausgangsport dagegen beliebig viele.

Nodes können am linken und rechten Rad angefasst und verbreitert bzw. schmaler gezogen werden.

Ein typischer Node gliedert sich in einen Ober- und Unterbereich:

Oberbereich

Im Oberbereich befindet sich ganz oben die ständig aktualisierte Node-Vorschau, d.h. wenn sich die Einstellungen fütternder Nodes ändern, wird diese Vorschau ebenfalls aktualisiert. Sie können die Vorschau mit dem kleinen Icon links neben dem Node-Namen ein- und ausblenden (dafür gibt es auch Befehle s.o.).

Unter der Vorschau befindet sich links der Node-Name, der so ebenfalls im Tab "Basis" auftaucht. Er kann dort oder hier mit Doppelklick (was übrigens auch mit Portnamen – das kann allerdings nicht rückgängig gemacht werden – funktioniert) umbenannt werden. Beachten Sie hierbei, dass es logischerweise zu Differenzen der Namen zu beschriebenen Node-/Parameternamen in der Hilfe kommt.

Rechts neben dem Node-Namen befindet sich – sofern es sich um eine Gruppe handelt – ein Pfeil-Icon. Klicken Sie hierauf, um den Gruppeninhalt in der Node-Ansicht anzuzeigen. Wiederum rechts neben dem Pfeil-Icon befindet sich der Solo-Modus-Schalter (s. Solo).

Die Hintergrundfarbe des Oberbereichs kann mit Benutzerdefinierte Node-Farbe des Tabs "Basis" eingefärbt werden.

Unterbereich

Im Unterbereich finden Sie auf der linken Seite Eingangsports mit ihrem Namen – diese können per Doppelklick umbenannt werden – rechts daneben die Ausgangs-Ports mit ihrem Namen links davor. Ports können ausgeblendet und ihre Reihenfolge kann geändert werden. Beachten Sie, dass nicht unbedingt alle Eingangs-Ports im Node selbst aufgelistet werden. Diese können dann per Kontextmenü eingeblendet werden.

Bestimmte Nodes (wie z.B. der Ebenen-Node) haben sogar auf- und zuklappbare Portgruppen für jede Ebene.

Ports haben je nach Datentyp, den sie verarbeiten, eine bestimmte Farbe (s. nächsten Absatz).

Ports können selektiert werden (mit den gewohnten Tasten Shift und Ctrl, um zur Selektion hinzuzufügen bzw. davon auszunehmen), um auf sie bestimmte Befehle (s. Node-Menü bzw. Kontextmenü) wirken zu lassen.

Datentypen und Farben

Ein- und Ausgänge sind farblich markiert. Die dort jeweils erwarteten bzw. ausgegebenen Datentypen werden durch die Einfärbung angezeigt. Die wichtigsten Typen dabei sind:

Wie von XPresso her bekannt, lassen sich aber auch artfremde Ein- und Ausgänge miteinander verbinden. Es findet dann in der Regel eine sinnvolle Konvertierung der Datentypen statt. So kann z.B. eine Textur auch an einen Eingang für Fließkommawerte geknüpft werden. Die RGB-Werte der Textur werden dann automatisch in Helligkeitswerte umgerechnet. Auf diese Weise können auch Farbtexturen zur Steuerung z.B. der Rauigkeit einer "BSDF"-Ebene verwendet werden. Derartige Umrechnungen von Datentypen werden am empfangenden Material-Node durch einen zusätzlichen Punkt am entsprechenden Eingang angezeigt.

Kontextmenü

Beim Rechtsklick auf einen Node/Port öffnet sich ein umfangreiches Kontextmenü, das überwiegend aus Befehlen des Node-Editor-Menüs besteht. Diese sind an anderer Stelle beschrieben. Dort nicht beschrieben sind diese:

Filter

Geben Sie hier eine Zeichenfolge ein, um angezeigte Elemente zu filtern (es werden nur Befehle, Nodes etc. angezeigt, die diese Zeichenfolge enthalten).

Eingang hinzufügen

Bei einem Node müssen nicht alle Eingänge, die im Attribute-Manager aufgelistet werden, auch als Port aufgeführt sein. Manchmal sind nur die wichtigsten Eingangs-Ports eingeblendet. Rufen Sie Eingang hinzufügen auf, werden alle ausgeblendeten Ports hier aufgeführt. Wählen Sie einen aus, wird dieser Eingangs-Port wieder eingeblendet (mit Alle werden alle Eingangs-Ports sichtbar gemacht).

Dieser Menüpunkt ist nicht vorhanden, wenn alle Eingangs-Ports eingeblendet sind.

Ausgang hinzufügen

Normalerweise sind alle Ausgänge aufgeführt. Sollten Sie jedoch Ausgänge verborgen haben (z.B. mittels des Befehls Nicht verwendete Ports entfernen), können Sie sie durch Auswahl eines hier gelisteten Ausgangs-Ports wieder sichtbar machen.

Verbinde Node

Hiermit wird eine Liste eingeblendet, aus der Sie einen zu verknüpfenden Node auswählen. Sollten mehrere Ausgangs-Ports pro Node in Frage kommen, so gehen Sie mit der Maus auf den kleinen schwarzen Pfeil, woraufhin dann die auszuwählenden Ausgangs-Ports eingeblendet werden. Neben der kompletten Asset-Liste finden Sie hier als ersten Eintrag "Bestehende Nodes", in der Nodes aufgelistet werden, die in der derzeitigen Node-Ansicht enthalten sind. Außerdem gibt es hier den Eintrag Gruppe Eingang hinzufügen, mit dem Sie einen Port aus einer Gruppe herausführen können (s.a. Eingangs- und Ausgangsgruppenbereiche).

Beachten Sie, dass diese Liste dynamisch erzeugt wird und nur passende Nodes vorschlägt.

Ersetze Node

Hiermit wird für den aktuellen, verbundenen Eingangs-Port der "fütternde" Node durch einen aus einer Liste auswählbaren ersetzt. Beachten Sie, dass hier die komplette Node-Kette am zu ersetzenden Node (die also diesen füttern) gelöscht wird. Das gilt nur für zu fütternde Nodes: Nodes, die an deren Ausgangs-Port hängen, sind davon unbetroffen.

Konverter einfügen

Bei bereits verbundenen Ports kann dieser Befehl aufgerufen werden. Er setzt in die Verbindung einen auszuwählenden Konverter-Node, d.h. dessen Ein- und Ausgang sind bereits sinnvoll verbunden.

Texturen

Hier werden alle geladenen Texturen aufgelistet, von der Sie eine auswählen, die dann mit einem Bild-Node in den Eingangs-Port eingeleitet wird.

Texturen laden

Dieser Befehl öffnet einen Dateiauswahldialog, mit dem Sie eine Bitmap oder ein Video auswählen, welche dann mit einem Bild-Node in den Eingangs-Port eingeleitet wird.

Portinstanz entfernen

Einige Nodes wie z.B. der Ebenen-Node oder der Farbverlauf bieten Ihnen diesen Befehl an. Sie können damit Elemente wie z.B. Ebenen oder Knoten löschen.

Port verbergen

Mittels dieses Befehls blenden Sie selektierte Ports aus. Das funktioniert nur mit unverbundenen Ports. Der ausgeblendete Port erscheint dann in der eben beschriebenen Liste unter Eingang hinzufügen (und kann damit wieder eingeblendet werden).

Beachten Sie auch den Befehl Zeige alle Ports und die nächsten beiden dort beschriebenen Befehle. Hierbei handelt es sich um eine andere Funktionalität des Anzeigens oder Nichtanzeigens von Ports.

Port nach oben/unten verschieben

Mit diesen beiden Befehlen kann ein einzelner, selektierter Port um eine Position nach oben bzw. unten verschoben werden.

Auf voreingestellten Wert zurücksetzen

Die meisten Parameter haben einen voreingestellten Wert, der bei Node-Neuerzeugung vordefiniert ist. Mit diesem Befehl – nur bei unverbundenem Node aufgeführt – setzen Sie evtl. verstellte Werte wieder auf diesen zurück.

Port herausführen

Der Aufruf dieses Befehls (nur sinnvoll, wenn die Node-Ansicht den Inhalt einer Gruppe zeigt) erzeugt eine Verbindung nach außen bzw. zur übergeordneten Hierarchie. S.a. Die Eingangs- und Ausgangsgruppenbereiche.

Solo-Port (nur Ausgang)

Sie können für Nodes eine Solo-Funktionalität einschalten. Hat dieser Node mehrere Ausgänge, muss einer davon als Solo-Port definiert werden. Das machen Sie mit dieser Option.

Als Vorschau-Port festlegen (nur Ausgang)

Im Oberbereich eines Nodes finden Sie die Node-Vorschau. Hat ein Node nun mehrere Ausgänge, kann mit dieser Option festgelegt werden, welcher Ausgang dort angezeigt werden soll.

Gruppe verriegeln
Gruppe entriegeln

Mit diesen beiden Befehlen können selektierte Gruppen ver- und entriegelt werden. Verriegelte Gruppen können zwar angesehen, aber nicht geändert werden.

Verbindungen

Um einen Node-Port mit einem anderen zu verbinden, gehen Sie so vor.

Verbindungen können ebenfalls selektiert werden, wobei wie (fast) immer Shift und Ctrl gedrückt werden kann, um zur Selektion hinzuzufügen, bzw. davon auszunehmen (Rechteckselektionen funktioniert ebenfalls). Was kann mit selektierten Verbindungen angefangen werden? Sie können z.B. mit den bekannten Tasten gelöscht werden oder per Kontextmenü mit einigen unten beschriebenen Befehlen bearbeitet werden (hier nur die Befehle, die noch nicht an anderer Stelle beschrieben wurden).

Verbindung entfernen

Löscht die selektierten Verbindungen.

Port stummschalten

Stumm geschaltete Verbindungen werden mit einer gestrichelten Linie dargestellt. Hierbei werden Werte nicht vom zuvor angeordneten Node übernommen, sondern von den im Attribute-Manager definierten. Damit können Verbindungen z.B. aus Testgründen temporär deaktiviert werden.

Andere Node-Editor-Bestandteile

Die rechts oben befindlichen Icons

Oben rechts im Node-Editor finden Sie diese 5 Icons, beschrieben von links nach rechts:

Der Attribute-Manager

Den bekannten Attribute-Manager gibt es innerhalb des Node-Editors in einer leicht abgewandelten Form. Der Attribute-Manager zeigt die Eigenschaften selektierter Nodes oder Node-Materialien an.

Das allermeiste funktioniert, wie unter Attribute-Manager beschrieben. Hier sind nur die wesentlichen Unterschiede aufgeführt.

Erzeugen Sie z.B. einen Spiral-Node (Assets-Liste: Form/Spirale):

Wie Sie sehen, sind alle Eingangs-Ports auch im Attribute-Manager aufgeführt. Der Attribute-Manager hat sogar mehr Einstellungen, als der Node Ein- oder Ausgänge hat. Im Attribute-Manager sind stets alle Einstellungen enthalten. Der Node hat meist nur eine Auswahl davon als Ein- oder Ausgang, Einstellungen der Tabs "Vorschau" oder "Basis" z.B. sind nicht enthalten.

Ausgangs-Ports sind hier logischerweise nicht aufgeführt, da sich deren Werte durch Berechnung innerhalb des Nodes ergeben, von Ihnen also nur indirekt durch Änderung von Eingangswerten geändert werden können.

Das Verbindungs-Icon

Die große Neuerung gegenüber dem alten Attribute-Manager sind die Verknüpfungsfelder, die durch das Verbindungs-Icon ersetzt wurden. Node-Eingänge können entweder mit Werten gefüttert werden, indem Sie bei den Parametern einfach Werte eingeben oder – und das ist neu – Node-Eingänge mit den Node-Ausgängen anderer Nodes verbinden, also eine Verknüpfung erzeugen (also das, was Nodes ausmacht).

Klicken Sie auf das Verbindungs-Icon rechts neben dem Parameternamen und wählen Sie aus dem Kontext-Menü "Verbinde Node" einen beliebigen Node aus, um diesen mit dem angeklickten Eingang zu verbinden (Sie können natürlich auch in der Node-Ansicht einfach die Ports verbinden). Dabei wird der ausgewählte Node erzeugt und verknüpft:

Bitmaps können übrigens von außerhalb Cinema 4D stets überall auf eine komplette Parameterzeile (inkl. Parametername, Verbindungs-Icon und GUI-Element) gezogen werden, um den entsprechenden Parameter mittels eines Bild-Nodes zu verknüpfen.

Sobald ein Parameter mit einem anderen Node verbunden ist, gilt:

Das Animations-Icon zeigt also Abhängigkeiten im Animations- und XPression-Zusammenhang, während das Verbindungs-Icon Abhängigkeiten im Shading- und Renderer-Zusammenhang symbolisiert.

Das Verbindungs-Icon kann diese 3 Zustände annehmen:

Beim Klick auf ein Verbindungs-Icon werden folgende Befehle angeboten, von denen Sie die meisten schon vom Port-Kontextmenü kennen. Das Verbindungs-Icon stellt also auch ähnliche Funktionalität bereit, auf die per Rechtsklick auf einen Port in der Node-Ansicht zugegriffen werden kann.

Im Folgenden beschrieben sind nur die Verbindungs-Icon-eigenen Befehle.

Ebene hinzufügen

Im Ebenen-Node z.B. finden Sie diesen Befehl. Es wird dann der auszuwählende Node mittels einer neuen Ebenen verknüpft.

Kopieren

Hiermit kann der verbundene Ausgangs-Port in den Zwischenspeicher kopiert werden und mit…

Einfügen (Link)

…einem anderen Eingangs-Port verbunden werden. Damit können also mehrere Eingänge mit dem gleichen Ausgang verknüpft werden.

Einfügen (Duplikat)

Dieser Befehl verbindet den in der Zwischenablage befindlichen Ausgangs-Port mit dem angeklickten Eingang. Dabei wird im Gegensatz zum vorhergehenden Befehl ein Duplikat des ganzen – fütternden – Nodes erzeugt.

Entfernen

Hiermit lösen Sie die Verbindung des Eingangs-Ports.

Port stummschalten

Hiermit wird die Verbindung zwar gehalten, es kommt aber nichts mehr durch den "Schlauch" durch. Stattdessen wird der im Attribute-Manager eingestellte Wert als Eingang herangenommen. Rufen Sie den Befehl erneut auf, um den "Hahn" wieder aufzudrehen.

Zeige Unterkanäle

Einige Nodes wie z.B. der Ebenen-Node oder der Farbverlauf bieten Ihnen diesen Modus an. Aktivieren Sie diesen, um z.B. die Ebeneneinstellungen als animierbare bzw. ebenfalls durch das Verbindungs-Icon regelbare Parameter anzuzeigen. Darüber hinaus können die Eingangsparameter des fütternden Nodes eingeblendet werden, wenn Sie auf den kleinen, schwarzen Pfeil links neben Farbe klicken. In folgendem Beispiel wären das die Eingänge des "Kreis"-Nodes:

Für den Farbverlaufs-Node (einen Greifer anklicken und auf eines der untergeordneten Verbindungs-Icons klicken, um den Befehl aufzurufen) werden die Parameter sämtlicher Knoten aufgelistet.

Rufen Sie den Befehl erneut auf, um wieder in den vorherigen Modus umzuschalten.

Erbe Interface

Einige Nodes wie z.B. der Abstand- oder Wert-Node können für Eingangs-Ports die Einheiten und die Parameterdarstellung des nachfolgenden, verbundenen Nodes übernehmen.

Die Node-Liste

Links oben finden Sie die Node-Liste, wo alle in der aktuellen Gruppenhierarchie vorhandenen Nodes und Gruppen aufgelistet werden. Sie können hier:

Die Listenreihenfolge hat übrigens keinerlei Einfluss oder Bedeutung.

Lupen-Icon

Klicken Sie rechts oben auf das Lupen-Icon, um einen Filter einzublenden. Geben Sie hier eine Zeichenfolge ein, um alle Nodes auszublenden, deren Name diese Zeichenfolge nicht enthält.

Die Asset-Liste

In der Asset-Liste finden Sie alle von Cinema 4D mitgelieferten Nodes, sowie auch eigene, erstellte Assets (der Node Commander stellt die gleiche Funktionalität zur Verfügung; lässt sich überall innerhalb des Node-Editors mit der Taste C aufrufen) in aufklappbaren Gruppen. Mittels dieser Liste erzeugen Sie Nodes, die dann in der Node-Ansicht angezeigt werden.

Um schnell auf das gewünschte Asset zugreifen zu können, wurde ein Filter (klicken Sie auf das Lupen-Icon) integriert. Geben Sie hier eine Zeichenfolge als Suchbegriff ein. Nodes sind intern mit einigen Schlüsselwörtern ausgestattet, so dass ein Node auch dann aufgelistet wird, wenn die Zeichenfolge von diesen Schlüsselbegriffen verwendet wird.

Beispiel: Der Farbkorrektur-Node hat die internen Schlüsselwörter "Korrektur, tönen, HSL, HSV" etc. Wenn Sie diese als Zeichenfolge eingeben, wird auch der Farbkorrektur-Node gelistet. Ein anderes Beispiel wären Noise-Namen (z.B. Luka, Stupl, etc), mit denen Noise-Nodes gefunden werden können. Hier kommt auch eine sehr praktische Spezialfunktionalität zum Einsatz: wenn Sie das mit "Stupl" gefundene Asset erzeugen, wird dieses gleich auf den Noisetyp Stupl gestellt. Das funktioniert z.B. auch mit dem Mischen-Node (tippen Sie z.B. "Multiplizieren" ein).

Bei einigen Nodes wie dem Mischen-Node kann das sogar weiter getrieben werden, wenn Sie z.B. nach "Multiplizieren Hintergrund" (mehrere Zeichenfolgen werden mit einem logischen "UND" kombiniert) filtern und den Mischen-Node erzeugen, werden sowohl die Auswahlmenüs Mischmodus als auch Umgang mit Alpha entsprechend gesetzt.

Der Node-Name selbst wird natürlich auch gefunden (und genießt auch die höhere Priorität gegenüber Schlüsselwörtern)!

In der Asset-Liste funktioniert Mehrfachselektion (mit Shift und Ctrl zum Hinzufügen und Ausnehmen von der Selektion). Ziehen Sie alle selektierten Assets in die Node-Ansicht oder doppelklicken Sie auf eines der selektierten, um alle zu erzeugen.

In der gefilterten Liste kann ein Asset mit Doppelklick erzeugt werden. Alternativ können Sie auch mit den Cursor-Tasten navigieren und das ausgewählte Asset per Return erzeugen.

Ansonsten können Sie eine selektierte Gruppe mit den Cursor-Tasten Links und Rechts auf- und zuklappen.

Sie finden in der Asset-Liste neben den Assets selbst eine Spalte namens "Datenbank". Hier können Sie Rückschlüsse ziehen, wo das Asset abgespeichert wurde. Wird hier "Eingebaut" aufgeführt, so handelt es sich um ein sog. "Kern-Asset", ein von MAXON erzeugter Grund-Node, in den sich nicht hineinblicken lässt. Andere Assets z.B. bestehen aus in Gruppen zusammen gefassten Kombinationen (in diese lässt sich sehr wohl blicken) dieser Kern-Assets. Diese sind z.B. in Datenbanken namens "Utilities" oder "Materalien" gespeichert.

Bei "Voreinstellungen" und anderen von Ihnen selbst benannten Datenbanken oder importierten Assets handelt es sich um nicht von MAXON erstellte Assets, die Sie in Ihrem Voreinstellungsverzeichnis (in einem Ordner namens "userrepository) oder anderswo gespeichert haben.

Informationen zum Erstellen und Verwalten von Assets finden Sie im Abschnitt Assets (dort sind dann auch die ganzen Kontextmenübefehle beschrieben).

Der Infobereich

Links unten finden Sie den Infobereich, der Ihnen für selektierte Nodes, Verbindungen und Ports einige Infos ausgibt.

Das sind für Nodes:

Für Verbindungen sind das zusätzlich:

Für Ports sind das zusätzlich:

Das Node-Editor-Menü

Erzeugen-Menü

Leere Gruppe erzeugen

Erzeugen Sie für das aktuelle Node-Material eine neue, leere Gruppe:

Klicken Sie auf das Pfeil-Icon, um Sie zu öffnen und mit Inhalt zu füllen.

Was ist eine Gruppe?

Gruppen sind zusammenfassende, übergeordnete Nodes, die ein Node-Netzwerk (und/oder wiederum Gruppen) enthalten. Die Ports innenliegender Nodes können nach außen geführt werden, um Werte von außerhalb der Gruppe liegender Nodes einzuleiten oder die Werte innen liegender Nodes abzugreifen.

Gruppen können in Assets umgewandelt und weitergegeben werden.

Sie können auch mehrere Nodes selektieren und mit den nächsten Befehl Nodes gruppieren aufrufen, um diese direkt in einer Gruppe unterzubringen.

Nodes gruppieren

Hiermit werden selektierte Nodes in einer Gruppe (s.a. vorherigen Befehl) zusammengefasst.

Gruppe auflösen

Hiermit können Gruppen wieder ausgepackt werden, wobei der Gruppen-Node gelöscht wird. Verbindungen bleiben – soweit möglich auch nach außen – erhalten.

Hinweis:
Um Assets aufzulösen, müssen diese zunächst in Gruppen konvertiert werden.

Eingangsport erzeugen
Ausgangsport erzeugen

Erzeugen Sie mit diesem Befehl einen neuen Eingangs- bzw. Ausgangsport. Das ist nur für Nodes innerhalb von Gruppen sinnvoll (s.a. Die Eingangs- und Ausgangsgruppenbereiche).

Port herausführen

Mit diesem Befehl erzeugen Sie Parameter-Eingangs-Ports für alle selektierten Ports. Zum Unterschied zwischen Eingangs-, Ausgangs-Ports und herausgeführten Ports siehe Eingangs- und Ausgangsgruppenbereiche.

Asset-Befehle

Details zu Assets finden Sie unter Assets.

Asset erzeugen...

Assets werden meist aus Gruppen-Nodes erzeugt (ein beispielhaftes Vorgehen finden Sie hier beschrieben).

Sobald Sie diesen Befehl bei einem (oder auch mehreren; diese werden dann nacheinander abgearbeitet) selektierten Node aufrufen, öffnet sich ein solcher Dialog:

Name

Vergeben Sie hier einen Namen für Ihr Asset. Unter diesem Namen wird das Asset in der Asset-Liste geführt und gefunden. Dieser Name wird auch später, wenn Sie das Asset tatsächlich in der Node-Ansicht als Instanz benutzen (es also von der Asset-Liste in die Node-Ansicht gezogen haben), im Infobereich bei "Asset" aufgeführt. Selbst wenn Sie den Node umbenennen, bleibt dieser Name unverändert.

Versions-Tag

Assets können in mehreren Versionen auftreten, haben also eine sog. "Versionierung". Stellen Sie sich vor, Sie erstellen ein Asset, bauen damit Szenen, speichern die Szenen ab. Danach überarbeiten Sie das Asset (Rechtsklick auf das Asset in der Asset-Liste: Asset bearbeiten), indem Sie z.B. eine Farbe ändern oder neue Nodes hinzufügen. Wenn Sie jetzt das Asset speichern (Neue Version speichern), können Sie hier bei Versions-Tag eine Versionsbezeichnung (z.B. 1.1 oder "Version 2") angeben. Im Asset befindet dann sowohl die ursprüngliche, als auch die neue Version.

Wenn Sie jetzt eine der ursprünglich gespeicherten Szenen laden oder das Asset neu verwenden, wird voreinstellungsgemäß die neueste Asset-Version verwendet. Es kann aber jederzeit in der Asset-Instanz (also dem Gruppen-Node) im Tab "Basis" zwischen dem Versionen hin- und her geschaltet werden:

Sie können sich die Versionierung auch so vorstellen: Angenommen Sie haben in Cinema 4D R15 das Grundobjekt Würfel abgespeichert. In R18 kam z.B. einer neuer Parameter "Rundung" hinzu. Wenn Sie jetzt die mit R15 gespeicherte Szene in R18 laden, gab es meist eine Kompatibilitätsoption á la "Alte Version laden". Wird die Option aktiviert, wird der Würfel ohne Rundung geladen, ist sie deaktiviert, mit Rundung. Gelegentlich wurde aber auch ohne weitere Nachfrage einfach der aktuelle Würfel geladen. Würde die Versionierung auch für Gundobjekte gelten, könnten Sie beliebig zwischen den Versionen hin- und herspringen.

MAXON kann per Online-Updater die eingebauten Nodes und Node-Materialien aktualisieren. Das wird aber so gehandhabt, dass alte Szenen weiterhin funktionstüchtig bleiben.

Was Sie also hier unter Version-Tag definieren, erscheint später bei der Asset-Instanz als Asset-Versions-Name.

ID

Hier wird eine eindeutige ID (Sie selbst müssen hier nichts eintragen) vergeben, womit ein Asset eindeutig identifiziert werden kann – es muss schließlich von einer Szene, die es verwendet, identifiziert werden. Diese ID – ergänzt um eine zufällige Zeichenfolge – wird dann später im Infobereich angezeigt, wenn Sie einen entsprechenden Node selektieren.

Datenbank

Assets können in verschiedenen Datenbanken abgelegt werden.

Ihnen werden immer mindestens die folgenden angeboten:

Das hier gezeigte Menü ist also dynamisch und kann beliebig viele Einträge enthalten.

Kategorie
Neuer Kategoriename

Wenn Sie einen Blick in die Asset-Liste riskieren, sehen Sie dort viele Assets in nach dem Alphabet sortierten Kategorien organisiert. Sie können jederzeit selbst neue Kategorien anlegen (diese sind übrigens selbst auch Assets).

Das zu speichernde Asset wird in der hier ausgewählten Kategorie untergebracht. Wenn Sie hier Neue Kategorie wählen, kann in der letzten Einstellung Neuer Kategoriename ein neuer erstellt werden.

Selbst erstellte Assets können später problemlos in der Asset-Liste per Drag&Drop in andere Kategorien verschoben werden.

Sobald Sie auf OK klicken, wird das Asset gespeichert und ist sofort in der Asset-Liste, wie auch im Node-Commander gelistet und einsetzbar.

Asset in Gruppe umwandeln

Asset-Nodes, die ja meist selbst aus Gruppen entstanden sind, können mit diesem Befehl auch wieder in Gruppen konvertiert werden. Es wird dann das von Gruppen gewohnte Pfeil-Icon eingeblendet:

Hiermit kann die Gruppe geöffnet werden.

Neue Version speichern...

Wenn Sie vorhandene Assets bearbeiten, sollten Sie Änderungen daran mit diesem Befehl speichern. Es öffnet sich dann wiederum der Dialog, den Sie schon von Asset speichern (s.o.) her kennen. Da der alte Asset-Zustand ebenfalls gespeichert bleibt, kommt es zur oben beschriebenen Versionierung.

Als neues Asset speichern (Kopie)...

Beim Bearbeiten von vorhandenen Assets können Sie hiermit ein neues Asset ohne die oben beschriebene Versionierung speichern. Es öffnet sich dabei der Dialog, den Sie schon von Asset speichern (s.o.) her kennen.

Asset-Bearbeitungsmodus verlassen

Sofern Sie ein Asset mittels des Befehls Asset bearbeiten geöffnet haben, befinden Sie sich im Asset-Bearbeitungsmodus. Diesen Modus schließen und verlassen Sie mit diesem Befehl. Es erfolgt dabei ggf. eine Sicherheitsabfrage, ob Sie Änderungen am Asset verwerfen wollen. Sie müssen Asset-Änderungen explizit abspeichern (z.B. mit Neue Version speichern).

Bearbeiten-Menü

Rückgängig
Wiederherstellen

Das sind die üblichen Befehle, mit denen Sie z.B. Änderungen im Attribute-Manager, Löschen, Erzeugen von Nodes und Verbindungen etc. wieder zurücknehmen oder wiederherstellen können.

Im Gegensatz zum XPresso-Editor fallen z.B. Verschieben oder Verbreitern von Nodes nicht unter diese Funktionalität.

Ausschneiden
Kopieren
Einfügen

Hiermit können selektierte Nodes in die Zwischenablage kopiert (im Falle von Ausschneiden werden die Nodes zusätzlich gelöscht) und mit Einfügen aus der Zwischenablage wieder in den Node-Editor kopiert werden.

Duplizieren

Mit diesem Befehl werden selektierte Nodes unter Wegfall evtl. bestehender Verbindungen dupliziert, also verdoppelt.

Löschen

Mittels diesen Befehls löschen Sie selektierte Nodes. Ein Druck auf die Rückschritt- oder Entf.-Taste tut das gleiche.

Alles selektieren
Alles deselektieren

Hiermit können alle Nodes selektiert bzw. deselektiert werden.

Verbundene selektieren

Mit diesem Befehl selektieren Sie alle direkt mit dem selektierten Node verknüpften Nodes. So können Sie schnell ganze verbundene Node-Kaskaden selektieren.

Node-Commander

Der Node Commander stellt eine ähnliche Funktionalität wie die links im Node-Editor angeordnete Asset-Liste zur Verfügung. Sie müssen nicht mit der Maus dort hinfahren, sondern drücken einfach die Taste C und die Liste öffnet sich. Dazu muss allerdings der Node-Editor aktiv sein!

Zusätzlich zu der bei der Asset-Liste beschriebenen Funktionalitäten hat der Node Commander folgende:

Node-Menü

Vorschau anzeigen
Vorschau ausblenden

Hiermit kann die Node-Vorschau (oben an jedem Node) angezeigt bzw. ausgeblendet werden.

In den Programm-Voreinstellungen gibt es im Tab "Material" auch eine Voreinstellung, die festlegt, ob die Vorschau bei Node-Neuerzeugung sichtbar ist oder nicht. Wozu soll das gut sein, die Vorschau auszublenden, wo diese doch so wertvolle Informationen liefert? Nun, so kann es z.B. bei extrem großen Node-Netzwerken bei Änderungen an Einstellungen sehr rechenzeitaufwendig sein, alle Vorschauen zu aktualisieren. In solchen Fällen kann es sinnvoll sein, die Vorschauen auszuschalten.

Horizontales Layout
Vertikales Layout

Links vertikales, rechts horizontales Layout.

Legen Sie mit diesen beiden Befehlen fest, wie die Eingangs- und Ausgangs-Ports im Node angeordnet werden sollen:

Zeige alle Ports
Alle Ports ausblenden

Alle Ports ausblenden blendet den Port-Bereich für selektierte Nodes komplett weg (ein Doppelklick auf den Node macht das gleiche). Die Verbindungen bleiben selbstverständlich erhalten. Es handelt sich um eine rein visuelle Angelegenheit, um z.B. besseren Überblick zu bekommen. Mit Zeige alle Ports (oder erneutem Doppelklick) kann das wieder rückgängig gemacht werden.

Selektierte Ports können auch per Kontextmenü als verborgen definiert werden. Selbst Zeige alle Ports macht diese dann nicht sichtbar! Sie müssten den entsprechenden Port erst mit Eingang hinzufügen als sichtbar definieren.

Verbundene Ports anzeigen

Damit zeigt der selektierte Node nur die Ports mit Verbindungen an. Die anderen werden ausgeblendet. Das kann mit Zeige alle Ports wieder rückgängig gemacht werden.

Solo-Node/Port setzen
Solo ausschalten

Verschiedene Nodes als Solo-Node definiert, gerenderte Textur auf einem Würfel.

Der Solo-Node lässt alle nachfolgenden, anderen Nodes vergessen. In der Ansicht und beim Rendern werden nur die in den Solo-Node gefütterten Nodes inkl. ihm selbst ausgewertet und entsprechend angezeigt. Das ist z.B. sehr praktisch, wenn Ihnen die Node-Vorschau zu klein ist, denn dann können Sie die Wirkungen einzelner Nodes in beliebiger Größe rendern oder anzeigen lassen.

Rufen Sie den Befehl für einen selektierten Node (mit evtl. selektiertem Ausgangs-Port: s.a. Solo-Port) auf oder klicken Sie einfach auf das "S"-Icon im Node selbst. Logischerweise kann immer nur ein einziger Node Solo-Node sein. Um die Solo-Node-Funktionalität wieder aufzuheben, rufen Sie Solo ausschalten auf oder klicken einfach erneut auf das (jetzt) gelbe "S"-Icon.

Als Start-Node definieren
Start-Node ausschalten

Node-Materialien können aus sehr komplexen Netzwerken mit hunderten von Nodes bestehen. Möchten Sie jetzt Kleinigkeiten am Material ändern, ohne groß in die Node-Ansicht einzutauchen, kann ein Node – pro Node-Material ein einziger – als "Start-Node" definiert werden. Die Eingänge dieses Nodes (und nur dieses Nodes) werden bei selektiertem Material im Attribute-Manager bzw. Material-Editor im Tab "Eingänge" angezeigt.

Wollen Sie hingegen nur einige wenige Ports anzeigen lassen, arbeiten Sie mit Gruppen, führen die besagten Ports aus dieser heraus und definieren den Gruppen-Node als Start-Node.

Start-Nodes werden unselektiert mit einem grünen, selektiert mit einem hellgelben Rahmen markiert.

Bei folgendem Beispiel soll nur der Parameter Arme des Spirale-Nodes als von außen zu regelnde Einstellung angezeigt werden. Gehen Sie so vor:


  1. Packen Sie alle Node in eine Gruppe, indem Sie sie selektieren und aus dem Kontextmenü Node gruppieren wählen. Öffnen Sie die Gruppe (Klick auf Pfeil-Icon des Gruppen-Nodes).
  2. Rechtsklicken Sie auf den Arme-Port des Spiral-Nodes und wählen Sie aus dem Kontextmenü Port herausführen.
  3. Verlassen Sie die Gruppe, indem Sie im Material- bzw. Gruppennamen auf "Node" klicken.
  4. Selektieren Sie den Gruppen-Node und wählen Sie Als Start-Node definieren (Menü "Node").

Sobald Sie jetzt das Node-Material selektieren, wird nur der Arme-Parameter angezeigt (Abbildung unten rechts).

Würden Sie jetzt auf den Gruppen-Node rechtsklicken und aus dem Kontextmenü Asset erzeugen aufrufen, hätten Sie bereits ein Asset erzeugt!

Mit Start-Node ausschalten wird ein etwaig vergebener Start-Node-Status aufgehoben.

In Material-Editor öffnen

Hiermit kann für das aktuell im Node-Editor angezeigte Material der Material-Editor eingeblendet werden (der prinzipiell – wie gewohnt – die gleichen Einstellungen wie ein selektiertes Material im Attribute-Manager anzeigt.)

In Material-Manager selektieren

Dieser Befehl selektiert für den aktiven Node-Editor das zugehörige Node-Material im Material-Manager, womit dessen Material-Einstellungen im Attribute-Manager angezeigt werden.

Unbenutzte Nodes entfernen

Unbenutzte Nodes sind Nodes ohne Verbindungen (Gefüllte Gruppen und Materialien fallen nicht darunter). Sie erfüllen also keinen Zweck. Diese können mit Unbenutzte Nodes entfernen gelöscht werden.

Nicht verwendete Ports entfernen

Dieser Befehl arbeitet nur, wenn pro Eingangs- bzw. Ausgangsportgruppe mindestens eine Verbindung besteht: dann werden für selektierte Nodes alle Ports ohne Verbindung ausgeblendet (diese können mit Eingang hinzufügen bzw. Ausgang hinzufügen wieder eingeblendet werden). Andernfalls bleiben die Ports unverändert sichtbar.

Ansicht-Menü

Selektierte anzeigen

Sollten Nodes außerhalb der Node-Ansicht liegen, können Sie mit diesem Befehl alle selektierten Nodes gleichzeitig anzeigen. Dabei wird die Ansicht ggf. verkleinert, damit alle selektierten Nodes sichtbar werden.

Alle anzeigen

Dieser Befehl zeigt alle Nodes in der Node-Ansicht an. Die Ansicht wird dabei ggf. verkleinert.

Selektierte zentrieren

Damit werden die selektierten Nodes in der Mitte der Ansicht angezeigt, ohne den Zoomfaktor zu verändern. Bei mehreren selektierten Nodes wird der Flächenmittelpunkt der in der Ansicht verteilten Nodes in die Mitte gerückt.

Alles zentrieren

Hiermit werden alle Nodes mittig angezeigt, ohne den Zoomfaktor zu verändern.

Einzoomen
Auszoomen

Vergrößern und verkleinern Sie hiermit die Node-Editor-Ansicht. Schneller gehts mit dem aus vielen anderen Managern gewohnten Hotkey 2 und der Maus.

Zoom 100%

Haben Sie Ihr aus 376 Nodes bestehendes Node-Netzwerk komplett in der Ansicht, sehen Sie keine Details mehr. Dieser Befehl setzt die Ansicht auf gut leserliche 100%.

Raster anzeigen

Den Hintergrund der Node-Ansicht schmückt ein dezentes Gitterraster. Mit diesem Befehl schalten Sie dieses aus und auch wieder an. Das Gitter-Snapping funktioniert unabhängig von der Sichtbarkeit.

Gitter-Snapping

Hiermit kann das Gitter-Snapping an- und ausgestellt werden. Ist es aktiviert, rasten die Node-Ränder jeweils auf den Gitterlinien ein. Ansonsten können Sie Nodes frei positionieren.

Gruppenverbindungen anzeigen

Sollen Gruppenverbindungen (s.a. Eingangs- und Ausgangsgruppenbereiche) eingeblendet werden, so aktivieren Sie diese Option. Oftmals sind das nur nach außen führende Verbindungen, die visuell wegen ihrer Vielzahl oft vom wesentlichen ablenken. Deaktivieren Sie dann diese Option.

Bézier-Verbindungen

Verbindungen sind voreinstellungsgemäß schön geschwungen. Möchten Sie lineare Verbindungen zwischen den Ports, so deaktivieren Sie diese Option.

Navigator anzeigen

Hiermit kann der Navigator ein- und ausgeblendet werden.

Fehler anzeigen

Falls ein Node Fehler produziert oder mit ungültigen Datentypen gefüttert wird, wird er mit einem roten Rahmen versehen (halten Sie dann nach Fehlermeldungen in der Node-Liste bzw. im Infobereich Ausschau, die ihnen Details darüber verraten). Dieser Rahmen kann ausgeblendet werden, wenn Sie die Option Fehler anzeigen deaktivieren.

Eine Ebene hoch

Beim Arbeiten mit Gruppen tauchen Sie öfters in diese Gruppen ein, d.h. die Node-Ansicht zeigt den Inhalt einer Gruppe. Wenn Sie eine Ebene hoch springen wollen, also aus dieser Gruppe heraus, rufen Sie diesen Befehl auf. Alternativ können Sie oben beim Material- bzw. Gruppennamen auf die Ebene klicken, in die Sie springen wollen.

Ausgewählte anordnen
Alle anordnen

Mit diesen beiden Befehlen werden selektierte bzw. alle Nodes so angeordnet, dass sie in der aktuellen Ansicht möglichst sichtbar, kompakt, nach Reihenfolge und horizontal/vertikal geordnet platziert werden:

Vor und nach Aufruf des Befehls Alle anordnen.

Beispielszene

Das folgende Material wurde komplett mit Nodes erstellt, wobei keine Bitmap als Textur zum Einsatz kam.

Laden Sie einmal die folgende Szene:


Sie können hier ansatzweise erkennen, was mit Nodes möglich ist. Rechtsklicken Sie auf das Material und wählen Sie Node-Editor, um einen Blick in die Node-Schaltung zu werfen. Beachten Sie den "Plaid"-Gruppen-Node, in diesem verbergen sich weitere Node-Schaltungen.