Cinema 4D/BodyPaint 3D Programmdokumentation Referenz Cinema 4D Cinema 4D Prime Charakter-Menü
Funktion verfügbar in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Wichtungs-Manager

Befehle Joints Wichtungen Auto-Wichtung Optionen Darstellung

Wichtungs-Manager

Wichtungs-Manager

Der Wichtungs-Manager bietet für das Erzeugen von Mesh-Wichtungen gegenüber dem Wichtungs-Werkzeug einen erweiterten Workflow und weitergehende Funktionen. Während Sie mit dem Wichtungs-Werkzeug dynamisch und intuitiv Wichtungen auf der Mesh-Oberfläche malen, können mit dem Wichtungs-Manager Wichtungen en gros, oder auf eine bestimmte Punktselektion oder anderen, im Folgenden beschriebenen Kriterien aufgetragen werden.

Die Hauptaufgabe des Wichtungs-Managers ist die Wichtungsanzeige (pro Objekt und Objektpunkt) der Joints in einer Tabelle.

Sie können hier jetzt einfach den Einfluss auf jeden Meshpunkt manipulieren, indem Sie Punkte und Kanten in der Ansicht selektieren. Sie müssen dann nicht mehr ständig zwischen Selektions- und Wichtungs-Werkzeug umschalten.

Alle Autowichtungen und Wichtungsmanipulation können direkt hier im Wichtungs-Manager vorgenommen werden. Einige Funktionalitäten sind sowohl im Wichtungs-Manager, als auch im Wichtungs-Werkzeug vorhanden.

Tipp:
Der Wichtungs-Manager kann schnell geöffnet werden, wenn Sie mit gedrückter Shift-Taste auf ein Wichtungs-Tag doppelklicken.

Für häufig benutzte Funktionen, kann das Interface des Wichtungs-Managers entsprechend konfiguriert werden, indem Sie im Manager auf das Icon rechts oben klicken und es an passender Stelle in der Programmoberfläche einklinken.

In diesem Beispiel wurde der Wichtungs-Manager dupliziert und dann in das Original-Fenster gedockt. Damit können Sie das Interface – sofern nötig – horizontal arrangieren, im Gegensatz zur gewohnten vertikalen Anordnung. Sie können den Wichtungs-Manager bis zu 3 Mal duplizieren und beliebig anordnen.

Hinweis:
Zum Riggen finden Sie ein neues Layout rechts oben über dem Objekte-Manager im Menü "Layout". Es nennt sich "Rigging (Wide)". Dieses Layout legt den Fokus für schnellen Zugriff auf für das Rigging oft benötigte Manager und Befehle.

Datei-Menü

Lade Wichtungen...

Mit diesem Befehl können Sie zuvor gespeicherte Wichtungen aus einer externen Textdatei laden und dem aktuell selektierten Objekt zuweisen.

Der Vorgang ist einfach: stellen Sie sicher, dass das Objekt oder einer seiner Joints im Wichtungs-Manager selektiert sind. Rufen Sie dann Lade Wichtungen auf, um die Wichtungen dieser Joint-Hierarchie zuzuweisen.

Lade-Optionen

Klicken Sie auf das Icon rechts neben dem Befehl, um Zugriff auf die folgende Option zu haben.

Übereinstimmende Jointnamen

bei aktivierter Option werden nur Wichtungen von Joints, die den gleichen Namen wie in der Textdatei haben, geladen. Sie haben damit die Möglichkeit, Joints (Joints, deren Namen nicht in der Textdatei enthalten sind, werden ignoriert) auszuschließen. Darüber hinaus können auch Wichtungen von nicht passenden Hierarchien transferiert werden.

Hinweis:
Passende Namen betreffen nur Joint-Objekte, reguläre Objekte, die als Joints Verwendung finden, werden gemäß ihrer Reihenfolge im Objekt-Manager (von oben nach unten) behandelt. D.h. Sie müssen passende Hierarchien vorliegen haben, wenn Sie mit dieser Methode Wichtungen zwischen 2 Objekten transferieren wollen.

Speichere Wichtungen...

Hiermit können Sie Joint-Wichtungen der aktuell selektierten Objekte in eine externe Textdatei speichern. Dieser Befehl kann gut dazu verwendet werden, Wichtungen schnell zwischen 2 Charakteren auszutauschen, ohne Wichtungen per Kopieren und Einfügen (aus dem Wichtungs-Manager) zu übertragen.

In der Textdatei werden Namen (Objekt, Wichtungs-Tag, Joints/Objekt etc.) und Wichtungswerte für jeden Punkt gespeichert.

Um Wichtungsinformationen in einer Textdatei abzuspeichern, selektieren Sie im Wichtungs-Manager einfach das Objekt oder einen seiner Joints und rufen Sie Speichere Wichtungen. Es wird dann ein Datei-Speichern-Dialog eingeblendet, wo Sie den Speicherpfad eingeben können.

Speichern-Optionen

Klicken Sie auf das Icon rechts neben dem Befehl, um Zugriff auf die folgende Option zu haben.

Null-Wichtungen

Bei aktivierter Option, werden auch Joints/Objekte in der Textdatei gespeichert, die keine Wichtung haben. Das ist meist die gewünschte Methode, da dann immer passende Wichtungs-Transfers zwischen Joints/Objekt-Hierarchien gibt. Bei deaktivierter Option werden die Dateien kleiner und übersichtlicher. Das ist beispielsweise ganz praktisch, wenn Sie die Datei manuell editieren wollen.

Joint-Filter-Menü

In diesem Menü finden Sie alle nötigen Befehle, um die im Tab "Joints" angezeigten Joints zu filtern und zu ordnen.

Die verschiedenen Methoden, Joints in der Liste zu ordnen.

Sortierung ohne Hierarchie

In diesem Modus werden alle Joints auf der gleichen Ebene, in einer flachen, vertikalen Liste angezeigt. Die Reihenfolge entspricht der im Objekte-Manager, aber ohne dessen hierarchische Verschachtelung.

Hierarchische Sortierung

Diese Option zeigt die Joints so wie im Objekte-Manager an: mit allen Hierarchien.

Sortierung nach Namen

Hierbei werden alle Joints alphabetisch aufgelistet.

Sortierung nach Wichtungs-Tag

In diesem Modus wird die gleiche Reihenfolge wie in der Joint-Liste des Wichtungs-Tags eingehalten.

Liste mit OM-Selektion verknüpfen

Diese Option filtert in Abhängigkeit der Selektion im Objekte-Manager. Multiselektion wird unterstützt. Ist die Option deaktiviert, werden unabhängig von etwaigen Selektionen alle Objekte mit Wichtungs-Tag in der Liste aufgeführt.

Verriegelungsmodus

Mit dieser Option wird die aktuelle Joint-Listenfilterung verriegelt, sodass Sie Selektionen im Objekte-Manager wechseln können, ohne die Anzeige der Joint-Liste zu beeinflussen. Diese Option betrachtet aber ausschließlich die Objekt-Manager-Selektionen, die Filter- und Sortierungsoptionen sind nach wie vor wirksam und können geändert werden.