Cinema 4D Cinema 4D Prime Gestione Materiali Proprietà Materiali Parametri Texture
Funzione disponibile in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Gestione Texture

Tutti conoscono il messaggio di errore "textures cannot be found " che viene visualizzato quando le texture non vengono trovate durante il rendering. Le textures che sono state correttamente salvate in una certa directory, non si trovano più. Questo può accadere quando un progetto viene copiato e aperto su un computer diverso: il contenuto del Content Browser non è disponibile nella nuova versione di Cinema 4D e così via.

La Gestione Texture aiuta a risolvere questo problema, elencando tutte le texture di un determinato progetto e mostrando dove è possibile trovarle nel rispettivo Cerca Percorso. La Gestione Texture possiede anche numerose funzioni aggiuntive con le quali le texture possono essere ricollegate. Ad esempio può essere usata la funzione Sostituisci per sostituire tutti i percorsi texture JPEG con percorsi texture TIFF con lo stesso nome.

I percorsi relativi e assoluti delle texture sono indicati qui di seguito. Dettagli su questi termini possono essere trovati qui.

Esempio: Cosa fare se viene caricato un progetto e le texture vengono a mancare quando viene eseguito il rendering?

Nei casi più comuni, dove la cartella texture originale è stata spostata e il percorso delle Texture deve essere indirizzato alla nuova cartella, procedere come segue:


  1. Selezionare il comando Modifica | Seleziona Texture Mancanti. Questo selezionerà tutte le texture mancanti.
  2. Selezionare: Modifica | Ri-collega Textures. Si aprirà una finestra di selezione.
  3. Navigare fino alla cartella dove sono posizionate le textures e cliccare su Apri. Fatto. Tutte le texture sono ora correttamente collegate.
  4. Se desiderate, è ora possibile salvare il Progetto con TUTTE le texture (in una sub-directory chiamata "tex”) usando il comando Salva Progetto con Assets... (ad es. se si desidera zippare il Progetto).

Generale

Elenco Texture

L'elenco Texture visualizza tutte le texture presenti nel progetto attualmente aperto, incluse alcune proprietà descritte qui di seguito. Notare che con doppio clic su un elemento (es. nome, percorso o altra proprietà) è possibile modificarlo direttamente, senza ad esempio dover passare attraverso la Gestione Materiali, allo scopo di definire un nuovo percorso texture.

E’ possibile eseguire una selezione multipla delle textures usando il tasto Shift o Cmd/Ctrl (è possibile anche trascinare con il mouse una casella di selezione). I comandi che possono essere applicati agli elementi selezionati verranno applicati solo alla selezione.

Status

Sono disponibili 3 status per le texture:

Texture

Visualizza il nome della Texture.

Percorso Suggerito

Questo è il percorso assoluto per le texture salvato nei materiali. Se il percorso è relativo, viene visualizzato solo il nome del file.

Percorso Reale

Visualizza i percorsi completi reali, compresi quelli di texture con percorsi texture relativi. Per i percorsi assoluti, questo rappresenta il percorso suggerito descritto prima.

Nuovo Percorso File

Se si usa la funzione Sostituisci per cambiare il percorso, questa colonna serve da anteprima (prima che il pulsante Sostituisci venga cliccato) del nuovo percorso. Nell'immagine qui sopra è possibile vedere come la cartella "Textures" sia stata sostituita da "Immagini" nella colonna Nuovo Percorso file.

Percorso Materiale

Qui viene visualizzato il percorso all’interno di Cinema 4D (canale materiale / gerarchia shader o Gruppo Nodi / Nodo) che porta alla texture.

Materiale

Consente di visualizzare il nome del materiale corrispondente e l'icona. È possibile fare doppio clic sull'icona per aprire il materiale in Gestione Materiale.

Livello

Visualizza il Livello Cinema 4D in cui si trova il materiale a cui la texture appartiene.

Anteprima Immagine e Funzione Sostituisci

Sarà visualizzata un’anteprima della texture selezionata - se trovata - in basso a sinistra della finestra Gestione Texture. Sarà visualizzata anche la Dimensione e la Profondità Colore della texture selezionata.

A destra è possibile trovare le funzioni Sostituisci, che possono essere usate per selezionare un percorso, una directory o un nome diversi per le texture. Questo funziona nel seguente modo (a scopo dimostrativo sarà usata solo una singola texture):

Supponiamo di avere una sola texture nella directory di destinazione: "/Users/olibecker/Desktop/Bunny/Textur/Bunny.jpg"

Due anni dopo il progetto viene aperto e la texture non è più disponibile poichè la directory con la texture è stata spostata qui: "/Users/olibecker/Desktop/archived Projects/xxx/Texture/Bunny.jpg"

Per reindirizzare al nuovo percorso, inserire "Bunny” nel campo Sostituisci e "Progetti Archiviati” nel campo Con (Percorso Completo o Directory deve essere definito nel menu a discesa sottostante). Se le texture sono selezionate, sarà visualizzato un nuovo percorso assoluto nella colonna Nuovo Percorso file corrispondente. Se si fa clic sul pulsante Sostituisci, saranno modificati tutti i percorsi per i materiali selezionati.

La funzione Sostituisci utilizza la parte del vecchio percorso (o il nome della texture) definite nel campo Con.

Questo rende possibile sostituire vecchi percorsi con nuovi percorsi per più texture contemporaneamente.

Nel menu Selezione è possibile definire quale parte del percorso deve essere utilizzata dalla funzione Sostituisci. Il percorso può essere impostato come segue:

I caratteri descritti qui possono essere usati nel campo Sostituisci: * (qualsiasi Testo); ? (qualsiasi o singolo carattere); # (qualsiasi o singolo numero).

Esempio: Questi settaggi possono essere usati per sostituire tutti i nomi delle texture con un certo prefisso con texture con lo stesso nome e con prefisso "final_”.

Ovviamente questo funziona piuttosto bene solo se ci si attiene a convenzioni precise per la denominazione dei file, nel nominare i percorsi e le texture (ad es. suffissi precisi, numerazioni sequenziali o aggiunta di un prefisso "low_” che corrisponde, ad esempio, a immagini low-res che potrebbero in seguito essere sostituite con immagini high-res – che ovviamente avranno il suffisso "high_”). Usare tali convenzioni rende facile sostituire le textures o definire nuovi percorsi.

Menu

Menu Modifica

Tutti i comandi descritti qui sotto influenzano solo i percorsi texture all’interno di Cinema 4D – nessun cambiamento viene apportato ai file originali. Quanto segue si applica comunque: tutte le texture nascoste dal filtro non saranno interessate (eccezione: Deseleziona Tutto).

La maggior parte di questi comandi è resa disponibile anche cliccando con tasto destro in Gestione Texture.

Mostra File in Explorer/Finder

Visualizza il file nel Finder o in Explorer per ulteriori modifiche.

Apri File in Explorer/Finder

Apre il tipo di file e la corrispondente applicazione.

Apri File in Visualizzatore Immagini

Apre il file nel Visualizzatore Immagini di Cinema 4D.

RELEASE 20

Apri File in Gestione

Apre la Gestione corrispondente (Gestione Materiali, Gestione Nodi ecc) nella posizione in cui è collegato il file.

Apri Materiale in Gestione

Apre il materiale nella rispettiva Gestione (Gestione Materiali, Gestione Nodi ecc)

Seleziona Tutto

Seleziona tutte le texture visualizzate nella colonna Texture.

Deseleziona Tutto

Deseleziona tutte le textures (incl. quelle nascoste dal filtro).

Seleziona Texture Mancanti

Saranno selezionate tutte le texture visualizzate nell’elenco che non sono state trovate.

Inverti Selezione

Selezionare questo comando per invertire la selezione: le texture selezionate vengono deselezionate e quelle deselezionate risulteranno selezionate.

Seleziona Texture Materiali Attivi

Saranno selezionate tutte le texture dei materiali correntemente selezionati nella Gestione Materiali.

Mostra in Gestione Attributi

Questa opzione (non è un comando) definisce se i materiali delle Texture selezionate nella Gestione Texture devono essere visualizzati in Gestione Attributi oppure no.

Localizza Nome File
Globalizza Nome File

Entrambi i comandi creano o eliminano interi percorsi di file.

Localizza NomeFile rimuove i percorsi delle texture da tutte le texture selezionate e utilizza solo il nome del file. Questo, in sostanza, trasforma un percorso assoluto in un percorso relativo (vedi qui >). Questo avviene automaticamente se si salva un progetto utilizzando il comando Salva Progetto con Assets....

Globalizza NomeFile trasforma i percorsi relativi in percorsi assoluti (se nel materiale fornito esiste solo un nome e nessun percorso) per tutte le texture selezionate. L'intero percorso del file sarà poi utilizzato.

Collega Texture...

Selezionando questo comando si ricollegano le texture selezionate a texture con lo stesso nome nella directory selezionata. Il percorso verrà creato in base alla posizione: assoluta (al di fuori dei percorsi di ricerca di Cinema 4D ...) o relativa (... all'interno di percorsi di ricerca di Cinema 4D).

Questo comando può essere utile se proprio nessuna texture viene trovata. Questo è soprattutto il caso in cui la directory della texture è in una posizione completamente diversa. In questo caso, è sufficiente selezionare tutte le texture, richiamare questo comando e selezionare la directory corretta. Tutti i percorsi texture saranno poi reindirizzati di conseguenza in modo che tutto sia pronto per il rendering.

Sostituire Texture con...

Consente di assegnare un nuovo e unico file alle texture selezionate.

Cancella Texture

Usa questo comando per eliminare tutti i link alle texture selezionate. I link delle texture che collegano a file inesistenti (segnalati con una X rossa in Gestione Texture) possono per esempio essere eliminate nei canali dei materiali disabilitati.

Menu Visualizza

Barra di Ricerca

Selezionando questo comando viene visualizzata una barra di ricerca nella Gestione Texture, che può essere utilizzata per filtrare attraverso centinaia di texture, se necessario.

Selezionare il tipo di filtro dal menu a discesa accanto al campo di testo.

Utilizzando il campo di testo nessun elemento sarà selezionato. Questo è un filtro in tempo reale, dove semplicemente va inserito il testo. Sarà visualizzato ogni elemento il cui nome è composto anche solo in parte dal testo inserito nel campo di testo. Cliccando sulla x a sinistra del campo di testo il campo sarà resettato e tutti gli elementi saranno visualizzati.

Possono essere usati 3 caratteri speciali (come pure nel sottostante campo di testo Sostituisci):

I seguenti esempi possono dare un'idea più chiara:

A sinistra c'è un elenco non filtrato di texture, seguita da questi filtri (da sinistra a destra):

Texture
Percorso Suggerito
Percorso Reale
Nuovo Percorso File
Materiale
Percorso Materiale
Livelli

Usare queste opzioni per definire quali colonne devono essere visualizzate nella Gestione Texture.

Ciò è particolamente utile se le texture mancanti si trovano nelle colonne Materiale (potete fare un doppio clic sull’icona per aprire i materiali nell’ Editor Materiale) e Canale, che mostrano esattamente dove si trovano le texture mancanti.