Novità della R20

Riferimento Cinema 4D Cinema 4D Prime Gestione Materiali Nodi Materiale
Funzione disponibile in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Editor Materiale

Generale

L’Editor Nodi è quell’area dove avviene la creazione e la modifica dei Nodi dei Materiali (d’ora in poi chiamati semplicemente "Nodi”). Tutto quello che vedete nell’Editor Nodi deve essere collegato ad un Materiale Nodale (prendete nota di questo suggerimento) cioè, per creare e modificare un Nodo, è necessario che un Materiale Nodale sia selezionato. L’Editor Nodi mostra sempre il Materiale Nodale attualmente selezionato.

Desideriamo sottolineare che i Nodi sono abbastanza complessi e per usarli in modo efficace dovreste avere una discreta conoscenza di come funzionano in generale lo shading e il rendering. Ad ogni modo molte funzioni sono davvero semplici se utilizzate un materiale predefinito come il Materiale Uber, che è semplice tanto quanto un materiale normale (e può essere usato anche insieme ad un Nodo immagine in vari canali dei materiali).

Il flusso generale dei dati va sempre da sinistra a destra. All’estremità destra, tutto deve sempre terminare in un Nodo Materiale (nessun Nodo = nessun materiale funzionante; solo 1 Nodo Materiale per materiale).

Potete aprire l’Editor Nodi in questo modo:

Editor Nodi

Navigazione:

Potete navigare nell’Editor Nodi come nelle altre Gestioni con le seguenti abbreviazioni da tastiera (trovate altri comandi nel menu Vista):

Creare i Nodi

I Nodi possono essere creati nei seguenti modi:

Notate che non tutte le porte di output possono essere collegate a ogni porta di input. Sebbene molti tipi di file vengano convertiti automaticamente, esistono delle limitazioni (ad esempio, uno Shading Contesto non può essere connesso ad un TipoDati Booleano). Cinema 4D vi mostrerà se la connessione è possibile: se passate col mouse sulla porta a cui volete collegarvi, la potenziale connessione diventerà luminosa (possibile) oppure scura (impossibile).

Spostare i Nodi

I Nodi possono essere spostati in qualunque momento cliccando e trascinando. Le selezioni multiple saranno spostate come un unico elemento. Se avvicinate la selezione sul bordo dell’Editor Nodi, la vista inizierà a scorrere in quella direzione.

Collegare i Nodi

Affinché i dati passino da un Nodo all’altro, è necessario che siano collegati: questo vuol dire che gli output di un Nodo (lato destro) andranno collegati agli input dell’altro Nodo (lato sinistro). Potete fare così:

Si applica quanto segue:

Selezionare i Nodi

Potete selezionare i Nodi tracciando un rettangolo di selezione (cliccate semplicemente su un’area vuota nella vista dell’Editor Nodi e trascinate) o cliccandoci sopra. Come sempre, potete usare i tasti Shift e Ctrl/Cmd per aggiungere o togliere elementi dalla selezione. Nel menu Modifica troverete ulteriori comandi per la selezione (come Seleziona Connessi). I settaggi dei Nodi selezionati vengono visualizzati nella Gestione Attributi.

Cancellare i Nodi

I Nodi selezionati possono essere eliminati premendo i tasti Backspace- e Canc.

Viewport dell’Editor Nodi

Nella parte superiore della finestra centrale dell’Editor Nodi troverete i seguenti elementi (da sinistra a destra):

Il Navigatore

Troverete il Navigatore nell’angolo in basso a destra nella viewport dell’Editor Nodi. È un’immagine ridimensionata dell’intera costellazione del Nodo e serve per orientarsi meglio e navigare più velocemente, in particolare all’interno di Nodi complessi. Il triangolo grigio chiaro mostra la parte visibile della vista dell’Editor Nodi. Potete spostare questa sezione cliccando nel Navigatore e trascinando.

I seguenti Nodi vengono visualizzati in modo particolare:

Campi di Input e Output

Ai lati di ogni Nodo troverete due bordi scuri. Potete collegare le porte a queste aree rilasciando una connessione nuova su una zona vuota. Questo crea un collegamento verso l’esterno. Non ha molto senso per i Nodi singoli, ma se combinate più gruppi tra di loro potete usare questo metodo per creare una porta che verrà visualizzata come "porta di gruppo” (come nell’immagine sotto). Ciò significa che potete collegare dall’esterno (o come output verso l’esterno) una porta specifica di un Nodo del livello più basso anche in un gruppo che si trova all’interno di un gruppo.

Le porte dei Nodi che si trovano in un gruppo possono essere condotte verso l’esterno.

Quando una porta viene collegata ad un’area di input o output, si aprirà un piccolo menu (vedi immagine in basso a sinistra) con le seguenti opzioni:

Alcune delle funzionalità descritte sopra (per creare gli input) sono disponibili anche nei comandi del menu di scelta rapida della porta.

Informazioni generali sui Nodi

Esempio di impostazioni e di visualizzazione di un Nodo (è possibile mostrare anche solo le porte connesse).

Il componente principale del Sistema dei Materiali Nodali è logicamente il Nodo. Un Nodo ha un input dove vengono inseriti i dati provenienti da altri Nodi, i quali vengono poi elaborati e il cui risultato viene poi passato all’output. Gli input e gli output hanno delle porte dalle quali partono le connessioni ad altri Nodi. In sostanza, una porta di input può avere una sola connessione, mentre un output può averne molteplici.

Potete afferrare il bordo destro o sinistro del Nodo per allargarlo o restringerlo.

Un Nodo ha in genere un’area superiore e una inferiore:

Area superiore

L’area superiore contiene l’anteprima del Nodo. Se i settaggi dei Nodi di input collegati cambiano, l’anteprima verrà aggiornata. Potete mostrare o nascondere l’anteprima con l’iconcina alla sinistra del nome del Nodo (c’è anche un comando dedicato, vedi sopra).

Sotto l’anteprima, sulla sinistra, trovate il nome del Nodo, che viene visualizzato anche nella tab Base. Potete rinominare il Nodo con un doppio clic (potete fare così anche per i nomi delle porte, ma in questo caso l’operazione non sarà annullabile). Si noti che nella documentazione possono esserci delle differenze nei nomi dei Nodi/settaggi.

A destra del nome, se si tratta di un Gruppo di Nodi, troverete un’icona a forma di freccia. Cliccatela per mostrare i contenuti del gruppo nella vista dell’Editor Nodi. A destra della freccia, trovate invece le icone per la modalità Solo (vedi Solo).

È possibile cambiare il colore di sfondo dell’area superiore con l’opzione Colore Nodo Personalizzato (tab Base).

Area inferiore

L’area inferiore contiene: a sinistra, le porte di input con i propri nomi (possono essere rinominate con un doppio clic); a destra, le porte di output. Le porte possono essere nascoste e riordinate. Notate che non tutte le porte di input saranno elencate nel Nodo (possono essere visualizzate tramite il menu contestuale).

Alcuni Nodi (come il Nodo Livello, per esempio) hanno anche dei gruppi di porte a discesa per ogni livello.

In base al tipo di dato elaborato, ogni porta avrà un colore specifico (vedi prossimo paragrafo Tipi di Dati).

Le porte possono essere selezionate (tasti Shift o Ctrl/Cmd per aggiungere o rimuovere selezioni) per subire l’effetto di alcuni comandi (vedi menu Nodo o menu contestuale).

Tipi di dati e colori

Gli input e gli output sono contrassegnati con dei colori. I tipi di dati per gli input e gli output saranno visualizzati con i colori corrispondenti. I più importanti sono:

Come in XPresso, è possibile collegare tra loro anche input e output atipici. Di regola, avverrà una conversione costruttiva dei tipi di dati. Per esempio, una texture può essere collegata anche ad un input per un valore in virgola mobile. I valori RGB della texture saranno quindi convertiti automaticamente in valori luminosità. Con questo metodo, le texture colorate possono essere usate anche per controllare la Ruvidità di un livello BSDF. Il tipo di conversione dei dati è indicato nel Nodo ricevente come ulteriore punto nel rispettivo input.

Menu contestuale

Se cliccate col tasto destro la porta di un Nodo, si aprirà un ampio menu contestuale costituito principalmente da comandi del menu dell’Editor Nodi. Questi sono descritti qui, ad eccezione dei seguenti:

Filtro

Inserite qui una serie di caratteri per filtrare gli elementi visualizzati (saranno visualizzati solo i comandi, nodi, ecc. che contengono quei caratteri).

Aggiungi Input

Non tutti gli input elencati nella Gestione Attributi devono essere visualizzati come porte di un Nodo. A volte vengono mostrati solo i più importanti. Usate il comando Aggiungi Input per mostrare tutte le porte nascoste. Se ne selezionate una, sarà visualizzata di nuovo (se Tutto è selezionato, saranno rese visibili tutte le porte).

Questa voce di menu non sarà disponibile quando tutte le porte di input sono visualizzate.

Aggiungi Output

Di solito, tutti gli output sono visibili. Se alcune porte risultano nascoste (es. se è stato applicato Nascondi Porte Inutilizzate), potete visualizzarle selezionandole dall’elenco che trovate qui.

Connetti Nodo

Questo comando visualizza un elenco da cui potete selezionare un Nodo da collegare. Se sono disponibili più porte di output, cliccate sulla freccina nera e verranno visualizzate le porte che possono essere selezionate. Oltre all’elenco completo degli Asset, la prima voce sarà "Nodi esistenti” con elencati tutti i Nodi presenti al momento nella vista dell’Editor Nodi. Troverete anche l’opzione Aggiungi Input Gruppo con cui potete estrarre una porta da un gruppo (vedi anche Aree Gruppi di Input e Output).

Notate che questo elenco è dinamico e verranno suggeriti solo i Nodi disponibili.

Sostituisci Nodo

Questo comando sostituirà il Nodo di "alimentazione” della porta di input al momento connessa, con uno selezionabile dall’elenco. Notate che verrà eliminata l’intera catena di Nodi collegati al Nodo che viene sostituito. I Nodi connessi ad altre porte di output rimarranno invariati.

Inserisci Convertitore

Se sono già presenti delle porte collegate, sarà possibile usare questo comando. Verrà posizionato un Nodo Convertitore all’interno della connessione, cioè, i suoi input e output saranno già collegati correttamente.

Texture

Qui sono elencate tutte le texture caricate. Selezionatene una per collegarla alla porta di input.

Carica Texture

Con questa opzione si aprirà una finestra da cui potrete selezionare una bitmap o un video che saranno quindi collegati alla porta di input attraverso un Nodo Immagine.

Rimuovi Istanza Porta

Questo comando è disponibile per vari Nodi, come il Nodo Livello o Gradiente. Potete usarlo per eliminare elementi come i Livelli o Nodi.

Nascondi Porta

Con questo comando, tutte le porte selezionate saranno nascoste. Funziona solo per le porte che non hanno connessioni. Le porte nascoste appariranno quindi nell’elenco descritto prima in Aggiungi Input (e possono essere rese visibili da qui).

Notate anche il comando Mostra Tutte le Porte e i successivi due comandi lì descritti. È un’altra funzione per visualizzare le porte o meno.

Sposta Porta Su/Giù

Usate questi comandi per spostare le porte su o giù nella gerarchia.

Ripristina a Valore Predefinito

La maggior parte dei settaggi ha un valore predefinito che viene impostato alla creazione del Nodo. Con questo comando, i valori modificati saranno riportati al proprio valore iniziale. Ha effetto solo sui Nodi senza connessioni.

Propaga Porta

Richiamando questo comando (utile solo se nella vista dell’Editor Nodi è visualizzato il contenuto di un gruppo) si creerà una connessione alla gerarchia esterna o al genitore. Vedi anche Aree Gruppi di Input e Output.

Porta Solo (solo output)

Potete attivare una funzionalità Solo per i Nodi. Se il Nodo selezionato ha più output, uno di questi andrà definito come Porta Solo.

Imposta come Porta Anteprima (solo output)

Nella parte superiore di un Nodo troverete l’anteprima del Nodo. Se il Nodo ha output multipli, questa opzione può essere usata per definire l’output da mostrare nell’anteprima.

Blocca Gruppo
Sblocca Gruppo

Questi comandi possono essere usati per bloccare e sbloccare i gruppi selezionati. I gruppi bloccati possono essere visualizzati ma non modificati.

Connessioni

Per collegare una porta di un Nodo ad un’altra, seguite queste indicazioni.

Potete selezionare anche le connessioni (usate tasti Shift e Ctrl/Cmd per aggiungere o rimuovere selezioni o create un rettangolo di selezione). Cosa potete fare con le connessioni selezionate? Per esempio, potete eliminarle o modificarle con i comandi del menu contestuale descritti sotto (trovate solo i comandi non descritti altrove).

Rimuovi Connessione

Elimina le connessioni selezionate.

Porta Muta

Le connessioni mute (non attive) saranno mostrate con una linea tratteggiata. I valori non saranno accettati dai Nodi che prima erano connessi, ma saranno invece prelevati dalla Gestione Attributi. Questo vi permette, per esempio, di disattivare temporaneamente le connessioni per eseguire dei test.

Altre componenti dell’Editor Nodi

Le icone in alto a destra

In alto a destra dell’Editor Nodi si trovano le seguenti 5 icone, da sinistra a destra:

Gestione Attributi

La Gestione Attributi è presente nell’Editor Nodi in una forma leggermente modificata. La Gestione Attributi mostra le proprietà dei Nodi o dei Materiali Nodali. La maggior parte delle funzioni opera come descritto nella Gestione Attributi. Qui vengono descritte solo le principali differenze.

Create, ad esempio, un Nodo Spirale (dalla lista Asset: Forma/ Spirale):

Come potete vedere, nella Gestione Attributi sono elencate anche tutte le porte di input. La Gestione Attributi offre ancora più settaggi rispetto al Nodo. La Gestione Attributi contiene sempre TUTTI i settaggi. Il Nodo generalmente ne ha solo una parte come input o output; le tab dei settaggi Anteprima e Base non sono incluse.

Le porte di output non sono qui elencate perchè i loro valori sono il risultato di calcoli all’interno del Nodo, che possono essere cambiati solo indirettamente modificando i valori di input.

Connettori

La novità più importante rispetto alla precedente Gestione Attributi è che i campi collegati sono stati sostituiti dai Connettori. Gli input dei Nodi possono essere alimentati con i valori inserendo semplicemente i valori di certi settaggi o, e qui sta la novità, collegando gli input del Nodo ad output dei Nodi di altri Nodi, creando così una connessione (che è ciò su cui si basano i Nodi).

Cliccate sull’icona a destra del nome del settaggio (icona-connettore) e selezionate un Nodo dalla lista Connetti Nodo per collegarlo all’input selezionato (ovviamente, potete semplicemente collegare le porte nella vista dell’Editor Nodi). Il Nodo selezionato sarà creato e collegato:

Le bitmap possono essere trascinate in qualsiasi momento dall’esterno di Cinema 4D in una linea completamente parametrica ( incluso* il nome del parametro, l’icona di connessione ed elementi di interfaccia) per collegare un dato settaggio usando un Nodo Immagine.

Non appena un parametro è collegato ad un altro Nodo, si applica quanto segue:

L’icona di animazione mostra le dipendenze tra animazione e XPressions, mentre l'icona-connettore simboleggia le dipendenze tra shading e renderizzatore.

L'icona-connettore può avere uno dei 3 stati seguenti:

Se cliccate su un Connettore, saranno resi disponibili i seguenti comandi, che dovrebbero esservi già familiari dal menu contestuale delle porte. L'icona-connettore rende disponibile una funzione simile, che permette di accedere ad una porta nell’Editor Nodi con un clic destro.

Di seguito sono descritti solo i comandi del Connettore.

Aggiungi Livello

Questo comando è disponibile, ad esempio, nel Nodo Livello. Il Nodo selezionato sarà collegato ad un nuovo livello.

Copia

La porta di output collegata viene copiata nella cache.

Incolla (Link)

La porta di output copiata nella cache può quindi essere collegata ad una porta di input diversa. In questo modo, più input possono essere connessi alla stessa porta di output.

Incolla (Duplicato)

Questo comando collega la porta di output nella cache all’input che viene selezionato. Al contrario del comando precedente, verrà creato un duplicato dell’intero Nodo di alimentazione.

Rimuovi

Rimuove la connessione dalla porta di input.

Porta Muta

La connessione viene mantenuta ma non saranno trasferiti dati. Sarà invece usato, come input, il valore definito nella Gestione Attributi. Richiamate questo comando per riattivare il collegamento.

Mostra Sottocanali

Diversi Nodi offrono questo modo, come ad esempio il Nodo Livello o il Nodo Gradiente. Abilitate questo modo per visualizzare i settaggi del livello come parametri animabili o regolabili. Inoltre, potete visualizzare i settaggi di input del Nodo di alimentazione attivando uno dei livelli. Nell’esempio seguente, gli input sono quelli del Nodo Cerchio.

Per il Nodo Gradiente (cliccate su un Nodo e su uno dei connettori subordinati per richiamare il comando), saranno visualizzati i settaggi di tutti i Nodi. Richiamate questo comando per ritornare al modo precedente.

Eredita Interfaccia

Diversi Nodi, come il Nodo Distanza o Valore, possono ereditare le unità e la visualizzazione dei parametri delle proprie porte di input dai Nodi connessi successivamente.

Lista Nodi

In alto a sinistra troverete la lista Nodi, dove vengono visualizzati tutti i Nodi e Gruppi presenti al momento nella gerarchia. Qui potete:

A tal proposito: l’ordine della lista non ha alcun effetto o significato.

Icona Cerca

Cliccate sull’icona Cerca in alto a destra per mostrare la barra del filtro. Inserite una stringa di caratteri per nascondere tutti i Nodi che non contengono questi caratteri.

Lista Asset

Nella lista Asset troverete tutti i Nodi presenti all’interno di Cinema 4D ( visualizzati in gruppi a discesa) oltre agli Asset personalizzati (il Comando Nodi ha la stessa funzione e può essere richiamato dall’Editor Nodi con il tasto c). Da questa lista, potete creare i Nodi che verranno poi visualizzati nella vista dell’Editor Nodi. Per accedere rapidamente ad un Asset, è stato integrato un filtro dove potete digitare una serie di caratteri per escludere gli elementi che non li contengono.

Esempio: il Nodo Gradiente Colore contiene all’interno le parole chiave "correzione, tonalità, HSL, HSV”, ecc. Se inserite questi termini, il Nodo verrà automaticamente individuato. Un altro esempio potrebbe essere con i nomi dei Disturbi (es. Luka, Stupl, ecc.), che potete usare per trovare i Nodi Disturbo. Qui potete inoltre usare una funzione speciale: se create un Asset contenente "Stupl”, verrà settato sul Tipo Disturbo Stupl. Funziona anche, per esempio, con il Nodo Mix (tipo "moltiplica”).

Per alcuni Nodi (come il Nodo Mix) potete spingervi oltre. Per esempio, se filtrate "moltiplica sfondo” (più termini vengono combinati con un AND logico) e create un Nodo Mix, entrambi i menu di selezione del Modo Mix e Usa Alfa saranno impostati di conseguenza.

Naturalmente, sarà trovato anche il nome del Nodo stesso (che avrà una priorità più alta rispetto alle parole chiave).

Nella lista Asset potete creare delle selezioni multiple (usate Shift e Ctrl per aggiungere o rimuovere selezioni). Trascinate tutti gli Asset selezionati nella vista dell’Editor Nodi o fate doppio clic su una delle selezioni per crearle tutte.

Un Asset può essere creato con un doppio clic anche dalla lista filtrata. In alternativa, potete anche usare i tasti freccia per navigare e selezionare gli Asset con tasto Invio.

Altrimenti, potete aprire e chiudere un Gruppo selezionato usando i tasti freccia Sinistra e Destra.

Oltre agli Asset, la lista Asset contiene una colonna Database, che mostra dove sono salvati gli Asset. Per esempio, se è visualizzato "Integrato”, dovete sapere che si tratta di un cosiddetto "core Asset” (Asset integrato), cioè un Nodo base creato da MAXON che non potrete "esaminare”. Altri Asset sono Asset integrati combinati in gruppi (che invece possono essere ”esaminati”), come ad esempio i database con nomi come Utilità o Materiali.

Per quanto rigiuarda le Preferenze o i database nominati dall’utente, o gli asset importati, non essendo asset generati da MAXON non sono salvati nel menu Preferenze (cartella userrepository) ne altrove.

Potete trovare maggiori informazioni sulla creazione e gestione degli Asset alla sezione Asset (qui sono descritti tutti i comandi del menu contestuale).

Area informazioni

In basso a sinistra troverete l’area Informazioni dove sono contenute tutte le informazioni riguardanti Nodi, le connessioni e le porte.

Per i Nodi:

Ulteriori informazioni per le connessioni:

Ulteriori informazioni per le porte:

Menu Editor Nodi

Menu File

Crea Gruppo Vuoto

Crea un gruppo vuoto per il Materiale Nodale corrente.

Cliccate sull’icona a freccia per aprire il gruppo.

Cos’è un Gruppo?

I Gruppi sono, in poche parole, dei Nodi genitori che contengono una rete di Nodi (e/o anche gruppi). Le porte dei Nodi in questi gruppi possono anche essere ampliate (propagate) verso l’esterno per comprendere valori dai Nodi esterni al gruppo o per accedere ai valori dei Nodi all’interno del gruppo.

I Gruppi possono essere convertiti in Asset e condivisi.

Potete anche selezionare più Nodi e raggrupparli usando il comando seguente.

Raggruppa Nodi

Raggruppa i Nodi selezionati (vedi anche comando precedente).

Separa Nodi

Separa i Nodi raggruppati e cancella il Nodo Gruppo. Le connessioni sono mantenute, per quanto possibile anche all’esterno.

Nota:
Per dissolvere gli Asset, prima devono essere convertiti in gruppi.

Crea Porta di Input
Crea Porta di Output

Crea nuove porte di input/output. È utile solo per i Nodi all’interno di un gruppo (vedi anche Area Gruppo di Input e Output).

Propaga Porta

Con questo comando, potete creare dei parametri per le porte di input per tutte le porte selezionate. Vedi Area Gruppo di Input e Output per le differenze tra porte di input e output e le porte propagate.

Comandi Asset

Potete trovare altri dettagli sugli Asset su Asset.

Crea Asset...

Gli Asset sono spesso creati dai Nodi Gruppo (un processo esemplificativo è descritto qui).

Non appena questo comando viene richiamato per un certo Nodo (o anche più comandi, che saranno elaborati nell’ordine di chiamata), si aprirà una finestra di dialogo:

Nome

Definisce il nome dell’Asset. Questo Asset apparirà con il suo nome nella lista Asset. Questo nome apparirà anche nell’area Informazioni se lo utilizzate come istanza nell’Editor Nodi (cioè, lo trascinate dalla lista Asset nella vista dell’Editor Nodi). Anche se rinominate il Nodo, questo resterà invariato.

Tag Versione

Gli Asset possono avere diverse versioni. Immaginate di creare un Asset, di costruire un scena che lo utilizza, e di salvare la scena. Modificate poi l’Asset (con un clic destro sull’Asset dalla lista Asset: Modifica Asset) cambiatene il colore o aggiungeteci un Nodo, per esempio. Se ora salvate l’Asset (Salva Nuova Versione) potrete usare il Tag Versione per definire una versione (es. 1.1 o Versione 2, ecc.). L’Asset conterrà quindi sia la versione vecchia che quella nuova.

Se caricate la scena salvata precedentemente o riutilizzate l’Asset, sarà usata la versione più recente. Potete ad ogni modo passare da una versione all’altra nell’istanza dell’Asset (il Nodo Gruppo):

Il controllo delle versioni (cosiddetto "versioning”) può anche essere spiegato così: supponiamo di avere salvato un cubo base in Cinema 4D R15. Nella R18 aggiungete un settaggio Smussatura. Se si carica la scena della R15 nella R18, in genere entra in scena la funzione di compatibilità che permette di "caricare la versione precedente”. Se questa opzione è attiva, il cubo viene caricato senza smussatura; se è disabilitata, le smussature saranno presenti. Tuttavia, a volte, il cubo viene caricato senza nessun preavviso riguardo allo stato precedente. Se il controllo delle versioni fosse applicato anche alle primitive, potreste fare avanti e indietro tra le versioni a piacimento.

MAXON può aggiornare i Nodi e i Materiali Nodali integrati tramite l’Aggiornamento Online. L’aggiornamento viene eseguito in modo che le vecchie scene rimangano funzionali.

Ciò che viene definito nel Tag Versione apparirà in seguito nell’istanza dell’Asset come nome della versione dell’Asset.

ID

Qui viene assegnato un ID univoco (non dovete inserire nulla) che identifica chiaramente un Asset all’interno dell’applicazione. Questo ID, integrato con una stringa casuale, viene poi visualizzato nell’area Informazioni nell’Editor Nodi quando un Nodo è selezionato.

Database

Gli Asset possono essere salvati in database diversi.

Solitamente vengono offerte le seguenti opzioni:

Questo menu è dinamico e mostrerà tutte le posizioni corrispondenti.

Categoria
Nome Nuova Categoria

Se osservate la lista Asset, vedrete numerosi Asset in categorie organizzate in ordine alfabetico. Potete aggiungere nuove categorie in ogni momento (anche queste sono Asset).

L’Asset scelto sarà salvato nella categoria selezionata. Se selezionate Nuova Categoria, potrete crearne una nuova tramite l’opzione Nome Nuova Categoria. Gli Asset personalizzati possono essere trascinati e rilasciati in altre categorie.

Cliccando su OK l’Asset sarà salvato nella lista Asset e sarà visibile nel Comando Nodi da dove potrà essere usato.

Converti Asset in Gruppo

I Nodi degli Asset, che vengono solitamente creati a partire dai gruppi, possono essere riconvertiti in Gruppi con questo comando. L’icona a freccia sarà visualizzata nuovamente.

Questo aprirà il gruppo.

Salva nuova Versione...

Quando si modificano degli Asset esistenti, le modifiche apportate dovranno essere salvate con questo comando. Si aprirà una finestra che dovrebbe risultarvi familiare dal comando Salva Asset (vedi sopra). Dato che anche lo stato precedente dell’Asset è stato salvato, saranno implementate le versioni multiple.

Salva come nuovo Asset (copia)...

Quando si modificano degli Asset esistenti, potete salvare un nuovo Asset senza che esso venga salvato come una nuova versione. Si aprirà una finestra che dovrebbe risultarvi familiare dal comando Salva Asset (vedi sopra).

Chiudi Modo Modifica Asset

Se aprite un Asset con il comando Modifica Asset, passerete al modo Modifica Asset. Con questo comando ne uscirete. Potreste ricevere l’avviso se volete salvare o scartare le modifiche apportate all’Asset. I cambiamenti apportati agli Asset devono essere confermati (es. con Salva Nuova Versione).

Menu Modifica

Annulla
Ripeti

Questi sono i soliti comandi con cui potete cancellare i cambiamenti apportati nella Gestione Attributi o annullare/ripetere alcune funzioni. Diversamente dall’editor di XPresso, spostare o espandere i Nodi non viene considerato come una di queste funzioni.

Taglia
Copia
Incolla

Qui potete copiare nella cache i Nodi selezionati (con Taglia, i Nodi saranno anche cancellati) e incollarli con Incolla nell’Editor Nodi.

Duplica

I Nodi selezionati saranno duplicati (privi però delle connessioni).

Cancella

I Nodi selezionati saranno eliminati. Potete fare lo stesso con i tasti Backspace- o Canc.

Seleziona Tutto
Deseleziona Tutto

Seleziona o deseleziona tutti i Nodi.

Seleziona Connesse

Seleziona tutti i Nodi connessi a quello selezionato. In questo modo potete selezionare rapidamente una serie di Nodi connessi.

Comando Nodi

Il Comando Nodi offre delle funzionalità simili ai collegamenti nella lista Asset dell’Editor Nodi. Per aprire la lista dovete semplicemente premere il tasto c. L’Editor Nodi deve però essere attivo.

Oltre a quelle descritte nella lista Asset, il Comando Nodi offre le seguenti funzioni:

Menu Nodo

Mostra Anteprima
Nascondi Anteprima

Questi comandi possono essere usati per mostrare o nascondere l’anteprima del Nodo (nella parte superiore del Nodo). Il menu Preferenze dell’applicazione ha una tab Materiale dove un settaggio predefinito definisce se l’anteprima di un nuovo Nodo deve essere mostrata oppure no. Perchè dovreste voler nascondere l’anteprima dal momento che fornisce delle informazioni utili? Nel caso di reti di Nodi molto estese servirebbe davvero tanto tempo per aggiornare tutte le anteprime quando apportate delle modifiche. Ecco quando potrebbe rivelarsi utile nascondere l’anteprima!

Layout Orizzontale
Layout Verticale

Un layout verticale a sinistra, un layout orizzontale a destra.

Usate questi settaggi per definire come devono essere disposte nel Nodo le porte di input e output:

Mostra Tutte le Porte
Nascondi Tutte le Porte

Nascondi Tutte le Porte nasconde l’area delle porte per tutti i Nodi selezionati (con un doppio clic su un Nodo si avrà lo stesso effetto). Le connessioni saranno mantenute. È un effetto puramente visivo, per avere una migliore visione d’insieme nell’area di lavoro. Con un altro doppio clic o con il comando Mostra Tutte le Porte si avrà l’effetto opposto.

Le porte selezionate possono essere nascoste anche dal menu contestuale. In questo caso, il comando Mostra Tutte le Porte non le renderà nuovamente visibili. Dovrete renderle di nuovo visibili con il comando Aggiungi Input.

Mostra Porte Connesse

Per il Nodo selezionato, verranno visualizzate solo le porte dotate di connessioni. Tutte le altre saranno nascoste. Potete annullare con il comando Mostra Tutte le Porte.

Imposta Solo per Porta / Nodo
Disattiva Solo

Diversi Nodi definiti come Nodi Solo, texture renderizzata su un cubo.

Il Nodo Solo omette tutti gli altri Nodi. Nella vista dell’Editor Nodi e per il rendering saranno considerati e visualizzati solo i Nodi collegati al Nodo Solo, oltre al Nodo Solo stesso. È utile per esempio se l’anteprima del vostro Nodo risultasse troppo piccola, dato che si può visualizzare o renderizzare l’effetto dei singoli Nodi in qualsiasi dimensione.

Potete usare questo comando se avete selezionato un Nodo (possibilmente con una porta di output selezionata: vedi anche Porta Solo) o semplicemente cliccando sull’icona S del Nodo.

Ovviamente è possibile avere un unico Nodo Solo alla volta. Per uscire dalla funzione Nodo Solo, utilizzate il comando Svuota Solo o cliccate di nuovo sull’icona S.

Imposta come Nodo Iniziale
Svuota Nodo Iniziale

I Materiali Nodali possono essere composti di reti molto fitte di centinaia di Nodi. Se volete apportare delle piccole modifiche ad un materiale e non volete dover esplorare tutto l’Editor Nodi, potete definire un Nodo (uno solo per Materiale) come Nodo Iniziale. Quando il materiale è selezionato, gli input di questo Nodo (e solamente questi) saranno visualizzati nella Gestione Attributi o nella tab Input dell’Editor Materiale.

D’altra parte, se volete visualizzare solo alcune porte e state lavorando con i gruppi, potete propagare dal gruppo le porte di cui avete bisogno e definire il Nodo Gruppo come Nodo Iniziale.

I Nodi Iniziali saranno evidenziati da una cornice verde (se non sono selezionati) o da una gialla (se sono selezionati).

Nell’esempio seguente supponiamo di voler visualizzare solo il settaggio Bracci del Nodo Spirale, come settaggio controllato dall’esterno. Procedete così:


  1. Posizionate tutti i Nodi in un gruppo. Selezionateli e scegliete Raggruppa Nodi dal menu contestuale. Aprite il gruppo (cliccate sull’icona a freccia del Nodo Gruppo).
  2. Cliccate con il tasto destro sulla porta Braccia del Nodo Spirale e selezionate Propaga Porta dal menu contestuale.
  3. Uscite dal gruppo cliccando su ”Nodo” nel Nome del Materiale o del Gruppo
  4. Selezionate il Nodo Gruppo e scegliete Imposta come Nodo Iniziale (menu Nodo)

Appena selezionate il Materiale Nodale, sarà visualizzato solo il settaggio Braccia (immagine in basso a destra).

Se ora cliccate col tasto destro sul Nodo Gruppo e selezionate Crea Asset, l’Asset risulterà già pronto!

Il comando Svuota Nodo Iniziale elimina lo stato di Nodo Iniziale.

Apri in Editor Materiale

Apre l’Editor Materiale per il materiale visualizzato al momento nell’Editor Nodi. Solitamente, l’Editor Materiale contiene gli stessi settaggi della Gestione Materiale per un dato materiale.

Seleziona in Gestione Materiali

Questo comando seleziona nella Gestione Materiali il Materiale Nodale attivo nell’Editor Nodi, e i suoi settaggi verranno quindi visualizzati nella Gestione Attributi.

Rimuovi Nodi Inutilizzati

I Nodi inutilizzati sono i Nodi privi di connessioni (i gruppi pieni e i materiali non sono inclusi). Non avendo utilità, possono essere cancellati con questo comando.

Nascondi Porte Inutilizzate

Questo comando funziona solo se esiste almeno una connessione per ogni gruppo di porte di input o output: per i Nodi selezionati, tutte le porte senza connessioni verranno nascoste (possono essere mostrate di nuovo con i comandi Aggiungi Input e Aggiungi Output). In caso contrario le porte rimarranno visibili.

Menu Vista

Mostra Selezionati

Se alcuni Nodi si trovano al di fuori della vista dell’Editor Nodi, potranno essere visualizzati tutti insieme con questo comando. La vista verrà scalata in modo che tutti i Nodi siano visibili.

Mostra Tutti

Mostra tutti i Nodi presenti nella vista dell’Editor Nodi. La vista verrà scalata proporzionalmente.

Centra Selezionati

I Nodi selezionati verranno visualizzati al centro della vista senza cambiare lo zoom. Per selezioni multiple, il centro dei Nodi selezionati sarà portato al centro della vista.

Centra Tutto

Tutti i Nodi saranno posizionati al centro della vista senza cambiare lo zoom.

Zoom Avanti
Zoom Indietro

Allarga o riduce la vista dell’Editor Nodi. Potete farlo più rapidamente con il mouse insieme al tasto 2.

Zoom 100%

Supponiamo di avere una rete di Nodi composta di 376 Nodi: non vedrete molti dettagli nella vista! Questo comando imposta lo zoom ad un 100% sufficientemente leggibile.

Mostra Griglia

Nasconde o mostra la griglia nella vista dell’Editor Nodi. Lo snap griglia funziona in modo autonomo con questa visualizzazione.

Snap Griglia

Attiva o disattiva lo snap griglia. Se attivo, i bordi dei Nodi si allineeranno alle linee della griglia.

Mostra Gruppi di Connessioni

Attivate questa opzione per visualizzare i gruppi di connessioni (Wires). Vedi anche Aree Gruppi di Input e Output. Si tratta spesso di connessioni verso l’esterno che oscurano la vista perchè molto numerosi (ecco perchè potete anche disattivare questa opzione).

Connessioni Bezier

Le connessioni sono rappresentate da curve per impostazione predefinita. Attivate questa opzione per far apparire le connessioni come linee dritte.

Mostra Navigatore

Mostra o nasconde il Navigatore.

Mostra Errori

Se un Nodo crea degli errori o se vengono inseriti dei dati non validi, apparirà una cornice rossa (cercate poi i messaggi di errore nella lista Nodi o nell’area Info per maggiori dettagli). Questa cornice verrà nascosta se disattivate l’opzione Mostra Errori.

Aumenta

Quando si lavora con i gruppi, spesso bisogna scavare al loro interno (il che significa che l’Editor Nodi mostra il contenuto di un dato gruppo). Richiamate questo comando se volete salire di un livello, cioè, uscire da quel gruppo. In alternativa, accanto al nome del materiale o del gruppo, potete cliccare il livello sul quale volete spostarvi.

Mostra Selezionati
Allinea Tutti

Con questo comando, tutti i Nodi, o quelli selezionati, saranno disposti in modo da essere visibili nella vista attuale: saranno compattati, ordinati e allineati orizzontalmente/verticalmente.

Prima e dopo aver richiamato il comando Visualizza Tutto.

Scena di esempio

Il seguente materiale è stato creato esclusivamente tramite i Nodi. Non sono state usate bitmap o texture!

Caricate la scena seguente:


Ecco un’idea di cosa potete fare con i Nodi. Cliccate il materiale con il tasto destro e selezionate Editor Nodi per vedere la configurazione del Nodo. Notate il Nodo Gruppo Plaid in cui sono presenti ulteriori reti di Nodi.