Cinema 4D Prime Gestione Oggetti Menu Tag Tag Cinema 4D Tag Texture
Funzione disponibile in CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D
Tag Texture

Base Tag Coordinate

Proprietà Tag

Materiale

Potete assegnare un materiale al Tag Texture trascinando il materiale dalla Gestione Materiali e rilasciandolo in questo box. Se sono selezionati più Tag Texture, il materiale sarà applicato a tutti i Tag. Se cliccate sul triangolo a dx del box Materiali, apparirà un menu con i seguenti comandi:

E’ possibile animare questo campo per il morph dei materiali, cioè per creare perfette transizioni da un materiale all’altro.

Pulisci

Rimuove i materiali dai Tag Texture.

Mostra in Gestioni

Mostra i materiali nei Tag Texture nella Gestione Materiali.

Seleziona Elemento

Seleziona i materiali dei Tag Texture nella Gestione Materiali

Selezione

Selezione vi permette di usare materiali diversi su diverse parti dello stesso oggetto. Questo è un modo facile e conveniente per aggiungere, per esempio, etichette agli oggetti. Prima di tutto vi servirà un tag Selezione. Potete anche inserire un nome (nella tab Base del tag Selezione in Gestione Attributi) o semplicemente trascinate il tag in questo campo.

Questa funzione lavora in modo gerarchico, ciò significa che un tag Texture con definito un campo Selezione proietterà il materiale su tutti gli oggetti Figli con un tag Selezione corrispondente.

Potete leggere qui ulteriori informazioni riguardanti le selezioni.

Suggerimento:
Quando posizionate una texture in una selezione, potrà essere d’aiuto nascondere le superfici non selezionate. Potete nasconderle dal menu Selezione Nascondi Deselezionati.

Notate anche le selezioni nascoste di specifici Generatori: Materiali diversi applicati alle superfici, ai tappi e alle smussature.

Proiezione

I settaggi Offset e Lunghezza definiscono la posizione e la dimensione della texture nella direzione X e Y sulla superficie nell’oggetto. Per esempio, se le lunghezza XY sono entrambe settate a 100%, la texture coprirà l’intera superficie.

Sferica

La mappatura sferica proietta la texture sull’oggetto in forma sferica.

Sferica applicata ad un piano.
Sferica applicata ad un cilindro.
Sferica applicata ad una sfera.

La proiezione sferica è raramente adattabile ad un oggetto piano. Si ottiene una distorsione anche applicandola come forma cilindrica.

Cilindrica

La mappatura cilindrica proietta la texture sull’oggetto in forma cilindrica.
Cilindrica applicata ad un piano.
Cilindrica applicata ad un cilindro.
Cilindrica applicata ad una sfera.

La proiezione cilindrica è raramente adattabile ad un oggetto piano. Si ottiene una distorsione anche applicandola ad un oggetto sferico.

Quando la proiezione cilindrica è applicata ad un cilindro, notate come i pixel vicini alla parte alta e a quella bassa della mappa texture vengono tirati verso l’interno sui tappi. Dovreste applicare texture separate a questi ultimi.

Piatta

La mappatura piatta proietta la texture sull’oggetto in una direzione planare.

Mappatura piatta applicata ad un piano.
Mappatura piatta applicata ad un cilindro.
Mappatura piatta applicata ad una sfera.

La proiezione piatta tende ad essere usata solo con oggetti piatti. La texture viene subito distorta se applicata ad una sfera o a un cilindro, come mostrano gli esempi.

Cubica

La mappatura Cubica proietta la texture su tutti i sei lati di un cubo texture.

Cubica applicata ad un cuboide.

Frontale

La texture viene proiettata dalla posizione della camera sull’oggetto. Questo assicura che, se proiettate la texture su un oggetto Poligono e su un oggetto Sfondo, le due texture combaciano perfettamente (ammesso che i tag Texture per entrambi gli oggetti utilizzino lo stesso Offset e la stessa Lunghezza).

Frontale applicata ad un cuboide.

Potete creare vari effetti speciali utilizzando la mappatura Frontale. Potete anche effettuare compositing direttamente in Cinema 4D. Probabilmente avrete visto film di fantascienza in cui personaggi o astronavi scomparivano gradualmente sullo sfondo. Utilizzate la mappatura Frontale per questo tipo di effetti. Per un altro effetto interessante, rimuovete l’oggetto Sfondo e spostate il poligono.

Spaziale

La mappatura Spaziale è simile alla proiezione Piatta. Tuttavia, con la mappatura Spaziale, la texture viene tirata in alto e a sinistra appena passa attraverso l’oggetto
Piatta
Spaziale

La mappatura Spaziale provoca comunque alcune distorsioni e per questo non è adatta ad immagini fotografiche. La mappatura Spaziale è più adatta a texture strutturali, come cemento e marmo.

Mappatura UVW

Se un oggetto ha coordinate UVW, potete selezionarle come tipo di proiezione. In questo caso, la geometria texture è fissata alla superficie dell’oggetto ed è soggetta a tutti i conseguenti movimenti e deformazioni applicati all’oggetto. La proiezione UV è descritta nel menu Modifica UV.

Un esempio di mappatura UVW è la pagina di un libro che viene girata. Prima dovete fissare la texture (ad esempio, utilizzate del testo e una bella

immagine) alla pagina utilizzando la mappatura UVW. In seguito, animate la pagina che viene girata con una deformazione. La texture è descritta in

Mappatura Piatta (sinistra) e mappatura UVW (destra).

Tutte le primitive di Cinema 4D e gli oggetti Generatori hanno coordinate UVW. Se applicate una nuova texture a questi oggetti, il tipo di proiezione nel tag Texture passerà automaticamente a mappatura UVW. Tutti gli oggetti Poligono con coordinate UVW avranno il tag UVW in gestione Oggetti.

Le primitive e gli oggetti Generatori hanno coordinate UVW interne e non hanno un tag UVW in gestione Oggetti. Potete comunque usare la mappatura UVW con questi oggetti. Se convertite una Primitiva o un oggetto Generatori in un oggetto Poligono, il tag UVW apparirà in gestione Oggetti.

Potreste chiedervi perché ci sono tre coordinate (UVW)

Perchè abbiamo tre coordinate?

Le texture convenzionali hanno due coordinate, una per la posizione orizzontale X e una per la verticale Y. Per rendere più chiaro che le coordinate UVW fanno riferimento ad una texture, X viene rinominata U e Y viene chiamata V. Le due coordinate (U e V) sarebbero sufficienti se non fossero per 3D shader. Queste sono texture tridimensionali e come tali richiedono una terza coordinata (W) per poter essere fissate all’oggetto.

Più di una struttura geometrica UVW.

Potete applicare più di una texture UVW ad un oggetto. Create un nuovo tag Texture per l’oggetto, quindi impostate la proiezione che desiderate, come ad esempio Piatta per la texture di un’etichetta. In seguito, create nuove coordinate UVW per la texture attiva selezionando Genera Coordinate UVW dal menu Texture in gestione Oggetti. Il tag Texture selezionato verrà impostato su mappatura UVW e si deformerà insieme all’oggetto.

Viene aggiunto un nuovo tag UVW a quelli esistenti ogni volta che richiamate Genera Coordinate UVW. Un tag Texture (mappatura UVW selezionata) utilizza sempre la mappa UVW direttamente sulla sua destra nella gestione Oggetti. Questo consente di assegnare mappe UVW diverse a tag Texture diversi. Se non c’è nessun tag UVW sulla destra del tag Texture, verrà usato il primo tag UVW.

La struttura delle coordinate UVW.

Qual è la struttura delle coordinate UVW? Immaginate una griglia divisa nelle direzioni U e V (Figura

1 sotto).

Figure 1.

Il campo UV inizia a 0, 0 e finisce a 1, 1. Per un poligono in alto a destra, 0, 0 descrive la posizione in alto a sinistra; 0, 1 quella in alto a sinistra; 1, 0 in alto a destra; 1, 1 in alto a destra.

Una texture viene "stirata” fra queste quattro coordinate (Figura 2).

Figure 2.

Ma dov’è la coordinata W in questo sistema? Ricordate che le texture convenzionali sono

bidimensionali: la coordinata W è creata solo quando necessario. Una volta creata, la coordinata W

si comporta allo stesso modo delle coordinate UV.

Mappa UVW Selettiva

Cinema 4D ha due modi di posizionare proiezioni texture sulle selezioni di poligoni (piuttosto che sull’intero oggetto come descritto sopra). Il primo metodo è descritto sotto. Per dettagli sul secondo metodo, vedete sopra.

La mappatura UVW selettiva vi permette di applicare diversi tipi di proiezioni in diverse regioni dell’oggetto utilizzando la stessa geometria texture.

Procedete come segue:


  1. Create una sfera e convertitela in un oggetto poligonale con Rendi Modificabile.
  2. Create un nuovo materiale con una texture, ad esempio lo shader scacchiera e impostate la proiezione su Piatta.
  3. Selezionate lo Strumento Poligoni e selezionate diversi poligoni in varie posizioni.
  4. Nel menu Tag Gestione Oggetti, selezionate il comando Assegna Coordinate UVW.

I poligoni UV selezionati usano la proiezione Piatta mentre quelli non selezionati continuano ad usare la mappatura UVW normale. Se deformate l’oggetto, la texture rimane fissa nella regione selezionata.

Avvolgente

Con questo tipo di proiezione, il centro della texture viene fissato al polo nord di una sfera e il resto della texture viene stirato sulla sfera. Il vantaggio di questo tipo di mappatura è che la texture incontra se stessa solo al polo sud. Questo evita un’interruzione della texture tra i poli. Viene usata solo una sezione circolare della texture, con il centro del cerchio corrispondente al centro dell’immagine. Il resto dell’immagine viene scartata.

Avvolgente.

RELEASE 20

Visualizza Proiezione

Visualizza Proiezione Semplice, Griglia e Piena
.

Usate questo settaggio per definire come deve essere visualizzato nella Viewport l’assistente che visualizza la proiezione (che può essere regolato nella Viewport):

  • Semplice: sara visible solo la forma della proiezione
  • Griglia: saranno mostrate le griglie utilizzate nelle versioni precedenti alla R20
  • Piena: verrà visualizzata la texture che vedete a destra, il che rende più semplice misurare l'orientamento

Se Proiezione è impostato su Mappatura Frontale, sarà sempre mostrata una griglia.

Camera Mapping

Con il Camera Mapping, la texture viene proiettata dalla camera sull’oggetto.

Suggerimento:
Il Camera Mapping ha una propria Gestione, vedi Projection Man, che offre tutte le opzioni necessarie per il Camera Mapping. Questa Gestione offre anche molte automazioni e diminuisce il numero di regolazioni da eseguire manualmente come la creazione di una camera, l’assegnazione di una camera ad un tag texture, ecc.

Immaginate di voler usare una foto e di doverla far interagire con i vostri modelli. Ad esempio, potreste volere che una figura 3D cammini dietro ad alcuni oggetti nella foto. Potete creare questo effetto proprio con il Camera Mapping.

Per prima cosa, caricate la foto nel canale Luminanza di un nuovo materiale. Applicate il materiale all’oggetto con il Camera Mapping. Per questo avrete bisogno di una camera per proiettare il materiale sull’oggetto. Attivate questa camera nella viewport (viewport: Camere / Usa Camera / XXX).

Quindi ricostruite (modellate) ogni oggetto presente nell’immagine reale a cui la figura (o altro soggetto) dovrà passare dietro.

Ad esempio, se desiderate che nella foto la figura in 3D passi dietro ad una grata, create per prima cosa la grata in 3D (è molto semplice - serve solo un supporto per la texture creata). Poi, proiettate la texture dello sfondo sull’oggetto ricostruito (la grata) utilizzando il Camera Mapping. Ora potete far camminare il vostro personaggio dietro alla grata.

Tenete a mente le limitazioni del Camera Mappinga. Per esempio, non potete compiere una rotazione completa di 360° intorno ad un edificio. La foto in genere è già distorta dalla prospettiva stessa, così, a determinate angolazioni, avrete una distorsione nella distorsione e una bassa qualità delle texture

Lato

Supponiamo di proiettare una texture su un tubo con una mappatura Piatta. Se spostiamo la camera intorno per dare un’occhiata all’altra parte della superficie, vedremo ancora la texture, ma questa sarà nella posizione sbagliata. Potete risolvere questo problema utilizzando una mappatura selettiva - un materiale che viene proiettato solo su un lato della superficie.

La direzione delle normali di superficie di ciascun poligono gioca un ruolo fondamentale nel decidere su quale lato la texture viene mappata.

Fronte: la mappatura avviene in direzione delle normali di superficie; Retro: avviene nella direzione opposta alle normali di superficie (Figura 1 sotto).

Figura 1.

Con la Proiezione Piatta, una texture viene proiettata davanti e dietro un oggetto. Come risultato, la texture è visibile anche dove non vorremmo; in questo caso, sul davanti come sul retro del tubo (Figura 2).

Figura 2.
Figura 3.

Potete evitare questi problemi con una mappatura selettiva. Cambiate Lato da Entrambi a Frontale. Ora renderizzate di nuovo il tubo. Questa volta l’etichetta è visibile solo sulla parte frontale (Figura 3). Se l’angolo di visuale (ad esempio, l’angolo camera) e la normale di superficie formano un angolo di meno di 90° l’uno con l’altro, il poligono è un poligono frontale; altrimenti è un poligono posteriore (Figura 4).

Figura 4.

Le uniche eccezioni sono la mappatura Frontale e Spaziale. Qui ci sono alcuni criteri aggiuntivi: la direzione dell’asse Z della proiezione della texture. Se i punti dell’asse Z della texture puntano nella direzione opposta alla normale di superficie e l’angolo di visuale e la normale formano un angolo minore di 90°,l’uno con l’altro, il poligono è un poligono frontale; altrimenti, è un poligono posteriore (Figura 4).

Entrambi

La texture viene proiettata su Fronte e Retro di ogni poligono, a prescindere dal tipo di mappatura selezionato.

Entrambi.

Fronte

Vedete la texture dove le normali di superficie puntano verso la camera, altrimenti il materiale è invisibile.

Fronte.

Retro

Vedrete la texture soltanto dove le normali delle superfici puntano inversamente alla camera, altrimenti il materiale è invisibile.

Retro.
Texture 1 Fronte; Texture 2 Retro

Settaggi Gestione Attributi

Camera

Trascinate la camera che dovrebbe proiettare la texture nel Campo di testo.

Settaggi texture migliorati per il Camera Mapping (Film e Pixel Aspect).>

Aspetto Pellicola [0.01..10000]

Definisce l’aspect ratio della texture proiettata. Ciò sarà determinato automaticamente quando si utilizza Projection Man o quando si clicca sul pulsante Calcola.

Il menu Selezione fornisce un elenco di formati pixel predefiniti.

Aspetto Pixel [0.01..10000]

Se il rapporto pixel dell’immagine non è 1:1, inserite il rapporto qui. Notate che il rapporto sarà sempre settato su 1:1 quando cliccate sul pulsante Calcola, in quanto l’informazione sul rapporto non è registrato in bitmap. Il menu Selezione fornisce un elenco di formati pixel predefiniti.

Calcola

Cliccando su di esso, i valori Film Aspect e Pixel Aspect (sempre 1:1) vengono settati alla dimensione della bitmap. Per renderizzare la scena con la stessa dimensione della bitmap, settate Risoluzione nei Settaggi di Rendering (tab Uscita) alla stessa dimensione della bitmap.

Offset U [-∞..+∞%]
Offset V [-∞..+∞%]
Lunghezza U [-∞..+∞%]
Lunghezza V [-∞..+∞%]

L’Offset e la Lunghezza definiscono la posizione e la dimensione della texture nelle direzioni U e V sull’involucro texture. Ad esempio, se Lunghezza U e Lunghezza V sono entrambi impostati al 100%, la texture copre completamente la superficie.

Ripeti U [-∞..+∞]
Ripeti V [-∞..+∞]

I valori Ripeti rappresentano il numero di volte che la texture viene ripetuta per riempire la superficie nelle direzioni U e V (Lunghezza U e Lunghezza V).

Non è la stessa cosa che cambiare la lunghezza?

Esatto, in effetti potete cambiare la lunghezza sia in termini di ripetizioni (Ripeti U, Ripeti V), sia come una percentuale della superficie (Lunghezza U, Lunghezza V). In entrambi i casi, cambiarne uno provocherà il cambiamento dell’altro. Notate che la texture sarà ripetuta solo se l’opzione Ripeti è abilitata.

Cinema 4D calcola la dimensione di una singola ripetizione dalla dimensione attuale della texture in direzione U e V. Ad esempio, se avete scalato la texture in modo che abbia una lunghezza di 25% nella direzione U e 50% in V, la texture riempie quattro volte la direzione U (1, 0.25) e due volte nella direzione V (1, 0.5) sulla superficie. Se cambiate Ripeti U o Ripeti V, la Lunghezza cambia di conseguenza. Ad esempio, se cambiate il numero a 3, la texture si restringe da 50% a 33.33%.

sinistra: 50%; destra: 33%

Ripetizioni U [0..100000]
Ripetizioni V [0..100000]

Se definite la dimensione della Ripetizione tramite i valori Ripetizioni U/V, potete utilizzare i valori Ripetizione per definire quante volte la ripetizione deve ripetersi in tutte le direzioni. Nelle precedenti versioni di Cinema 4D (nelle versioni precedenti alla R12), l’intero spazio UV veniva sempre riempito. Ora, ad esempio, possono essere proiettate solo due ripetizioni in ogni direzione.

Ripeti

Se questa opzione è attiva, l’immagine della texture sarà ripetuta all’infinito sulla superficie. L’effetto diviene visibile se scalate la texture o quando la geometria della texture non viene adattata con il comando Adatta all’Oggetto. Altrimenti, la texture riempie la geometria dell’oggetto una sola volta.

Se questa opzione è disattiva, la mappa texture non verrà ripetuta sulla superficie. Qualsiasi materiale sottostante verrà mostrato nelle parti non coperte dalla ripetizione della texture.

Suggerimento:
Se abilitate questa opzione per uno shader 2D o 3D questo non è, strettamente parlando, ripetuto, ma riempie piuttosto l’intero oggetto senza soluzione di continuità. Potrebbero esserci o meno ripetizioni in base alla programmazione dello shader.

Senza Cuciture

Se l’opzione Senza Cuciture è abilitata, le Ripetizioni sono specchiate per evitare cuciture visibili. Questo qualche volta porta ad un effetto farfalla nel modello (simile ad una macchia d’inchiostro/prova Rorscach), o provocherà un pattern simile ai motivi delle tappezzerie antiquate.

Suggerimento:
Senza Cuciture è generalmente utilizzato per piccole texture fotografate, sebbene si possano creare interessati patterns. Questa opzione è adatta per pattern tipo legno sassi o marmo.

Usa UVW per Rilievo

Suggerimento:
Per ottenere un effetto rilievo dev’essere abilitato il canale rilievo.

Prima di Cinema 4D R8.2, il rilievo veniva sempre proiettato usando la mappatura sferica, nonostante fosse definita la mappatura UVW. A partire dalla versione R8.2, è stata usata la mappatura UVW, ammesso che il tag Texture avesse selezionato Mappatura UVW. Questo può creare problemi vedi immagine seguente.

Difetti con lo shader Disturbo nello shader Rilievo. Usa UVW Per Rilievo attivo.

Possono comparire degli effetti in certe aree ai bordi tra due poligoni UV vicini, soprattutto quando si usa lo shader Disturbo con un valore Delta elevato. Questo è causato dalla discrepanza fra i sistemi di coordinate dell’oggetto poligono e del poligono UV mappato. Questo è un problema

comune che può essere risolto solo aumentando la risoluzione della geometria. In alternativa, potete usare la vecchia variazione che veniva adottata in automatico precedentemente alla versione 8.2. Tuttavia, ricordate che ciò comporterà dei difetti ai poli e inoltre non supporta il riallineamento delle UVW (soprattutto con la mappatura ottimale).

Applicare un’etichetta ad una bottiglia

Fatto. Probabilmente la texture copre tutto l’oggetto, ma ora potete scalarla

Selezionate lo strumento Scala, quindi selezionate lo strumento Assi Texture. Potete trascinare per ridurre la scala della texture. Poi, selezionate lo strumento Muovi e posizionate la texture nella posizione desiderata sulla superficie dell’oggetto.

La texture è spesso leggermente fuori proporzione dopo la scalatura. Selezionate il tag Texture e, in gestione Attributi, impostate la Lunghezza come desiderato. Dato che la lunghezza non può andare oltre il 100%, potreste aver bisogno di dividere entrambi i valori.

Per esempio, se la vostra texture è di 800x600 pixel, potrete definire la lunghezza come segue:

Lunghezza XLunghezza YFattore di Conversione
8060/ 10
86/ 100
3224/ 100 x 4

ecc.

Mixare le Texture

Cinema 4D vi permette di utilizzare quanti materiali e tag Texture desiderate su un oggetto. Pensate ad una valigia con degli adesivi: c’è un materiale di base (la pelle della valigia) con molti materiali sopra (gli adesivi).

Non potete vedere il materiale originale della valigia (la pelle) nei punti in cui ci sono gli adesivi. Inoltre, supponete che alcuni adesivi si sovrappongano. Se volete vedere un adesivo che sta sotto agli altri, dovete rimuovere uno di quelli posati sopra o fare un buco per vederci attraverso.

Questa analogia è abbastanza simile al comportamento di Cinema 4D. Il vostro oggetto ha un materiale di base. Per vederlo, i materiali sovrastanti devono essere scalati e non ripetuti. Cosa che potete fare scalando la geometria della texture e, allo stesso tempo, disattivando l’opzione Ripeti. Se due materiali si sovrappongono e volete vedere quello più in basso, dovete fare un buco in quello sopra. Potete fare ciò usando il canale alfa o la mappatura ritaglia.

Come può sapere Cinema 4D su quale livello si trova un materiale?

Quando applicate diversi materiali, ciascun nuovo materiale viene posto sopra il precedente. Così l’ordine dei tag Texture in Gestione Oggetti definisce l’ordine dei livelli: il materiale più a destra è il livello più alto, quello più a sinistra è il materiale più in basso. Potete cambiare l’ordine dei livelli semplicemente cambiando la posizione dei tag Texture usando drag-and-drop.

Suggerimento:
La proprietà materiale Trasparenza non permette di vedere attraverso il materiale successivo. Utilizzate piuttosto materiali con canali Alfa o mappature clip (genlocking).
Figura 1.

Nell’esempio sopra, il materiale T1 è stato definito come materiale muro, T2 come materiale poster, il quale non è stato piastrellato ma scalato, e T3 per i graffiti, il quale è stato creato utilizzando un canale Alfa.

T1-T2-T3 sono dei livelli posizionati l’uno sull’altro partendo dal basso verso l’alto.

Poiché il materiale superiore, T3, è stato fatto utilizzando un canale Alfa, i materiali T2 e T1 sono visibili. E poiché la geometria della texture del materiale T2 è stata scalata e la Ripetizione è disattivata (molto importante!) essi non ricoprono l’intero oggetto superficie, quindi anche parte del materiale T1 è visibile.

Mixa Texture

Il materiale mattoni è stato creato utilizzando un canale colore e un canale rilievo. Il canale rilievo crea l’illusione dei mattoni con fughe in basso-rilievo. Ora vogliamo aggiungere una seconda mappa rilievo alla parete senza cambiare la texture stessa. Come si fa?

La potente opzione tag texture che rende possibile tutto questo è chiamata Mixa Texture e si trova nella pagina Tag in gestione Attributi, per un tag texture selezionato.

Con "Ripeti” intendiamo che le proprietà materiale vengono messe insieme, da qui il termine texture aggiuntive. Ad esempio, aggiungiamo due texture che hanno canali colore diversi: rosso e verde; la somma dei colori RGB 100,0,0 (rosso) e 0,100,0 (verde) è 100,100,0 (giallo). Se il colore verde ha una luminosità del 50%, allora viene aggiunto solo 50% del colore. Il risultato in questo caso sarebbe 100,50,0 (arancione). Tuttavia, il risultato non può eccedere il valore massimo del colore. Aggiungere 100,0,0 a 100,100,0 non dà 200,100,0, ma 100,100.0.

Alcuni canali non possono essere mixati in maniera sensata. Ad esempio, mixare due materiali, ciascuno con un indice di rifrazione pari a 1 risulterebbe in un materiale con indice di rifrazione 2, che probabilmente non era ciò che si intendeva. In questi casi, viene usato il valore del materiale aggiunto (quello più a destra, ammesso che il canale sia attivo).

Suggerimenti:

  • Potete aggiungere quante texture desiderate.
  • Solo i seguenti canali sono aggiunti: Colore, Trasparenza, Riflettanza, Rilievo, Displacement, Luminanza.
  • Vengono valutate solo le proprietà attive.
  • Una texture aggiuntiva dev’essere alla destra della texture cui dovrebbe essere aggiunta in gestione Oggetti.
  • Vengono aggiunte tutte le texture a sinistra della prima texture aggiuntiva fino alla texture successiva non-aggiuntiva, esclusa quest’ultima.

Suggerimenti:
Potete mixare più texture all’interno dello stesso tag Texture usando lo shader Livello o lo shader Fusione. Questi shader comprendono un’ampia varietà di modalità di blending, rendendo possibile la creazione di più effetti diversi.

Ritornando all’esempio del muro.

Figura 2.

Nell’immagine sopra potete vedere il risultato del mix del materiale T2 con il materiale T1.

Nei capitoli precedenti avete imparato ad applicare e mixare i materiali in una singola superficie.

Ora voglia mettere assieme entrambe le cose, quindi su un singolo oggetto utilizzeremo più materiali, aggiungendoli l’uno sull’altro.

Per il nostro esempio basato sui graffiti, sono stati utilizzati cinque materiali. In ordine da sinistra (T1) a destra (T5): T1 (muro), T2 (poster) e T4 (graffiti) sono materiali normali. T3 e T5 sono materiali aggiuntivi e T4 ha un canale Alfa addizionale.

Ecco svelato il mistero della visualizzazione dei materiali nella Gestione Oggetti da sinistra a destra:

Per prima cosa, T2 viene calcolato con T3, inoltre T2 ha anche una struttura addizionale. Poiché T2 non è piastrellato, T1 è visibile. T4 viene calcolato in aggiunta a T5, e anche T4 ha una struttura addizionale. Dal momento che T4 è mascherato con un canale Alfa, T1 e T2 sono visibili attraverso ad esso.

Mixa Texture

Se questa opzione è attiva, i materiali saranno mixati con i materiali di base. Per i dettagli sul mixaggio delle texture, vedere Mixa texture.