--- title: "Compositing with ACES" url: "https://help.maxon.net/r3d/houdini/en-us/Content/html/Compositing%2Bwith%2BACES.html" section_path: "Redshift Render Options > Color Management - OCIO & ACES > Compositing with ACES" description: "Example image provided by Saul Espinosa can be downloaded below." --- # Compositing with ACES You are here: # Compositing with ACES ## Overview ![Image: ACES_Comp_Intro_Examplea9f1.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_Comp_Intro_Examplea9f1.png) > **Note:** Example image provided by Saul Espinosa can be downloaded below. > > [Compositing_with_ACES_Example.zip](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Downloads/Compositing_with_ACES_Exampleac30.zip) > > Contents: > > - ACEScg_OCIO_Example.exr - Primary example image to be used in ACEScg compositing workflow. > - Output Example JPEGs - Example JPGs provided as both correct and incorrect output results to compare with your own results. > **Note:** The examples on this page use the ACES 1.0 SDR-Video view transform but this can be substituted with the ACES 2.0 SDR-Video view transform. You should use the same view transform you used to preview your renders in Redshift. > **Tip:** ## ACES in Autograph > > **Click here for ACES in Autograph workflow...** > > ### Step 1 > > Start by bringing your footage in and add it to a composition. Then click on the settings icon in the upper right: > > | | > | --- | > | ![Image: OCIO_Comp_Autograph_Settings.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_Settings.png) | > > - Set the OpenColorIO config to the same one used to render your scene in Redshift > - This example uses the default Redshift config in this example. > - Set the Display Colorspace to the same one used to preview your render in Redshift > - This example uses ACES 1.0 SDR-video > > | | > | --- | > | ![Image: OCIO_Comp_Autograph_Config_Setup.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_Config_Setup.png) | > > ### Step 2 > > Before moving on, let's make sure our footage is being interpreted correctly. This can be done by selecting the footage layer and making sure the "File Colorspace" is set to "ACEScg." > > | | > | --- | > | ![Image: OCIO_Comp_Autograph_Footage_ACEScg.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_Footage_ACEScg.png) | > > ### Step 3 > > Next create an Adjustment Layer *above* the footage in the composition and rename it "OCIO View Transform." > > | | > | --- | > | ![Image: OCIO_Comp_Autograph_Adjustment_Layer.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_Adjustment_Layer.png) | > > Then select the Adjustment Layer (1), add an OCIO Colorspace modifier (2), and set the Input Colorspace to "ACEScg" and the Output Colorspace to the same one you used in Redshift (3), we'll use the display space "ACES 1.0 SDR Video." > > | | > | --- | > | ![Image: OCIO_Comp_Autograph_Adj_OCIO.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_Adj_OCIO.png) | > > ### Step 4 > > Now your footage looks correct inside of Autograph and you can render out to a video or image sequence and retain the OCIO Colorspace and effects correctly. > > | | | > | --- | --- | > | ![Image: OCIO_Comp_Autograph_wACES.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_wACES.png) | ![Image: OCIO_Comp_Autograph_noACES.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_noACES.png) | > | *Correct OCIO view transform* | *Raw linear preview* | > > > **Note:** ### Reminder > > > > The correct way to adjust ACEScg footage with this workflow should be done *above* your ACEScg footage but *below* the "OCIO Colorspace" adjustment layer. This is demonstrated below with a Color Correct modifier being applied to an adjustment layer titled " *Color Correct*" in between the two layers. > > > > You want to apply any color corrections first to the ACEScg footage when still linear so it must be done in this order before the View Transform converts your image to non-linear. This also means that you can composite *multiple* ACEScg openEXRs render layers all under the same *one* "OCIO Colorspace" adjustment layer. > > > > | | | > > | --- | --- | > > | ![Image: OCIO_Comp_Autograph_wACES_Exp.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_wACES_Exp.png) | ![Image: OCIO_Comp_Autograph_noACES_Exp.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIO_Comp_Autograph_noACES_Exp.png) | > > | *Correct layer order* | *Incorrect layer order* | > **Tip:** ## ACES in Photoshop > > There are multiple ways to add an ACES transform to footage in Photoshop, the most common methods are covered below. > > ### ACES via native OCIO in Photoshop (version 26+) > > **Click here for the native OCIO in Photoshop workflow...** > > ### Step 1 > > First set up OCIO in Photoshop as pictured below by clicking on "OpenColorIO Settings" in the Edit menu. Then use the following settings: > > - "Enable OpenColorIO Features" > - Set the Default Configuration to "cg-config..." > - Set the Default Settings "Working Space" to "ACEScg" and click on "Ok" to continue. > > | | > | --- | > | ![Image: OCIOn_PS_Setup.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIOn_PS_Setup.png) | > > ### Step 2 > > Next open your rendered image using the "Open as OpenColorIO" option in the File menu. In the option box set the Input Color Space to "ACEScg." > > | | > | --- | > | ![Image: OCIOn_PS_Step_01.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIOn_PS_Step_01.png) | > > ### Step 3 > > Immediately your render should perfectly match what was seen in the Redshift render view. This is because it should be using the exact same color space and view transform used by default in Redshift. > > The current view transform can be seen by clicking on the OCIO button outlined in the image below. The "View" should be set to "ACES 1.0 - SDR Video" and the "Display" should be set to sRGB - Display." > > | | > | --- | > | ![Image: OCIOn_PS_Step_02.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIOn_PS_Step_02.jpg) | > > ### Step 4 > > In this state your image is fully ready to be edited in the linear ACEScg working space and viewed with the ACES 1.0 - SDR Video view transform. This ensures that making changes like increasing the exposure behave as they would in Redshift, allowing you much more control and flexibility than editing without OCIO in a non-linear space. > > | | > | --- | > | ![Image: OCIOn_PS_Exposure.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIOn_PS_Exposure.jpg) | > > ### Step 5 > > After you're done editing your image you need to convert it to a non-linear color space before exporting as a PNG, JPG, or other file format. To convert your image, use the "Duplicate to Profile" option in the Edit menu as demonstrated below. This opens an option box with a critical step to perform, by default Photoshop is set to use the color space "Adobe RGB (1998)" for the Target Settings "Profile," however this is the wrong color space to use when the image has been previewed using the sRGB - Display view transform. > > Instead change the Profile to "sRGB IEC61966-2.1" and click "Ok." After this your image is copied to a new regular Photoshop file — a non-OCIO file — with the correct view transform baked in and is ready for export using the same methods you are used to like Export and Save for Web. > > | | > | --- | > | ![Image: OCIOn_PS_Step_03.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/OCIOn_PS_Step_03.jpg) | > > ### Adobe RGB vs sRGB > > As an example, if you use Adobe RGB instead of sRGB in the last step the image might look similar but it will not be correct for the default Redshift render settings. Adobe RGB has a wider color gamut than sRGB and results in more saturated colors. > > In the example below the sRGB and Adobe RGB versions are masked using a stripe pattern for comparison. The more saturated areas, starting on the left, use the Adobe RGB conversion while the stripe starting on the right uses sRGB — the correct color space for this example. > > | | > | --- | > | ![Image: sRGB_vs_Adobe_RGB.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/sRGB_vs_Adobe_RGB.jpg) | > > ### ACES via fnord OCIO Plugin for Photoshop (Legacy) > > **Click here for the fnord OCIO plugin for Photoshop workflow...** > > ### Step 1 > > In older versions of Photoshop the best way to use ACES is to download and make use of the **[fnord plugin OpenColorIO for Photoshop](https://fnordware.blogspot.com/2017/02/opencolorio-for-photoshop.html)**. > > ### Step 2 > > First open your ACEScg footage in Photoshop. > > ![Image: Photoshop_ACES_Step_1.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_1.png) > > ### Step 3 > > Then convert your ACEScg layer to a smart object. > > > **Important:** This is a very important step if you will be doing any editing. All adjustments must occur *inside* of the ACEScg smart object itself in order to properly make use of the ACES workflow. > > ![Image: Photoshop_ACES_Step_1a184c.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_1a184c.png) > > ### Step 4 > > Then apply the OpenColorIO plugin as a smart filter to your ACEScg footage layer. > > ![Image: Photoshop_ACES_Step_25e2f.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_25e2f.png) > > ### Step 5 > > Then set your OCIO config file path. > > Set the mode to "***Display***" > > Input Space: ***ACEScg*** > > Display: ***sRGB*** (or your *own* monitor's display color space) > > View: ***ACES 1.0 SDR-video*** (or the same View transform *you* were using in Redshift) > > ![Image: Photoshop_ACES_Step_32640.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_32640.png) > > ### Step 6 > > Now the ACEScg footage is being previewed with the correct Output Transform*but* it still does not look correct in Photoshop, this is due to an extra gamma correction that Photoshop is applying. > > ![Image: Photoshop_ACES_Step_49743.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_49743.jpg) > > ### Step 7 > > To counteract this gamma correction issue apply *another* OpenColorIO smart filter to the ACEScg footage, but this time with different settings. > > Use the same configuration file used last time. > > Set the mode to "**Convert**" > > Input Space: ***sRGB*** > > Output Space: ***scene-linear Rec.709-sRGB*** > > ![Image: Photoshop_ACES_Step_5501f.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_5501f.png) > > ### Step 8 > > Now the ACEScg footage looks correct and is working properly with its two OpenColorIO transforms. > > ![Image: Photoshop_ACES_Step_644dd.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_644dd.jpg) > > > **Note:** ### Reminder > > > > The correct way to adjust ACEScg footage with the Photoshop workflow above is only possible inside the smart object itself as demonstrated in the video below. > > > > [Video: Photoshop_Correct_Adjustments.mp4](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Videos/Photoshop_Correct_Adjustments.mp4) > > ### ACES via a LUT in Photoshop (Legacy) > > **Click here for ACES via LUT in Photoshop workflow...** > > > **Important:** This method will *only* work with an sRGB output space and when Photoshop is in 32bits/Channel mode. > > > **Note:** **Required download: Photoshop LUT**\ > > Credit to Alex Fry for this method and the LUT used. > > > > You will need to download the following LUT to use this method:\ > > [ACEScg_Photoshop_SceneLinear_to_DisplayLinear_Transform_DimSurround.csp](https://github.com/alexfry/PureNukeACES/tree/master/Luts) > > > > For more information please see [this post on ACES Central.](https://community.acescentral.com/t/aces-photoshop-friendly-workflows/1369/30) > > ### Step 1 > > First open your ACEScg footage in Photoshop. > > ![Image: Photoshop_ACES_Step_1.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_Step_1.png) > > ### Step 2 > > Next go to **Edit > Assign Profile**. > > ![Image: ACES_PS_Assign_Color_Profile.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_Assign_Color_Profile.png) > > ### Step 3 > > Set the Profile to **ACEScg**. > > ![Image: ACES_PS_ACEScg_Profile.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_ACEScg_Profile.png) > > Now your image will probably look a whole lot nicer and more saturated but we're still not quite there yet, most noticeably the highlights are clipping much more harshly than we would expect and in general the whole image might be brighter. > > ![Image: ACES_PS_ACEScg_Profile_After.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_ACEScg_Profile_After.jpg) > > *In-progress result after assigning the ACEScg color profile* > > ### Step 4 > > Next, from the Layers panel, create a new **Adjustment Layer > Color Lookup**. > > ![Image: Photoshop_ACES_LUT_Step_2.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_LUT_Step_2.png) > > ### Step 5 > > Next you must load the appropriate LUT from the Color Lookup's Properties panel seen below. > > Click on the *"Load 3D LUT"* drop down and then click on the *"Load 3D LUT..."* text to bring up a file open dialog. > > ![Image: Photoshop_ACES_LUT_Step_3.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Photoshop_ACES_LUT_Step_3.png) > > ### Step 6 > > Navigate to where you saved the downloaded LUT file:\ > [ACEScg_Photoshop_SceneLinear_to_DisplayLinear_Transform_DimSurround.csp](https://github.com/alexfry/PureNukeACES/tree/master/Luts) and select it, your Color Lookup properties should look like the image below when set up correctly. > > ![Image: ACES_PS_Color_Lookup_Properties_Applied.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_Color_Lookup_Properties_Applied.png) > > > **Note:** You may need to select the CSP file type in order to be able to see and select the LUT from the file browser as seen in the image below. > > > > ![Image: ACES_PS_LUT_CSP_Dropdown.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_LUT_CSP_Dropdown.png) > > ### Step 7 > > Now the ACEScg footage looks great and is working as expected with the properly setup Color Lookup Adjustment Layer. > > ![Image: ACES_PS_ACEScg_LUT_Applied.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_ACEScg_LUT_Applied.jpg) > > > **Note:** **Reminder** > > > > The correct way to adjust ACEScg footage with this Photoshop workflow is above your ACEScg footage but below the Color Lookup adjustment layer. This is demonstrated below with an Exposure effect being applied to an adjustment layer titled "Exposure 1" in between the two layers. The reason for this is that you want to apply any color corrections to the ACEScg footage when it is still linear so it must be done before the Output Transform conversion that converts your image to non-linear via the Color Lookup. This also means that you can composite multiple ACEScg openEXRs render layers all under the same one Color Lookup adjustment layer. > > > > | | | > > | --- | --- | > > | ![Image: ACES_PS_LUT_Correct_Adjustment.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_LUT_Correct_Adjustment.jpg) | ![Image: ACES_PS_LUT_Incorrect_Adjustment.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/ACES_PS_LUT_Incorrect_Adjustment.jpg) | > > | *Correct color correction result and layer order* | *Incorrect color correction result and layer order* | > **Tip:** ## ACES in After Effects > > ### ACES via native OCIO in After Effects (version 23.2+) > > **Click here for the native ACES in After Effects workflow...** > > ### Step 1 > > First import your ACEScg footage into After Effects and place it in a new composition, by default you will find your render probably looks wrong and washed out as seen in the example image below. > > | | > | --- | > | ![Image: AfterEffects_Native_Import.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Import.png) | > > ### Step 2 > > Now set up your Project Settings. This can be found either by clicking the small button at the bottom of the Project panel circled in the image below or going to **File > Project Settings.** > > | | > | --- | > | ![Image: After_Effects_Native_Project_Settings.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/After_Effects_Native_Project_Settings.png) | > > ### Step 3 > > Under the **Color** tab's **Color Management** section set the following settings: > > Color Engine: ***OCIO color managed*** > > OCIO Configuration: ***ACES 1.3 CG v1.0*** > > By default the **Color Settings** should be set up correctly with the following settings: > > Bit Depth: **32 bits per channel (float)** > > Working Color Space: **scene_linear: ACEScg** > > Display Color Space: sRGB - **Display/ACES 1.0 - SDR Video** > > > **Note:** If you were using a different Display Color Space (Output Transform) to preview your renders in Redshift you must match that here in After Effects. For example, if you were using an un-tone-mapped view transform in Redshift. > > | | > | --- | > | ![Image: AfterEffects_Native_OCIO_Setup.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_OCIO_Setup.png) | > > ### Step 4 > > Now the ACEScg footage is being previewed with the correct ACES Output Transform in the composition viewer and can be worked on in a proper ACES workflow but there is a possibility that your imported footage is being interpreted incorrectly and the colors may appear more saturated than they should be. > > | | > | --- | > | ![Image: AfterEffects_Native_Correct_Preview.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Correct_Preview.png) | > > ### Step 5 > > To fix this, it is a good idea to make certain that your renders are being correctly interpreted as "ACEScg" color space rather than "ACES2065." > > Right click your imported footage and navigate to **Interpret Footage > Main** and set the **Override Media Color Space** to **ACES/ACEScg** under the **Color** tab as pictured below. > > | | | > | --- | --- | > | ![Image: AfterEffects_Native_Interpret_Settings.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Interpret_Settings.png) | ![Image: AfterEffects_Native_Interpret_Footage.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Interpret_Footage.png) | > | Opening the Interpret Footage panel | Interpret Footage in ACEScg color space | > > | | | > | --- | --- | > | ![Image: AfterEffects_Native_Correct_ACEScg.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Correct_ACEScg.png) | ![Image: AfterEffects_Native_Incorrect_ACES2065.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Incorrect_ACES2065.png) | > | Correct: ACEScg color profile | Incorrect: ACES2065 color profile | > > ### Step 6 > > Now your ACEScg footage should match what was seen in the Redshift render view and can be edited in an ACES workflow but there is one more key step to consider before rendering - you must match the Output Color Space with the Display Color Space (Output Transform) that you have been using to preview your footage in the viewer. > > To do this, add a composition to the **Render Queue** and click on the blue text to the right of the **Output Module** as pictured below. > > | | > | --- | > | ![Image: AfterEffects_Native_Open_Output_Module.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Open_Output_Module.png) | > > ### Step 7 > > In the **Output Module Settings** panel under the **Color** tab enable the "**Show All**" option and set the **Output Color Space** to the same Display Color Space that you have been using (sRGB - Display/ACES 1.0 - SDR Video by default) and disable the **Embed color space** option as pictured below. Now your renders should look the same in final output as they did in the Redshift render view and After Effects composition viewer. > > | | > | --- | > | ![Image: AfterEffects_Native_Output_Module_Settings.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Native_Output_Module_Settings.png) | > > > **Note:** For more information, please see Adobe's help on the [OCIO and ACES Color Management page](https://helpx.adobe.com/after-effects/using/opencolorio-aces-color-management.html). > > ### ACES via plugins in After Effects (versions before 23.2) > > **Click here for the legacy ACES in After Effects workflow...** > > ### Step 1 > > The best way to use ACES in After Effects versions before 23.2 is to download and make use of the **[fnord plugin OpenColorIO for After Effects](https://fnordware.blogspot.com/2012/05/opencolorio-for-after-effects.html)**. > > > **Note:** **fnord OCIO Plugin Version** > > > > Make sure you have fnord OCIO version 2.1.1 or later which was released in December 2021 for OCIO v2 support in order to be able to use the same OCIO config file that ships with Redshift. > > ### Step 2 > > First import your ACEScg footage into After Effects and place it in a new composition. > > ![Image: AfterEffects_Step_16e26.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_16e26.jpg) > > ### Step 3 > > Now set up your Project Settings. This can be found either by clicking the small button at the bottom of the Project panel circled in the image below or going to **File > Project Settings.** > > ![Image: After_Effects_Step_1a3a29.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/After_Effects_Step_1a3a29.jpg) > > ### Step 4 > > Under the **Color** tab set the following settings: > > Depth: ***32 bits per channel (float)*** > > Working Space: ***sRGB IEC61966-2.1*** > > Linearize Working Space: ***Enabled*** > > ![Image: AfterEffects_Step_1bf3da.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_1bf3da.png) > > ### Step 5 > > Next create a new adjustment layer above your ACEScg footage in the composition. We will name this adjustment layer and refer to it as " *ACEScg to sRGB.*" > > ![Image: AfterEffects_Step_25fcc.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_25fcc.jpg) > > ### Step 6 > > Then add an ***OpenColorIO*** effect to the "*ACEScg to sRGB*" adjustment layer. This effect is found under **Effects > Utility > OpenColorIO.** > > ![Image: AfterEffects_Step_3025c.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_3025c.jpg) > > ### Step 7 > > Now set your OCIO config location for the OpenColorIO effect. > > ![Image: AfterEffects_Step_74cdd.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_74cdd.png) > > ### Step 8 > > Use the following settings: > > Set the mode to "***Display***" > > Input Space: ***ACEScg*** > > Output Space: ***sRGB*** > > View: ***ACES 1.0 SDR-video*** > > ![Image: AfterEffects_Step_8_OCIO_v2.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_8_OCIO_v2.png) > > ### Step 9 > > Now the ACEScg footage is being previewed with the correct ACES Output Transform*but* it still does not actually look correct in After Effects, this is due to an extra gamma correction that After Effects color management is applying. > > ![Image: AfterEffects_Step_9_OCIO_v2.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_9_OCIO_v2.jpg) > > ### Step 10 > > To counteract this gamma correction issue add a ***Color Profile Converter*** effect beneath the existing OpenColorIO effect, this can be found under **Effects > Utility > Color Profile Converter.** > > ![Image: AfterEffects_Step_6e482.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_6e482.png) > > ### Step 11 > > Use the following settings for the Color Profile Converter: > > Input Profile: ***sRGB IEC61966-2.1*** > > Output Profile: ***sRGB IEC61966-2.1*** > > Linearize Output Profile: ***Enabled*** > > ![Image: AfterEffects_Step_11_OCIOv2.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_11_OCIOv2.png) > > ### Step 12 > > Now the ACEScg footage looks correct and will render out properly. > > ![Image: AfterEffects_Step_12_OCIO_v2.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AfterEffects_Step_12_OCIO_v2.jpg) > > > **Note:** ### Reminder > > > > The correct way to adjust ACEScg footage with this After Effects workflow should be done *above* your ACEScg footage but *below* the "ACEScg to sRGB" adjustment layer. This is demonstrated below with an Exposure effect being applied to an adjustment layer titled " *Color Correction*" in between the two layers. You want to apply any color corrections first to the ACEScg footage when still linear so it must be done in this order before the Output Transform conversion that converts your image to non-linear. This also means that you can composite *multiple* ACEScg openEXRs render layers all under the same *one* "ACEScg to sRGB" adjustment layer. > > > > | | | > > | --- | --- | > > | ![Image: After_Effects_Project_ACES_CC_correctb9f2.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/After_Effects_Project_ACES_CC_correctb9f2.jpg) | ![Image: After_Effects_Project_ACES_CC_incorrect6e31.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/After_Effects_Project_ACES_CC_incorrect6e31.jpg) | > > | *Correct color correction result and layer order* | *Incorrect color correction result and layer order* | > **Tip:** ## ACES in Nuke > > **Click here for Nuke workflow...** > > ### Step 1 > > Navigate to the Color tab of your Nuke Project settings. > > ![Image: Nuke_ACES_step_14e99.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Nuke_ACES_step_14e99.jpg) > > ### Step 2 > > Set your "Color Management" to OCIO. > > ![Image: Nuke_ACES_step_2f06a.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Nuke_ACES_step_2f06a.jpg) > > ### Step 3 > > Set the "OCIO config" to an ACES configuration or provide the path of your own custom OCIO config. > > ![Image: Nuke_ACES_step_32b5b.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Nuke_ACES_step_32b5b.jpg) > > ### Step 4 > > Your Read nodes for ACES footage should already be set up with the correct color space of scene linear as pictured below. > > ![Image: Nuke_ACES_step_45186.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Nuke_ACES_step_45186.jpg) > > ### Step 5 > > Set your Viewer to the correct output display transform that corresponds with the display you are using to view your work on. > > ![Image: Nuke_ACES_step_514ec.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Nuke_ACES_step_514ec.jpg) > **Tip:** ## ACES in Resolve > > There are multiple ways to add an ACES transform to footage in Resolve, the most common methods are covered below. > > ### ACES via Project Settings in Resolve > > **Click here for ACES via Project Settings in Resolve walkthrough...** > > ### Step 1 > > To make the results of your settings changes more apparent start by adding your ACES footage to a timeline. > > ![Image: Resolve_ACES_Project_Step_1c1e1.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_ACES_Project_Step_1c1e1.jpg) > > ### Step 2 > > Then open your "Project Settings" which is found in the File menu. > > ![Image: Resolve_ACES_Project_Step_20a3b.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_ACES_Project_Step_20a3b.jpg) > > ### Step 3 > > Next select the "Color Management" section on the left side of the Project Settings panel and then change your "Color science" to ACEScc or ACEScct. > > ![Image: Resolve_ACES_Project_Step_321b5.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_ACES_Project_Step_321b5.png) > > ### Step 4 > > Then set your ACES version, Input Device Transform to " *CSC - ACEScg*" and Output Device Transform to the color space corresponding to the monitor you are working on, in most cases sRGB. > > ![Image: Resolve_ACES_Project_Step_48e59.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_ACES_Project_Step_48e59.png) > > ### Step 5 > > Now your ACES footage is set up properly. > > | | | > | --- | --- | > | ![Image: Resolve_ACES_Project_Before90af.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_ACES_Project_Before90af.jpg) | ![Image: Resolve_ACES_Project_Step_52cae.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_ACES_Project_Step_52cae.jpg) | > | *Default Resolve Color science (without ACES Transform)* | *ACES Color science (with ACES Transform)* | > > ### ACES via Edit Page in Resolve > > **Click here for ACES via Edit Page in Resolve walkthrough...** > > ### Step 1 > > Start by adding your ACES footage to a timeline and switching to the Edit page. > > ![Image: Resolve_Edit_ACES_step_18115.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_18115.jpg) > > ### Step 2 > > Then add an  *ACES Transform* effect to your footage found under the Open FX > Resolve FX Color section. > > ![Image: Resolve_Edit_ACES_step_23d55.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_23d55.png) > > ### Step 3 > > Next switch to the Effects tab so you can access the ACES Transform options. > > ![Image: Resolve_Edit_ACES_step_39fe0.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_39fe0.png) > > ### Step 4 > > Then set your ACES version, Input Transform to " *CSC - ACEScg*" and Output Transform to the color space corresponding to the monitor you are working on, in most cases sRGB. > > | | | > | --- | --- | > | ![Image: Resolve_Edit_ACES_step_4e77f.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_4e77f.jpg) | ![Image: Resolve_Edit_ACES_step_50ca7.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_50ca7.jpg) | > > ### Step 5 > > Now your footage is set up properly. > > > **Note:** Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB. > > | | | > | --- | --- | > | ![Image: Resolve_Edit_ACES_step_18115.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_18115.jpg) | ![Image: Resolve_Edit_ACES_step_62221.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Edit_ACES_step_62221.jpg) | > | *Before ACES Transform* | *After ACES Transform* | > > ### ACES via Color Page in Resolve > > **Click here for ACES via Color Page in Resolve walkthrough...** > > ### Step 1 > > From the Color page start by adding an *ACES Transform* node to your color correction graph. > > ![Image: Resolve_Color_ACES_step_19ec3.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Color_ACES_step_19ec3.jpg) > > ### Step 2 > > Then set your ACES version, Input Transform to "*CSC - ACEScg*" and Output Transform to the color space corresponding to the monitor you are working on, in most cases sRGB. > > | | > | --- | > | ![Image: Resolve_Color_ACES_step_21d62.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Color_ACES_step_21d62.jpg) | > | *Setting Input Transform to ACEScg* | > | | > | ![Image: Resolve_Color_ACES_step_3b39a.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Color_ACES_step_3b39a.jpg) | > | *Setting Output Transform to sRGB* | > > ### Step 3 > > Now your footage is set up properly. > > > **Note:** Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB. > > | | | > | --- | --- | > | ![Image: Resolve_Color_ACES_step_19ec3.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Color_ACES_step_19ec3.jpg) | ![Image: Resolve_Color_ACES_step_44ae2.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Resolve_Color_ACES_step_44ae2.jpg) | > | *Before ACES Transform* | *After ACES Transform* | > **Tip:** ## ACES in Fusion > > **Click here for ACES in Fusion walkthrough...** > > ### Step 1 > > With your footage imported via a Loader create an *OCIO Colorspace* node downstream from your footage. This effect can be found under the Tools > Color section. > > ![Image: Fusion_ACES_step_3e64f.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Fusion_ACES_step_3e64f.jpg) > > ### Step 2 > > First specify the location of your OCIO Config file. > > ![Image: Fusion_ACES_step_46ede.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Fusion_ACES_step_46ede.jpg) > > ### Step 3 > > Then set your Source Space to "*ACEScg*" and Output Space to the color space corresponding to the monitor you are working on, in most cases sRGB. > > | | | > | --- | --- | > | ![Image: Fusion_ACES_step_55f8a.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Fusion_ACES_step_55f8a.jpg) | ![Image: Fusion_ACES_step_6cf96.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Fusion_ACES_step_6cf96.jpg) | > > ### Step 4 > > Now your footage is set up properly. > > > **Note:** Note: In the demonstration images below the display being worked on used a color space of P3-D65 so the Output Transform was set to that instead of the more common sRGB. > > | | | > | --- | --- | > | ![Image: Fusion_ACES_step_3e64f.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Fusion_ACES_step_3e64f.jpg) | ![Image: Fusion_ACES_step_7467f.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Fusion_ACES_step_7467f.jpg) | > | *Before ACES Transform* | *After ACES Transform* | > **Tip:** ## ACES in Affinity Photo / Designer / Publisher > > **Click here for ACES in Affinity walkthrough...** > > This walkthrough only works with OCIO v1 Configs. OCIO v2 configs currently have issues in Affinity. > > ### Step 1 > > Before you begin working you must first specify your OCIO config path by opening the Affinity *Preferences* > ;*Color* section. > > | | | > | --- | --- | > | ![Image: Affinity_Photo_ACES_step_1f2db.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_1f2db.jpg) | ![Image: Affinity_Photo_ACES_step_2ba73.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_2ba73.png) | > > ### Step 2 > > Then press the " *Select...*" button and navigate to and select your OCIO config file. A restart of the program may be required after this step. > > ![Image: Affinity_Photo_ACES_step_3e07a.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_3e07a.png) > > ### Step 3 > > Next open your footage and add an Adjustment by clicking the button located at the bottom of the Layers panel circled below... > > ![Image: Affinity_Photo_ACES_step_51964.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_51964.jpg) > > ### Step 4 > > ...and select the *OCIO* adjustment. > > ![Image: Affinity_Photo_ACES_step_61fc4.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_61fc4.jpg) > > ### Step 5 > > Then set your Source Color Space (Input Transform) to " *ACEScg*" and Destination Color Space (Output Transform) to the color space corresponding to the monitor you are working on, in most cases sRGB. > > ![Image: Affinity_Photo_ACES_step_7325e.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_7325e.jpg) > > ### Step 6 > > Next add a Levels adjustment and apply a Gamma adjustment of 2. > > ![Image: AffPhoto_Levels.png](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/AffPhoto_Levels.png) > > > **Important:** This step is necessary because Affinity applies a double gamma correction. Without this manual gamma adjustment your footage will export incorrectly and not match your view while working inside Affinity. > > ### Step 7 > > Now your footage is set up properly. > > | | | > | --- | --- | > | ![Image: Affinity_Photo_ACES_step_51964.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_51964.jpg) | ![Image: Affinity_Photo_ACES_step_9_resultdbf7.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Affinity_Photo_ACES_step_9_resultdbf7.jpg) | > | *Before ACES Transform* | *After ACES Transform* | > **Tip:** ## ACES in Natron > > **Click here for ACES in Natron workflow...** > > ### Step 1 > > Start by bringing in your footage with a read node. A read node has built in OCIO support but should be left to ACEScg / raw for the input and output transforms so we can work in ACEScg and then transform to sRGB later. > > > **Note:** Effectively Natron's read node has the ACES Input Transform built right in, alternatively you could also use an OCIO colorspace node with the same settings for the same result. > > ![Image: Natron_ACES_Step_19086.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Natron_ACES_Step_19086.jpg) > > ### Step 2 > > Then create an OCIO Colorspace node (this will function as our ACES View Transform) and set your OCIO config file. Set your Input Colorspace to ACEScg and your Output Colorspace to sRGB. This color transform should take place before writing out / rendering your footage so the ACES Output Transform is baked in. > > > **Important:** The node graph is now setup properly but by using Natron's default viewer settings we're still *incorrectly* previewing the footage in the viewer due to an extra sRGB transform being applied and making it far too bright as seen in the example image below. The solution to this is covered in the next step. > > ![Image: Natron_ACES_Step_21ee3.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Natron_ACES_Step_21ee3.jpg) > > ### Step 3 > > To remove the unwanted sRGB transform make certain to set your viewer lut to " ***Linear (None)***" as highlighted in the image below to preview your footage correctly. > > With this change now your footage looks correct in the viewer and you can do your compositing work in ACEScg as long as the editing takes place *before* the ACES Output Transform. > > ![Image: Natron_ACES_Step_37236.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Natron_ACES_Step_37236.jpg) > > ### Step 4 > > Make sure that when exporting your footage with a *Write* node that you set the Input and File Colorspaces to linear / raw in order to avoid the double sRGB transform as well. > > The ACES Output Transform is *already* coverting the footage to the appropriate sRGB output. > > ![Image: Natron_ACES_Step_4fae2.jpg](https://help.maxon.net/r3d/houdini/en-us/Content/Resources/Images/Natron_ACES_Step_4fae2.jpg)