Cinema 4D Prime Конфигурация программы Настройки программы Импорт и экспорт Плагин ArchiCAD
Функция доступна в CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

ArchiCAD

На заметку:
Следующее описание действует в основном для ArchiCAD 14-17. Пользователям ArchiCAD 18 следует заглянуть сюда и посмотреть на новую команду Объединение сцены ArchiCAD 18+.

Установка

Вам необходимы плагины для ArchiCAD и Cinema 4D.

Необходимые плагины вы можете найти в интернете по адресу:

http://www.graphisoft.com/products/archicad/addons/cinema_4d/cinema4d_download.html

Ранние версии плагинов вы можете найти в интернете по адресу:

http://www.graphisoft.com/products/archicad/addons/cinema_4d/cinema4d_download_old.html

(вы можете скопировать ссылку и вставить её в браузер)

Первый плагин будет установлен в соответствующую директорию программы ArchiCAD. Второй вам необходимо предварительно распаковать. Распакованные данные необходимо копировать в папку «Плагины», расположенную в основной директории программы Cinema 4D. При обновлении второго плагина вам необходимо предварительно удалить ранние версии плагина ArchiCAD, которые вы установили раннее для программы Cinema 4D.

Применение

Имеется два вида, на основе которых функционирует привязка программы ArchiCAD к программе Cinema 4D:

Предварительно вам необходимо проверить, что в программе ArchiCAD (Настройки > Ссылки проекта > Установки размеров) и Cinema 4D (Настройки сцены > Масштаб документа) установки единиц измерения являются идентичными:

Импорт и сохранение данных Cinema 4D (*.c4d)

Импорт в ArchiCAD

Если вы намерены открыть файл программы Cinema 4D (*.c4d) в программе ArchiCAD, в этом случае вам необходимо в настройках программы на закладке Файлы, установить активной установку Сохранять полигоны для Melange:

В программе ArchiCAD вы используете закладку Файл > Открыть. В показанном при этом диалоге из выпадающего меню, вам необходимо выбрать запись Cinema 4D File (*.c4d), в окне типа данных:

Это позволит вам производить импорт всех данных Cinema 4D. В основном будет производиться работа с файлами геометрии и материалов.

Сохранить из ArchiCAD

Для сохранения данных в формате Cinema 4D, программа ArchiCAD должна находиться в режиме 3D (например, Вид > Режим 3D-вида > Перспектива).

Используйте теперь закладку Файл > Сохранить как, и в показанном при этом окне диалога из выпадающего меню для типа данных выберите запись Cinema 4D File (*.c4d):

В основном в таких файлах сохраняются параметры геометрии, материалов, камер и источников света.

Рабочий процесс при передаче данных в программу Cinema 4D.

Предположим, ваш коллега создал определённую конструкцию в программе ArchiCAD и вы намерены произвести просчёт этой сцены в программе Cinema 4D. После того, как ваш коллега произвёл сохранение файла как Cinema 4D, вы можете открыть его в программе Cinema 4D посредством команды Открыть, которую вы найдёте на закладке Файл. Вы найдёте при этом аналогичную структуру с той, которая предоставлена на этом изображении:

Типичная структура объекта

Элементы сцены вы найдёте как суб-элементы для известных нам ноль объектов, и подразделённых на отдельные подгруппы в менеджере объектов. Например, в группе с названием ArchiCAD Environment вы найдёте все источники света и камеры, или в группе Windows вы можете найти все окна (эти структуры по возможности вам необходимо ставить без изменения). В программе ArchiCAD изменение названий объектов и их последовательности не имеет значения, так при экспорте данных, для всех объектов будет произведено назначение специальных идентификационных номеров ID. Программа Cinema 4D способна опознавать такие иерархии, распределять их согласно с актуальной иерархией.

Эта структура руководствуется классами программы ArchiCAD, и выглядит следующим образом.

Во время обработки вами файла в программе Cinema 4D, например, вы производите замену материалов на более качественные материалы программы Cinema 4D (смотрите здесь) или производите добавление Неба, ваш коллега решил произвести некоторые изменения для начального файла. Например, на одной из стен необходимо удалить окно, и добавить его на другом участке.

Эти изменения должны быть в обязательном порядке переняты программой Cinema 4D. Если упомянутую выше структуру вы оставили без изменения, создаваемые повторно изменения будут автоматически переняты, и вновь созданные материалы в программе Cinema 4D останутся без изменений. Для вновь созданных элементов (в нашем случае это окно), созданные материалы будут назначены автоматически.

На заметку:
При создании новых объектов в программе Cinema 4D, вам необходимо обращать внимание на такой момент: созданные вами объекты, должны быть расположены в менеджере объектов за пределами иерархии объектов, принадлежащих программе ArchiCAD (то есть не в иерархии ноль объекта, который был создан как группирующий в программе ArchiCAD). При загрузке изменённого файла, расположенные вами, таким образом, объекты (случайно или по ошибке) будут удалены из общей иерархии!

Изменения конструкции и их передача в программу Cinema 4D.

Всё, что вам необходимо для этого сделать, это сообщить вашему коллеге информацию о необходимости сохранения, им изменённого файла в программе ArchiCAD как файл программы Cinema 4D. Вы можете произвести загрузку такого файла при использовании команды Импортировать в уже обработанную сцену программы Cinema 4D. При этом будет выполнено следующее:

Режим синхронизации

Другой вид обмена данными между программами, ArchiCAD и Cinema 4D называется Режим синхронизации. Обе программы при этом должны быть запущены, что позволяет беспрепятственный перенос данных между программами.

Из ArchiCAD в Cinema 4D

Послать в ArchiCAD

Для обоих случаев будет произведён старт программы Cinema 4D, и соответствующие элементы будут загружены. ArchiCAD и Cinema 4D находятся при этом в режиме синхронизации. При обработке или создании новых элементов, программа ArchiCAD производит открытие диалогового окна Explorer/Finder. Определите директорию к программе Cinema 4D и выберите исполняемый файл программы Cinema 4D (Cinema 4D 64 Bit.exe или Cinema 4D.exe)

Из Cinema 4D в ArchiCAD

Если при активном режиме синхронизации вы произвели обработку объектов или их добавление в программу Cinema 4D, вы можете произвести их экспорт в программу ArchiCAD, используя для этого в меню Файл команду Экспорт в ArchiCAD. При этом вам необходимо определить название файла, что позволит программе произвести сохранение геометрии в промежуточном файле.

Дополнительную информацию вы найдёте в изложенной выше документации Graphisoft.

ArchiCAD 18

Если вы экспортируете сцену в Cinema 4D, вам следует действовать следующим образом. Это соответствует тут описанному методу: