Cinema 4D Cinema 4D Prime Менеджер материалов Параметры материалов и Редактор материалов Настройки текстуры
Функция доступна в CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Менеджер текстур

Кто из вас не знает таких ошибок, когда при старте рендера будет показано уведомление программы об отсутствии текстуры на вашем компьютере. Текстуры, которые при создании сцены были в папке Х, теперь просто отсутствуют. Такие нюансы могут произойти очень быстро, если вы производите копирование сцены, открытие сцены на другом компьютере или в новой версии программы Cinema 4D отсутствуют библиотеки в браузере библиотек и так далее.

Для комфортабельного обхождения таких проблем в программе имеется менеджер текстуры, который предоставляет для вас список всех имеющихся в сцене текстур на предмет возможности их поиска программой Cinema 4D в своих строках поиска. Кроме этого менеджер текстуры имеет различные функции, позволяющие повторно связывать ненайденные текстуры. Естественно найденные текстуры могут заменяться посредством других текстур. К примеру, является возможным посредством процесса замены произвести замену всех путей текстуры формата JPEG на пути формата TIF текстуры:

В последующем материале мы будем часто упоминать такие понятия, как абсолютный и относительный путь текстуры. Подробности этой темы вы можете найти в соответствующей главе.

Пример: Что делать, если при импорте сцены и её просчёте у вас отсутствуют текстуры (о чём вы получите уведомление программы как окно с ошибкой при процессе рендера!)?

Для наиболее часто встречающегося случая, когда начальная папка с текстурой была перемещена и назначение путей поиска должно производиться повторно, вам необходимо поступить следующим образом:


  1. В меню используйте команду Правка > Выделить отсутствующие текстуры. Посредством этого вы выделяете все необходимые для обработки текстуры.
  2. Используйте теперь команду Правка > Связать текстуры повторно.... При этом будет показано окно выбора.
  3. В показанном окне укажите действительную папку с текстурами и кликните затем на кнопке Открыть. Все текстуры теперь повторно связаны (то есть происходить автоматическое назначение новых путей и директорий, в которых расположены папки с текстурами).
  4. При необходимости вы можете использовать команду Сохранить сцену с учётом составляющих… в меню Файл, посредством которой происходит сохранение сцены со всеми текстурами (в папке с названием «tex»). Сохранённые таким образом текстуры вы можете впоследствии запаковать (в архив ZIP или RAR) с целью их последующей передачи или дальнейшей обработке на другом компьютере.

Общие положения

Список текстуры

В списке текстуры (расположенное ниже поле) вы найдёте все текстуры, которые являются актуальными и принадлежат к открытой сцене. Посредством двойного клика мыши на отдельном названии текстуры, пути и всех других записей, расположенных в данном поле, вы производите его преобразование в обрабатываемый текст, который вы можете непосредственно изменять для необходимых элементов (к примеру, без дополнительного открытия окна Менеджер материалов, для выбора нового пути текстуры).

Создание выделения или его удаления происходит на основе привычных для вас клавиш SHIFT и CTRL/CMD (вы можете при использовании курсора мыши также создавать прямоугольное выделение). Вызываемые команды, которые позволяют с ним работать, относятся в данном случае только к созданному выделению.

Статус

Существует три состояния текстуры:

Текстура

В этой колонке будет показано реальное название текстуры.

Предположенный путь

Это сохранённый в материале абсолютный путь. Если речь при этом идёт об относительном пути текстуры, в этом случае здесь будет расположено только название файла.

Реальный путь

Здесь происходит показ реального и полного пути для текстуры (а также для текстуры с относительным путём). Это соответствует при абсолютно сохраняемых путях, изложенному выше материалу.

Новый путь

Если вы производите изменение путей текстуры на основе расположенной ниже функции Заменить, в этом случае будет показан новый и получающийся при этом путь (прежде чем вы нажмёте на кнопке Заменить). На верхнем изображении вы видите, как папка Изображения вместо Текстуры будет показана в колонке Новый путь на основе использования для неё функции замены.

Материал

Здесь производится показ соответствующего материала со значком и названием для назначенной текстуры. Вы можете дважды кликнуть на значке материала, что приведёт к отдельному открытию окна Менеджер материалов.

Канал

Каждая текстура является связанной в канале материала. Название этого канала при этом будет показано в этой колонке.

Слой

Если материал принадлежащий к текстуре расположен на Cinema 4D слое, в этом случае он будет здесь показан.

RELEASE 16

Контекстное меню

Кликнув правой кнопкой мышки на найденную текстуру откроется меню со разными командами. Следующие (ниже) ещё не были описаны:

  • Показать файл в Explorer или Finder: откроет окно Explorer или Finder с папкой и выделенным файлом.
  • Открыть файл в Explorer или Finder: Открывает файл предусмотренной оперативной системой программой.
  • Открыть файл в менеджере изображений: Загружает файл в менеджере изображений Cinema 4D.

Обратите внимание на то, что эти три команды действуют всегда только для одной (выделена ярче) выделенной текстуры.

Изображение просмотра и функция замены

Слева внизу при найденной и выделенной текстуре, будет произведён показ её изображения.

Справа от окна вы найдёте функцию замены, на основе которой можно производить замену всех возможных путей текстуры, а также названия для текстур и папок.

Это функционирует следующим образом (для упрощения просмотра здесь только одна текстура вместо 324 в реальности):

Предположим у вас имеется текстура в пути: «> Users > olibecker > Desktop > Bunny > Textur > Hase.jpg». Через два года вы производите открытие соответствующего файла и он не будет найден, так как папка с текстурой расположена теперь по следующему адресу:

«> Users > olibecker > Desktop > old projects > xxx > Textur > Hase.jpg». Для изменения старого пути на новый, для функции Заменить вам необходимо занести «Bunny» и для поля на занести « old projects > xxx» (в расположенном ниже меню выбора вам необходимо определить активным режим Полный путь или Папка). Если вы произвели выделение текстуры, вам при этом будет показан новый и абсолютный путь в колонке Новый путь. Этот путь должен соответствовать реальному пути. При клике курсором мыши на кнопке Заменить для всех выделенных текстур произойдёт изменение пути в материале.

В поле Заменить занесённое название текстуры или предварительного пути заменяется при этом на новое название пути или текстуры, которое вы заносите в поле параметра на.

Таким образом, вы можете очень быстро производить изменение предварительно назначенных путей для используемой текстуры на новые.

В этом меню выбора часть пути, который будет использован для функции замены. Разделение пути может происходить следующим образом:

Для поля Заменить действительными являются следующие и изложенные в данном материале выражения * (любой текст), ? (любой и отдельный знак) и # (любая и отдельная цифра).

Небольшой пример: на основе этих настроек вы производите замену всех названий текстуры с назначенной датой на текстуры с аналогичным названием и дополнительным словом «final_».

Это функционирует идеально в том случае, если при назначении названий для путей или текстуры, вы придерживаетесь установленных правил (например, добавляете дату, определённый порядок номеров или для текстуры с низким разрешением добавляете слово «low_», которое впоследствии вы намерены изменить на «high_»). В этом случае при использовании данной функции вы можете очень просто и быстро производить замену текстуры и для текстуры, которая не была найдена, назначать новые пути.

Меню

Меню Правка

Все последующие команды относятся только к путям (директориям) текстуры в пределах программы Cinema 4D. Изменение в файлах текстуры при этом не происходит.

Имеется также следующее правило: текстуры скрытые от фильтра при этом не учитываются (исключение: команда Отменить все выделения).

Выделить все

При использовании данной команды вы производите выделение всех текстур, которые имеются в расположенном ниже поле.

Отменить все выделения

Эта команда производит удаление имеющегося выделения для всех текстур (и даже скрытых от фильтра текстур).

Выделить отсутствующие текстуры

Все текстуры показываемые в расположенном ниже поле которые не были найдены, будут выделены на основе данной команды.

Обратить выделение

При необходимости удаления имеющегося выделения у текстуры и его назначения для текстуры без выделения вы можете использовать команду Обратить выделение.

Выделить текстуры активных материалов

При использовании данной команды происходит выделение всех текстур принадлежащих к соответствующим материалам, которые являются актуально выделенными в окне Менеджер материалов.

Показать в менеджере атрибутов

Эта установка (но не команда!) определяет дополнительный показ материалов, принадлежащих к выделенным в окне Менеджер текстур текстурам, дополнительно в окне Менеджер атрибутов.

Название файла локально
Название файла глобально

Эти две команды производят полное создание или удаление назначенных путей данных.

Команда Название файла локально производит удаление назначенных путей для всех выделенных текстур и назначает при этом только название файла. Практически на основе данной команды, вы преобразуете абсолютный путь в относительный (программа Cinema 4D производит поиск <здесь). В принципе это происходит автоматически, если при использовании команды Сохранить сцену с учётом составляющих… вы производите сохранение сцены.

Команда Название файла глобально для всех выделенных текстур производит преобразование относительного пути (где в материале не содержится папки или директории, а только название) на абсолютный. При этом используется полное название пути для файла.

Связать текстуры повторно...

Эта команда производит повторную связь выделенной текстуры с текстурой имеющей аналогичные названия в одной из выбираемых папок. В зависимости от расположения папок, будут созданы абсолютные (за пределами...) или относительные (в пределах путей поиска программы Cinema 4D) пути.

Использование данной команды имеет смысл в том случае, если текстуры не были найдены. Как правило, это происходит в том случае, если папка с текстурой расположена полностью в другом месте (директории). В этом случае выберите просто все текстуры, используйте команду и выберите актуальную папку. При этом происходит повторное изменение всех имеющихся путей текстуры и для процесса рендера это создаёт только положительное влияние.

Заменить текстуры на...

Эта команда позволяет вам произвести назначение выбираемого файла для выделенных текстур.

RELEASE 17

Отчистить текстуры

Удалите все соединения с выделенными текстурами. Это поможет, например, удалить соединения с несуществующей текстурой в отключённых каналах материала, которые отмечаются в менеджере текстур красным крестом.

Меню Вид

Строка поиска

С показываемой здесь строкой поиска для вас предлагается специальный фильтр, на основе которого вы можете сохранять общий и визуальный просмотр, при наличии большого количества текстуры.

На основе Меню выбора вы определяете колонку с аналогичным названием, имеющиеся записи которой должны быть подвергнуты процессу фильтрации.

Для Поля задания действительным является следующее: выделение элементов не происходит. Речь при этом идёт о чистом фильтре показа, который функционирует в режиме реального времени. Он осуществляет свою работу на основе задаваемой вами строки в его поле. Каждый элемент, который хотя бы частично содержит набор знаков аналогичных с заданной строкой (словом), будет показан. Правописание больших и маленьких букв при этом процессе учитывается. Клик курсора мыши на расположенном слева от поля значке х на фоне белой окружности, производит удаление знаков поиска из поля фильтра, который при этом остаётся без воздействия и производит показ всех имеющихся знаков (названий, цифр и так далее).

Имеется три режима, которые используются здесь, а также в расположенном ниже поле Заменить:

Некоторые примеры помогут вам понять данную тему:

Слева вы видите список текстуры без фильтрации и затем после фильтрации слева направо:

Текстура
Предположенный путь
Реальный путь
Новый путь
Материалы
Канал
Слой

На основе данных записей расположенных в меню Вид, вы определяете показ соответствующих колонок для окна Менеджер текстур.

При утерянных текстурах особенно полезные колонки Материалы (тут можно произвести двойной клик на значок, чтобы открыть материал в менеджере Правка материала) и Канал, которые вам показывают, где именно утеряна текстура.