Справка Cinema 4D Cinema 4D Prime Меню Производственный процесс Substance
Функция доступна в CINEMA 4D Prime, Visualize, Broadcast, Studio & BodyPaint 3D

Менеджер составляющих Substance

Содержит все загруженные составляющие Substance и позволяет ими управлять. Составляющие в списке можно переносить и выделять точно также, как и другие элементы в Cinema 4D (CTRL/CMD позволит выделить или отменить выделение нескольких составляющих, SHIFT выделяет диапазон составляющих и Del удаляет выделенные составляющие). С помощью двойного клика по названию составляющей, её можно переименовать.

Составляющие можно переносить из менеджера в различные места (при этом будут автоматически установлены необходимые ссылки):

При создании материала с помощью перетаскивания, он будет создан с помощью автоматического режима, описанного тут.

Составляющие можно перенести из Менеджера составляющих в библиотеку предустановок (файлы Substance при этом буду сохранены), откуда их затем можно будет вновь загрузить в менеджер составляющих.

При выборе составляющих в менеджере составляющих, их свойства будут отображены в менеджере атрибутов (у которого для такого случая имеется отдельный режим отображения).

Слева от названия составляющей вы найдёте опцию, с помощью которой можно заморозить составляющую со всеми её текущими настройками. Это применимо в случае, когда вы работает со сценой, которая функционирует очень медленно из-за просчётов Substance Engine. К примеру, у вас есть анимированный параметр составляющей и вы работаете с Таймлайном и все текстуры составляющей должны просчитываться заново для каждого нового кадра. Это со временем может доставить много хлопот и в таком случае составляющую лучше заморозить.

Когда составляющая не активна, вы можете изменять её настройки, что будет сразу сохранено, но информация об этом будет передана Substace Engine лишь после активации составляющей.

Обратите внимание на то, включили ли вы составляющую при рендере (особенно при анимации параметров составляющей).

Справа от названия составляющей находится её предпросмотр, который можно также в лучшем разрешении найти в Менеджере атрибутов.

Кликнув по названию колонки, можно выстроить список в алфавитном порядке (в этом случае порядок составляющих уже нельзя будет изменить вручную). Повторный клик упорядочит список в обратном порядке, а третий клик уберёт алфавитный порядок вообще.

Меню Файл

Загрузить Substance...

С помощью этой команды можно загрузить новые составляющие в Cinema 4D (или просто перетащить соответственные файлы в менеджер составляющих). Файл составляющей должен быть формата *.sbsar. В зависимости от предустановок Substance Engine, после загрузки будет создан материал с соответственной составляющей.

Информацию об относительном и абсолютном путях файлов составляющих можно найти тут.

RELEASE 19

Добавить Substance из папки...

С помощью этой команды можно загризть составляющие Substance выбранной папки, без учёта в ней находящихся других папок.

Перезагрузить Substance

Если файл с составляющей уже загружен в Cinema 4D, но его свойства были изменены или опубликованы в Substance Designer, вызовите эту команду, чтобы его перезагрузить.

Меню Правка

Вырезать

Эта опция удаляет выбранные элементы и копирует их в буфер обмена. Их можно вновь вернуть оттуда в нужное место с помощью команды Вставить.

Копировать

Эта опция копирует выбранные элементы в буфер обмена. Их можно вновь вызвать оттуда в соответственное место в проекте с помощью команды Вставить.

Вставить

Эта опция вызывает из буфера обмена отправленные туда элементы.

На заметку
Вы также можете вставлять элементы в другие открытые проекты или сцены.

Удалить

Эта опция удаляет выбранные составляющие. Вы также можете это сделать с помощью нажатия клавиши Del.

Удалить неиспользуемые Substance

Эта команда удаляет все составляющие, которым не назначен материал.

Выделить все

Эта опция выделяет все загруженные составляющие.

Отменить все выделения

Эта опция отменяет выделение всех составляющих.

Выделить из активных материалов
Выделить из отмеченных материалов

Эти команды выделяют все составляющие, назначенные материалы которых выбраны или отмечены в менеджере материалов (отмеченные материалы отображаются с жёлтой рамкой вокруг, что обозначает, что выбран объект, которому они назначены).

Выделить из активных объектов

Эта команда выделяет все составляющие, которые назначены объектам посредством материалов.

Выделить материалы
Выделить объекты

Эта команда выделяет все материалы или объекты, которые связаны с выделенными составляющими.

Активировать все
Деактивировать все

Эти опции активируют и деактивируют все составляющие. Больше информации об это можно найти тут.

Настройки программы...

Эта команда вызовет настройки Substance Engine.

Меню Создать

Создать стандартные материалы

По умолчанию, при создании составляющих будет создан также материал Cinema 4D в следующем порядке:

Вывод канала Substance Канал материала Cinema 4D
Diffuse Цвет
Basecolor * Цвет
Emissive Свечение
Reflection Отражение
Environment Окружение
Bump Рельеф
Opacity Альфа
Specular Отражение > Глянец - Стандарт
Height Смещение
Normal Нормали
Ambient Occlusion Диффузия

* В случае, если нету канала вывода Diffuse или была вызвана команда Создать металлические материалы.

С помощью этой команды вы всегда может создать новый материал с вышеуказанными каналами.

Создать металлические материалы
Создать глянцевые материалы

Substance Designer в основном предполагает два метода того, каким образом должен быть отображена физически обоснованная визуализация.

Первый — это рабочий процесс Metallic/Roughness (так он назван в Substance Designer), который как минимум отображает характерные каналы вывода (текстуры) «Base color», «Metallic» и «Roughness».

Другой — это рабочий процесс Specular/Glossiness, который как минимум отображает характерные текстуры «Diffuse», «Glossiness» и «Specular».

Оба этих рабочих процесса используют функции, которые также доступны в канале Отражение Cinema 4D.

Обе команды, Создать металлические материалы и Создать глянцевые материалы, в дополнение к уже описанному каналу вывода команды Создать стандартные материалы загружают также следующее:

Таким образом, визуализированные результаты выглядят максимально похоже (идентичные результаты очень редки) на результаты в Substance Designer. Вы можете использовать это различие в качестве отправной точки вашей дальнейшей работы. К примеру, вы можете отключить канал Цвет, как уже было описано в Дополнительные отличия от предыдущих версий.

Создать копию

Эта опция создаёт копии выбранных составляющих.

Создать копию с материалами

Эта опция создаёт копии выбранных составляющих и соответственных, с ними связанных материалов.

Меню Предустановка

Указанные тут команды не относятся к предустановкам Браузера библиотек, а предусмотрены для предустановок составляющих Substance (файл формата *.sbsprs). Это предустановки, которые можно создать как в Substance Designer, так и в Cinema 4D. Они позволяют переносить настройки составляющей из программы в программу, без необходимости загрузки их особого формата. Естественно, лучше всего использовать предустановки с подходящими составляющими. Однако, «незнакомые» предустановки также можно задействовать:

Применить предустановку Substance

Применяет предустановку Substance ко всем выбранным составляющим. Параметры, которые не заданы в предустановке, будут установлены по умолчанию. Если среди выбранных составляющих есть мультиграф, отобразится диалог для выбора графика. Параметры в предустановке, которых нет в составляющей, будут проигнорированы.

Добавить предустановку Substance

Применяет предустановку Substance ко всем выбранным составляющим. Параметры, которые не заданы в предустановке, останутся без изменений. Параметры в предустановке, которых нет в составляющей, будут проигнорированы.

Экспортировать предустановку Substance

С помощью этой команды можно экспортировать для каждой выбранной составляющей файл предустановки. Экспортированы будут лишь те параметры, которые отличаются от своих стандартных значений.

Меню Кеш на диске

При загрузке сцены, все текстуры составляющих должны быть созданы заново (и сохранены в RAM). В зависимости от разрешения и количества текстур, это может длиться очень долго. Чтобы ускорить процесс, текстуры можно сохранить в «substance_cache» в папке сцены.

В зависимости от их разрешения, текстуры могут требовать очень много памяти (На заметку: в настройках Substance Engine можно изменить формат записи текстуры на диске на JPG или PNG)!

На заметку:
Использование кеша диска может привести к неожиданным или ошибочным результатам в случае, когда составляющая Substance была, к примеру, изменена в Substance Designer (тогда следует вызвать команду Перезагрузить Substance в меню Файл). Следовательно, будьте аккуратны при временном отключении кеша жёсткого диска в меню настроек программы. Это также может вызвать проблемы с синхронизацией между параметрами и кешом.

Создать кеш выделенного

Эта команды кеширует все выбранные Substance.

Создать кеш изменённого

Только те составляющие, которые были изменены после кеширования, будут вновь кешированны (после изменения параметров, изменённые текстуры автоматически не кешируются).

Кешировать все

После подтверждения действия, эта команда кеширует текстуры всех составляющих.

Очистить кеш для выделеного
Очистить кеш для всех

Обе эти команды удаляют кешированные текстуры (лишь для формата файла, заданного в настройках программы) выделенных или вообще всех составляющих.