Справка Cinema 4D Cinema 4D Visualize, Broadcast, Studio Трекер движения Трекер движения
Функция доступна в CINEMA 4D Studio
Трекер движения

Общие Координаты Футаж 2D трекинг Реконструкция 3D Реконструкция

2D трекинг

Настройками закладки «2D трекинг» можно регулировать свойства 2D треков, которые в свою очередь должны преследовать примечательные участки футажа.

Успех реконструкции трёхмерной камеры или объекта полностью зависит от качества 2D треков. Cinema 4D выбирает их в основном автоматически и так, что вам в некоторых случаях вообще о них не надо будет беспокоиться. Но всегда будут случаи, в которых придётся вручную создавать 2D треки. Иногда и дополнительно к созданным автоматически. Но также есть возможность работать и исключительно с 2D треками созданными вручную.

Что такое 2D треки?

Различные 2D треки. Выбранные 2D треки пользователя отображаются с учётом размера образца и площади поиска (закладка «Настройки» в группе «Показ»).

2D треки — это части изображения, которые выбираются в определённый момент времени и в последующих, либо предыдущих кадрах находятся снова. Части изображения соответствуют меньшим квадратам в изображении сверху. Они сохраняются как ключевые и в соседних кадрах отыскиваются в рамках соответственного большего квадрата («Площади поиска»). Целью является отследить и сохранить расположение данного трека в двухмерной плоскости на протяжении максимально длинного отрезка времени. После чего из полученной информации реконструируется трёхмерная сцена.

2D треки можно создавать автоматически и вручную в любом кадре футажа.

Каждый 2D трек присвоен либо реконструкции камеры либо объекта. Присвоение происходит через список треков объекта (закладка «Трекер»). Имеющиеся там авто-треки или треки пользователя будут использованы исключительно для реконструкции объекта, но не для реконструкции камеры.

Интерактивная работа с 2D треками

Зачем нужно обрабатывать 2D треки, вы узнаете в разделе Как отличить хорошие треки от плохих?. Обратите внимание, что при изменении 2D треков после проделанной реконструкции, нужно повторить реконструкцию ещё раз!

На заметку:
На панели анимации можно найти ключи выбранных 2D треков. Их нельзя там обработать, но можно использовать команды Перейти к следующему или предыдущему ключу, которыми вы можете быстро перемещаться во времени. В этой панели отображаются ключи для 2D треков и сокращённых путей.

Создание 2D треков

2D треки можно создавать в 2D вид , к примеру, следующим образом:

Изменение размера образца и площади поиска

Выбранные треки пользователя как правило отображаются с квадратами размера образца и площади поиска. Эти квадраты имеют в углах грифы, которыми можно изменять размер каждого из квадратов. Если 2D трек уже был просчитан, то при изменении размера квадрата происходит новый просчёт трека.

Выделять и удалять

2D треки можно выделять следующим образом:

Выделенные треки можно удалить вместе с путём нажатием клавиши Backspace. Точнее говоря, их отображение отключается и при реконструкции они не будут учитываться. Поэтому вы в любой момент можете восстановить их командой Восстановить удалённое .

Редактирование имеющихся 2D треков

Смещённые треки

Имеющиеся треки можно в любой момент подхватить мышкой и переместить. К примеру, если трек в каком-то кадре скачет, его таким образом можно переместить на правильное место. При этом появляется небольшая лупа, которая вам поможет расположить трек:

С помощью лупы можно передвигать с точностью до пикселя.

RELEASE 18

Потерянные треки: треки, выбранные в другой временной точке и которые на данный момент не просчитываются, будут отмечены тёмно красным в 2D режиме (как на изображении выше) и их можно выделить мышкой и передвинуть на правильную позицию. Это, в принципе, имеет тот же эффект как и команда из контекстного меню Добавить ключ здесь, но в большинстве случаев работает быстрее. Если же правильной позиции нет, так как, к примеру, область исчезла из футажа, вам ничего дальше делать не нужно.

Если 2D трек уже был просчитан, то после его перемещения происходит (если режим Авто-обновление треков активирован) новый просчёт, включая создание ключа. Если авто-трек исчезает, то это означает, что он был профильтрован (см. Фильтр).

Это одна из самых важных функций Трекера движения. На практике вам придётся потратить много времени, перемещая отдельные треки кадр за кадром вручную, чтобы помочь алгоритму справиться с задачей:

Тут вы видите 2D трек, который был расположен на левой кнопке и в последствии просчитан. На втором кадре данный трек начинает перемещаться и останавливается на средней кнопке. Это, конечно, нужно исправить. Решение в данном случае следующее: просто поместите этот трек во втором кадре снова над левой кнопкой во втором кадре. Если вам немного повезёт, то система станет теперь отслеживать эту кнопку и далее. Если нет, то вам нужно будет перемещать этот трек кадр за кадром вручную до того момента, когда трекинг начнёт работать как надо или левая кнопка перестанет быть видимой в футаже.

Используйте один 2D трек исключительно только для одного образца пикселей!

Прервавшиеся, заканчивающиеся и неправильные 2D треки

Если трек временно исчезает из виду или его качество ухудшается и фильтр не срабатывает, то путь этого трека можно обрезать прямо перед тем, как это случится. Соответствующую команду вы найдёте в главном меню > Трекер движения > Обрезать трек. Но если путь заканчивается идеально, это делать не надо. Передвиньте ползунок времени не снимая выделение с трека, до того момента, когда соответствующий образец пикселей снова появится, кликните там правой кнопкой мышки и выберите из появившегося меню команду Добавить ключ здесь. Теперь трек будет продолжен. Но если путь будет просчитан с ошибками, возможно, вам нужно будет перед этим ключом произвести очередное сокращение. И это является важной информацией для Трекера движения. Он смог бы распознать оба трека автоматически и провести успешный просчёт, но система не будет знать, что эти оба трека являются одним и тем же.

Если площадь поиска определённого трека заканчивается, к примеру совсем исчезая из футажа, но трек прыгает к другому похожему месту, то в этом случае следует обрезать путь трека в последнем правильном кадре описанным выше путём.

Если 2D трек вообще бесполезный, то просто удалите его полностью.

Масштабировать и перемещать футаж во вьюпорте

При отображении футажа во вьюпорте можно менять масштаб изображения зажимая кнопку ALTи правую кнопку мышки и перемещая курсор по вьюпорту. Переместить футаж во вьюпорте можно кнопками ALT и средней кнопкой мышки.

Как отличить хорошие треки от плохих?

Треки до 2D трекинга

В общем можно сказать, лучшие треки это те треки, которые можно преследовать максимально долго и которые, кроме этого, представляют однозначное расположение в трёхмерном пространстве. Если таких треков достаточно много и они по возможности располагаются по всей поверхности, то это сильно облегчает работу алгоритма, что позволяет ему предоставить вам точную реконструкцию камеры.

Хорошие (зелёный цвет) и плохие треки (красный).

В этом примере вы видите ряд красных треков, с которыми алгоритм реконструкции справиться не сможет. Почему? А посмотрите, на пример, на эти два трека впереди, на краю стола и на те два лежащие выше на столешнице: проходящие грани не предоставляют собой однозначные точки, которые можно было бы преследовать во времени (2 см дальше выглядит это также). Похожая ситуация и с теми двумя на столешнице. В данном примере у нас однородное распределение цвета, без структур – алгоритму просто не за что «зацепиться».

Посмотрите теперь на красные треки на торшере. Тут видны определённые угловые точки, которые Cinema 4D на первый взгляд может хорошо проследить. Но на самом деле эти точки образованы перспективой. Представьте себе, что камера движется направо, и уже станет ясно, что эти точки не имеют однозначной позиции в трёхмерном пространстве, а изменяются с перспективой, и в следствии чего – бесполезны.

А сейчас посмотрите на зелёные треки. Вы увидите, что они всегда находятся на однозначных, контрастных позициях, к примеру, на углах, которые не изменяются в трёхмерном пространстве. Кроме этого эти позиции представляют собой легко распознаваемые объекты, за которыми, в крайнем случае, даже 10 кадров позже можно проследить вручную, если алгоритм трекинга по какой-то причине откажется это делать.

Также примите во внимание следующее:

Треки после 2D трекинга

После законченного 2D трекинга каждый трек будет отображён в своём временном течении, так называемом пути. Перед отображением они будут пропущены через фильтр (см. Фильтровать треки), т. е. неточные, плохие пути вместе с треками не будут отображаться. Это не всегда получается полностью, поэтому вам эти треки вместе с их путями нужно удалить, обрезать или исключить их маской.

Примеры некоторых плохих путей треков. В данном случае специально были ослаблены значения фильтра. Пути треков, которые похожи друг на друга и проходят параллельно соседним, как правило подходят для просчёта.

С видимыми путями легко найти неподходящие. Как правило, близко находящиеся друг к другу пути похожи. Такие необычные пути, как пример слева внизу, скорее всего являются ошибочными и должны быть удалены. Слишком дрожащие пути, как в центре являются также ошибочными, особенно если в данном случае пути на клавиатуре не дрожат. Но это не всегда так. Если камера дрожит, то и пути будут дрожать. Трек справа у торшера Cinema 4D смогла просчитать, но как уже объяснено выше, это точка перспективного пересечения, что следует избегать.

Треки, которые прыгают на другие позиции или сдвигаются относительно данного футажа также неправильны.

В принципе, пути треков, которые только от или до какого-то момента работают неправильно, не нужно удалять полностью. Достаточно этот путь соответственно обрезать.

На заметку:
Обратите также внимание на График трекера движений. Он может вам помочь оценить качество треков.

Общие советы

Параметры

Закладка «Авто-трекинг»

Коротко о различии между ручным и автоматическим трекингом:

Вы можете одновременно использовать ручной и автоматический трекинг или по отдельности только ручной или только автоматический.

Предварительно предлагается использовать автоматический трекинг, если при этом вы получите хорошую конструкцию камеры. В противном случае вам необходимо помочь дополнительно посредством ручного добавления треков или удаления плохих, автоматических треков (смотрите Что такое хорошие и плохие треки?).

Количество треков [1..10000]

Тут можно указать количество треков, которое должен создать алгоритм в каждом кадре. Количество треков которые в конце концов будет создано может отличаться от этого значения – значение служит только для ориентировки. Значение Мин. дистанция или же недостаточное количество найденных алгоритмом участков изображения, на которых имеет смысл создавать треки, могут привести к меньшему количеству треков. При других обстоятельствах треков может стать и больше, к примеру если вы укажите слишком маленькое значение.

В принципе имеет смысл создавать большое количество треков, но если они будут находится слишком близко друг к другу, то на просчёт будет уходить больше времени без того, что результат реконструкции камеры станет существенно лучше. Это значит, что не имеет смысла создавать тысячи треков, меньше треков, но качественней, приведут к более хорошему результату.

Мин. дистанция [1..1000]

Укажите тут минимальное расстояние в пикселях, которое треки должны иметь при создании. При создании самого 2D трекинга, треки смогут приближаться друг к другу и на меньшее расстояние. Ограничивая минимальную дистанцию, ограничивается и Количество треков.

Заменить треки

Представьте себе трек, который создан на краю кадра. В 20-ом кадре исчезает участок изображения, за котором следит трек, так как камера изменила своё направление или Трекер движения этот участок уже не находит. Другими словами, на протяжении видео-материала всё больше и больше треков исчезают, что никак не помогает реконструкции камеры. Если эта опция активна, то исчезнувшие треки будут заменены на новые, созданные на других участках кадра. Таким способом количество треков может оставаться константным.

При длинных роликах, в которых вы хотите, к примеру, только в начале и конце провести трекинг, может быть лучше отключить эту опцию, что-бы не все кадры между нужными просчитывались. В нужный момент вы можете воспользоваться кнопкой Создать авто-треки.

Создать авто-треки

Кликом на эту кнопку можно создать определённое количество однородно распределённых треков вместе с ключом в данном кадре. Количество и распределение треков можно регулировать вышеописанными параметрами Количество треков и Мин. дистанция.

Вы можете в любом кадре создать новый набор треков. Они будут независимы друг от друга.

Функциональность этой копки уже содержится в ниже расположенных кнопках, но в отличии от них, она не производит трекинг. Это имеет смысл тогда, когда вы хотите создать треки только на определённых кадрах. Вы их тогда сначала создаёте, а затем удаляете ненужные вручную или с помощью Маски.

Созданные треки изначально не выделены. Если вы хотите произвести трекинг, то вам следует выделить соответствующие треки и затем кликнуть на кнопку < Авто-трек >, либо используйте соответствующую команду в контекстном меню.

<
< Авто-трек >
>

Этими тремя кнопками производится трекинг выделенных авто-треков, а если треков ещё нет, то они будут созданы автоматически. Если ничего не выделено, будут просчитаны все треки следующим образом:

Как правило, следует кликать на Авто-трек. Эта кнопка произведёт просчёт вперёд и назад. Но иногда имеет смысл произвести трекинг только в одну сторону. Так например, если вы в 76-ом кадре создали авто-треки, образцы которых и так появляются только в этот момент, то нет никакого смысла производить просчёт назад.

После просчёта во вьюпорте вы найдёте вот такие элементы:

Каждый просчитанный трек получит ключ обозначенный точкой во вьюпорте. Передвижение трека во времени будет отображено путём длинной в 10 кадров до и после ромба (опознанного трека).

Но до того, как вы перейдёте к реконструкции камеры, следует исправить плохие треки и пути или же удалить их. См. Интерактивно работать с треками.

Удалить авто-треки

Тут вы можете удалить все, если ничего не выбрано, или только выбранные авто-треки вместе с их путями.

 Фильтровать треки

При автоматическом трекинге создаётся большое количество авто-треков с путями. Среди них, конечно же, будут и ошибочные пути, которые приведут к нежелательным последствиям при реконструкции камеры либо объекта. Поэтому этими настройками можно произвести предварительный отбор «хороших» треков, а ошибочные пути будут по возможности удалены или укорочены. Это поможет создать подходящую реконструкцию.

На заметку:
Вручную созданные треки или пути пользователя не будут подвергаться фильтрации, так как в данном случае можно исходить из того, что они были созданы так, как того желает пользователь.

Настройки фильтра уже оптимизированы для создания хороших результатов. Но в отдельных случаях может случится, что и очевидно ошибочные треки пройдут фильтрацию. Их можно выделить и удалить до реконструкции.

С другой стороны может также случится, что в зависимости от конкретного случая, фильтр будет работать слишком агрессивно и не пропустит слишком много треков. В этих случаях следует подправить настройки фильтра.

Фильтр удаляет проблематичные треки: слева исходный материал (все четыре фильтра отключены), справа после фильтрации.

Мин. длина (кадры) [2..200]

Этот фильтр сначала ждёт результаты других трёх фильтров, которые в зависимости от значения укорачивают пути треков, и затем фильтрует треки с путями короче указанной длины в кадрах. Если вы помните, у хороших треков пути должны быть максимально длинными. Слишком короткие пути треков не помогают при реконструкции.

Макс. ускорение [0..10]

Треки, которые прыгают от кадра к кадру имеют большое ускорение и часто, но не всегда, ошибочны. Чем меньшее значение вы тут указываете, тем больше укорачиваются пути треков. Этот параметр можно также найти в виде интерактивного ползунка в Графике трекера движений (где он должен находится в меню Вид > «Ускорение 2D трекера»).

Значение ошибки [0..100%]

При просчёте система старается найти в следующем кадре элементы изображения в определённом радиусе установленном Площадью поиска. По причине движения камеры и зернистости футажа практически невозможно найти точно совпадающие значения пикселей. Поэтому имеется настройка Значения ошибки, которая позволяет определённое отклонение от элемента изображения. Чем больше значение, тем больше может быть отклонение.

При очень маленьком значении вы заметите, что треки сохранятся только на однородных, одноцветных участках. В этом нет ничего удивительного, так как эти участки практически не изменяются из кадра в кадр. Но такие треки обычно и несут в себе ошибки, прыгают без того, что бы закрепиться за какими-то деталями. Этот параметр можно также найти в виде интерактивного ползунка в Графике трекера движений (где он должен находится в меню Вид > «Ошибки 2D трекера»).

Смарт ускорение [0..5]

Этот фильтр похож на выше описанный Макс. ускорение с той разницей, что треки не рассматриваются по отдельности, а вместе с соседними треками. Представьте себе в футаже скачёк камеры. В этом случае у треков будет большое ускорение, но так как все они движутся более или менее одинаково, то система Трекера движения распознает этот скачёк камеры и оставит треки.

Чем больше будут значения, тем меньше треков будут исчезать.

Вместе с фильтром Мин. длина (кадры) приводит этот фильтр к наилучшим результатам.

Закладка «Ручной трекинг»

 Треки пользователя

Коротко о различии между ручным и автоматическим трекингом:

Вы можете одновременно использовать ручной и автоматический трекинг или по отдельности только ручной или только автоматический.

Предварительно предлагается использовать автоматический трекинг, если при этом вы получите хорошую конструкцию камеры. В противном случае вам необходимо помочь дополнительно посредством ручного добавления треков или удаления плохих, автоматических треков (смотрите Что такое хорошие и плохие треки?).

Вот так можно создать 2D треки вручную:

2D треки пользователя после реконструкции будут собраны в отдельную от авто-треков группу 3D треков в менеджере объектов.

<
< Ручной трекинг >
>

Этими тремя кнопками можно произвести просчёт выделенных треков пользователя. Если ничего не выделено, то будет произведён просчёт всех треков пользователя. А именно следующим образом и в указанном в закладке «Футаж» временном отрезке:

Обычно следует кликнуть на кнопку Ручной трекинг, которая произведёт трекинг вперёд и назад. Но иногда имеет смысл произвести трекинг только в одну сторону. Это следует делать тогда, когда вы знаете, что к примеру образец трека пользователя появляется только с 98-ым кадром, в случае этого трека нет смысла просчитывать то, что находится в кадрах до этого и поэтому можно просчитать только в одну сторону, от 98-ого кадра и вперёд.

Каждый просчитанный трек получает во вьюпорте выделенный точкой ключ, содержимое которого преследуется во времени. Расположение трека во времени обозначается путём на протяжении 10 кадров перед и за маленьким крестом, в свою очередь обозначающим распознанный трек.

Теперь, перед тем как начать реконструкцию камеры, следует исправить плохие треки (см. Интерактивная работа с 2D треками).

Удалить треки пользователя

Эта кнопка удаляет выбранные треки пользователя. Если ничего не выбрано, то будут удалены все треки пользователя.

Треки
Название

Тут можно найти список всех треков пользователя. Выделив одну из строчек в этом списке, вы выделите соответствующий трек во вьюпорте. Возможно выделение нескольких строчек одновременно. Выделенный трек можно переименовать в поле Название. Под этим именем позже появится и соответствующий 3D-трек в менеджере объектов после реконструкции камеры.

Если перечисленные тут треки пользователя появятся также во вкладке «Трекеры» Трекера объекта, то они принадлежат трекингу объекта. Их нужно там специально назначить. То есть, объект Трекера движений сохраняет и управляет принятыми авто-треками и треками пользователя, не важно какому из Трекеру объекта они в итоге принадлежат.

Размер образца [3..10001]
Размер образца
Площадь поиска [5..10001]
Площадь поиска

Тут отображается размер образца и площадь поиска выделенного в списке трека пользователя. Также вы можете их интерактивно редактировать тут или же во вьюпорте. Значения размеров при создании трека пользователя перенимаются из соответствующих настроек в закладке «Настройки».

Обрамлённый размером образца набор пикселей, в данном случае буква О, будет искаться в соседствующих кадрах.

Ещё немного о работе 2D трекинга. Узнаваемые участки футажа преследуются в течении некоторого времени по их 2D координатам. Теперь следует узнать следующее – какой размер у этих участков и где их следует искать в кадре?

Именно это и регулируют эти параметры. Вы видите вокруг каждого трека пользователя два квадрата. Один поменьше, другой побольше. Тот, который поменьше обозначает размер образца: образец битовой карты, который сохраняется в ключе. Этот образец в ключе и ищется вовремя трекинга по площади кадра. Но конечно не весь кадр обыскивается – это слишком долго бы просчитывалось и вообще не имело бы смысла, так как обычно изображение меняется из кадра в кадр лишь незначительно. Поэтому поиск этого образца происходит только на площади поиска, которая обозначается квадратом побольше. Если образец в соседнем кадре не найден, то трек заканчивается.

Как только треки созданы, то их в любой момент можно интерактивно обработать во вьюпорте используя для этого грифы в углу каждого квадрата. Если до этого был произведён трекинг, то после изменения автоматически он будет обновлён для данного трека.

Когда следует изменять эти параметры?

Более крупный размер образца обеспечит в данном случае более точную идентификацию трека.

Посмотрите на пример выше. На изображении слева в маленьким квадратом обведён маленький штрих буквы «F». Это значит, что алгоритм будет искать этот образец в следующем кадре и при этом может по ошибке случиться, что вместо маленького штриха алгоритм найдёт большой штрих. Если вы измените размер образца таким образом, что он, как на картинке справа, вместит в себя всю букву «F», то это поможет алгоритму лучше идентифицировать образец.

Площадь поиска следует увеличить, к примеру, в том случае, если камера движется быстро и искомый образец в соседних кадрах находится слишком далеко.

Площадь поиска и Размер образца измеряются в пикселях соответственно масштабу футажа.

К примеру, если вы настроили окно вьюпорта так, что отображает размер футажа 1:1 и установили Ресамплинг на 100%, то в этом случае футаж отображается таким, каким он является на самом деле. Если вы установите Ресамплинг на 50%, то размер квадратов окажется в два раза больше.

RELEASE 19

Форма образца
Форма образца

Тут у вас есть возможность выбрать между квадратным и круглым треком пользователя. После этого сразу будет произведён новый трекинг выбранных треков (смотрите также Стандартная форма образца).

Канал цвета
Красный канал [-200..200%]
Красный канал
Зелёный канал [-200..200%]
Зелёный канал
Синий канал [-200..200%]
Синий канал

Здесь вы можете выборочно изменить вес цвета индивидуально выбранных треков. Это немедленно произведёт новый трекинг. Информацию о весах цветов можно найти в Задание веса красного/зелённого/синего.

В меню Канал цвета можно найти следующие опции:

  • Яркость: уже знакомая по предыдущим версиям программы яркость.
  • Красный/Зелёный/Синий: задайте тут индивидуальное значение для соответственного канала цвета.
  • Усиленный Красный/Зелёный/Синий: эта опция также дополнительно задаёт другим каналам цвета негативные значения, чтобы, например, при наличии белого фона (смотрите также Задание веса красного/зелённого/синего), красный имел более сильный контраст с ним. Таким образом маркеры будут хорошо выделяться на том фоне, который содержит большой процент цвета самого маркера.
  • Стандартный: меняет значения веса цветов во вкладке «Настройки» на заданные тут.
  • Установить как стандартный: делает установленные веса цветов предварительно заданными.
  • Пользовательский: становится доступной, когда вы индивидуально меняете настройки соответственных весов цветов (их можно открыть, кликнув по небольшому треугольнику около Канала цвета).

Закладка «Настройки»

Стандартный размер образца [3..10001]
Стандартный размер поиска [5..10001]

Тут можно установить исходные значения этих двух параметров, которые впоследствии будут использоваться авто-треками и треками пользователя. Эти значения в треках пользователя можно изменить вручную.

Более подробную информацию об этих функциях вы найдёте в разделе Размер образца .

RELEASE 19

Стандартная форма образца

В предыдущих версиях Cinema 4D (до R19) были доступны лишь квадратные размеры образца. Если вы используете футаж, в котором, к примеру, применяются круглые маркеры (или небольшие сферы), то процесс трекинга можно улучшить, выбрав здесь опцию Круг. Если размер образца находится точно на круглой форме, то изменение заднего плана не играет никакой роли (что было бы проблемой при использовании квадратного размера образца и образец просто не был бы найден). При создании новых треков будет применяться соответственная форма, в зависимости от того, что вы задали здесь. Отдельные и выделяемые треки можно впоследствии также изменить подобным образом (вкладка «Ручной трекинг»).

Показ треков

RELEASE 19

Отображение футажа

Чтобы отобразить футаж привычным образом, выберите тут Оригинал.

Если же вы хотите отобразить футаж с учётом нижеуказанных весов канала цвет, то выберите опцию Вид трекера. Футаж будет отображён в качестве полутонов. Треки лучше всего отслеживаются в областях высокого контраста, к примеру, при переходе от белого к чёрному (смотрите также на следующее изображение). Области без контраста как такового не могут быть отслежены.

Показать участок образца
Показать участок поиска

Включите или выключите во вьюпорте отображение квадратов размера образца и площади поиска выделенных треков.

RELEASE 19

Стандартный вес красного [-200..200%]
Стандартный вес зелёного [-200..200%]
Стандартный вес синего [-200..200%]

Контраст для треков слева — хуже, а справа — лучше.

Начиная с R19, каналам цвета футажа можно задать различные веса для каждого трека пользователя (но не авто-трека!). В предыдущий версиях Cinema 4D учитывался лишь общий вес всех трёх каналов цвета. Стандартные значения весов 29.9%, 58.7% и 11.4% для красного, зелёного и синего соответствуют тому, как человеческий глаз воспринимает яркость. К примеру, красный цвет воспринимается в три раза ярче синего идентичной яркости. Если оставить эти опции без изменений, программа будет вести себя как раньше.

Обратите также внимание на опцию Отображение футажа Вид трекера (описана выше), при помощи которой можно увидеть то, что видит трек с учётом весов цветов.

Вы также может задавать негативные значения опциям. Представьте себе, что вы хотите отследить красный маркер на белом фоне. Оптимальным параметрами для красного, зелёного и синего в этом случае были бы значения 100%, -100% и -100% соответственно. Почему не 100%, 0%, 0%? Большая часть белого цвета состоит из красного компонента. Значения в -100% сильно увеличивают контраст. Таким образом, веса цветов можно использовать с большой точностью для определения контраста цвета для трека.

При помощи весов цветов вы можете назначить вес для новых авто-треков и треков пользователя. Существующим Трекам пользователя можно также задать новый вес цветов (вкладка «Ручной трекинг»).

Экстраполяция позиции поиска

Если опция активна, то область площади поиска будет немного перемещена вперёд по направлению движения треков. Это может помочь при идентификации треков и при быстрых и плавных движениях камеры. Площадь поиска в этом случае может быть немного уменьшена, что ускорит просчёт. Если же треки перемещаются рывками, то эта опция мало чем будет полезна.

RELEASE 18

Префикс трекера объекта

Эта опция заботится о том, чтобы треки, которые перечислены в предыдущей вкладке «Ручной трекинг» и принадлежащие объекту Трекера объекта, отображались в списке (и только тут) с их именами.