--- title: "Strokes" url: "https://help.maxon.net/zbr/en-us/Content/html/user-guide/3d-modeling/sculpting/sculpting-brushes/strokes/strokes.html" section_path: "User Guide > 3D Modeling > Sculpting > Sculpting Brushes > Strokes" description: "While sculpting polymeshes in 3D you can use 6 different types of strokes: Dots, DragRect, Freehand, Colorized Spray, Spray and DragDot. These can be used …" --- # Strokes While sculpting polymeshes in 3D you can use 6 different types of strokes: **Dots**, **DragRect**, **Freehand**, **Colorized Spray**, **Spray** and **DragDot**. These can be used with the alpha sculpting feature. Below, left to right; **Dots**, **DragRect**, **Freehand**, **Spray**, and **DragDot** stroke types, sculpted onto a plane in **3D Edit** mode. The **DragRect** stroke started at the center of the circle, and was dragged out; all other strokes started at the top left, and were dragged to the lower right. ![Strokes01](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes01.png) To experiment with these different strokes we’ll use the Cylinder3D primitive as a starting point. Follow these steps: - Select the **Cylinder3D**primitive in the **Tool** palette. Draw it on the canvas by clicking and dragging downwards then turn on **Edit** mode by pressing **T** on the keyboard. Rotate the view so the cylinder is side view by click+dragging the background. - In the **Tool>Initialize** sub-palette, set **X Size** = 20, **Y Size** = 20, **Z Size** = 100. Other settings can be left at their defaults. - Press the **Make Polymesh3D** button at the top of the **Tool** palette. This converts the primitive so it can be sculpted. - Press **Tool>Geometry>Divide** five times so that the cylinder has about 525,000 polygons. This will be a good resolution to work with. ### Using DragDot A **DragDot** stroke allows you to drag your brush around, to place your sculpting or painting at a precise point. Only the area under the mouse when the drag ends is affected. That’s very useful for a case where you might want to have a company logo or some other bit of text stamped onto the model. For our example, though, we’re going to get a bit more creative so that your imagination might be sparked to try even more interesting things. ![Strokes02](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes02.png) We’ll need these settings: - **Brush>Standard** selected. - **Alpha>Brush 09** (ring-shaped alpha) selected. - **Stroke>DragDot** selected. - **Transform>Activate Symmetry** on, to activate symmetry and turn off X and turn on **Z** for the Z axis only. - **Transform>(R)** on, to activate radial symmetry. - **Transform>RadialCount** = 8. - **Draw>Z Intensity** = 25. - **Draw>Draw Size** = 64. Now: 1. Click **Tool>Layer>New** to create a layer that we’ll edit on. 2. Use **Tool>Layer>Rename** and change the layer’s name to *DragDotLayer*. 3. Click on the column and drag your stroke down to a point near the bottom as shown below. ![Strokes03](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes03.png) Draw again to get this: As you can see, this stroke allows us to very easily create an intricate pattern with only a simple alpha. What’s especially nice about this stroke is how precise it is. You can place your alpha instance(s) in exactly the desired position. ### Using Dots This stroke draws a great many instances of the alpha very close together so that they blend into a single line. The closeness of each alpha to its neighboring instances is determined by how quickly you move the mouse. A slow stroke will create a uniform line (especially when lazy mouse mode is active), while fast movement will create a blotchy effect that is useful for some organic work. For this example, we’re going to use the stroke to add some rings around the column, separating it into sections. ![Strokes04](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes04.png) Set: - **Brush>Standard** selected. - **Alpha>Brush 12** (circle-shaped alpha) selected. - **Stroke>Dots** selected. - **Transform>Activate Symmetry** on, to activate symmetry and turn off X and turn on **Z** for the Z axis only. - **Transform>(R)** on, to activate radial symmetry. - **Transform>RadialCount** = 100. - **Draw>Z Intensity** = 20. - **Draw>Draw Size** = 5. After everything is set up, just: 1. Create a new layer by pressing **Tool>Layer:New**. 2. Rename it by pressing **Tool>Layer>Rename**, call it *DotsLayer*. 3. Draw some narrow rings around the column as shown in the following figure. ![strokes05](https://help.maxon.net/zbr/en-us/Content/Resources/Images/strokes05.png) Keeping the same settings as above, set: - **Draw>Z Intensity** = 15. - **Draw>Draw Size** = 10. Add a few more rings as shown in below. Don’t be afraid to keep going over the same area to build up additional width or depth. ![256px-Zb25droppedImage_6](https://help.maxon.net/zbr/en-us/Content/Resources/Images/256px-Zb25droppedImage_6.png) Now let’s sculpt a bit of a design on the very top of the column. Otherwise keeping the same settings as above, set: - **Alpha>Brush 01** (blurred circle-shaped alpha) selected. - **Transform>RadialCount** = 6. - **Draw>Z Intensity** = 35. - **Draw>Draw Size** = 30. Now just three strokes will add the sculpting shown above. ### Using DragRect The Drag Rectangle stroke draws a single instance of the alpha, which may be rotated while dragging the stroke. The alpha is drawn with its center point being where the stroke begins. As you move the mouse away from the starting point, the alpha becomes larger. As you move the mouse around the starting point, the alpha is rotated. ![Strokes06](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes06.png) Set up for drawing with: - **Brush>Standard** selected. - **Alpha>Brush 29** (three stacked arrows) selected. - **Stroke>DragRect** selected. - **Transform>Activate Symmetry** on, to activate symmetry and turn off X and turn on **Z** for the Z axis only. - **Transform>(R)** on, to activate radial symmetry. - **Transform>RadialCount** = 6. - **Draw>Z Intensity** = 35. - **Draw>Draw Size** is irrelevant; the size is determined by your mouse movement. 1. Create a new layer by pressing **Tool>Layer>New**. 2. Rename it to *DragRectLayer* by pressing **Tool>Layer>Rename**. 3. Now draw a stroke that begins a little below the upper set of rings. Drag straight down until the arrows almost touch those that are also being drawn to the left and right. When the size is right, move the pointer left or right a bit to ensure that the arrows point straight down along the shaft of the column, and release the mouse. The result will be as shown in the next figure. ![Zb25droppedImage_8](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Zb25droppedImage_8.png) 1. Repeat this just above the next set of rings down. Drag your stroke upwards to point the arrows toward the top of the column. As you can see, the **DragRect** stroke type is perfect for stamping any sort of design onto the model. Another use would be with a speckled alpha to draw pores on a person’s skin. Because you control the size and orientation of the alpha with every stroke, you can keep the stamps from repeating, thus preserving a naturally organic appearance. ### Using Freehand The **Freehand** stroke type is very similar to **Dots**. Both can be used with the **LazyStep**modifier to repeat the alpha in a regular way. ![Strokes08](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes08.png) Set: - **Brush>Standard** selected. - **Alpha>Brush 18** (pyramid-shaped alpha) selected. - **Stroke>Freehand** selected. - **Stroke>Modifiers>LazyMouse**turned on and **LazyStep** = 1.5. - **Transform>Activate Symmetry** on, to activate symmetry and turn off X and turn on **Z** for the Z axis only. - **Transform>(R)** on, to activate radial symmetry. - **Transform>RadialCount** = 6. - **Draw>Z Intensity** = 35. - **Draw>Draw Size** = 30. 1. Create a new layer by pressing **Tool>Layer>New**. 2. Rename it to *LazyStepLayer* by pressing **Tool>Layer>Rename**. 3. Now draw a single line down the side of the column. It may help to rotate the model onto its side before doing this. The **LazyStep**modifer is remarkably useful any time you want to draw lines of repeated detail. You could trace a line of rivets along the seams in an aircraft’s panels, create cute little swirls of dots, etc. The **Roll** modifier is similar but instead of the alpha being spaced out as with LazyStep, it is stretched depending on the **Roll Dist** setting. **Roll** is specifically designed for tileable alphas so that an unbroken design can be created. To test the **Roll** modifier, turn off the LazyStepLayer first, then: Set: - **Brush>Standard** selected. - **Alpha>Brush 62** (stone wall type alpha) selected. - **Stroke>Freehand** selected. - **Stroke>Modifiers Rol**l turned on and **Roll Dist** = 1. - **Transform>Activate Symmetry** on, to activate symmetry and turn off X and turn on **Z** for the Z axis only. - **Transform>(R)** on, to activate radial symmetry. - **Transform>RadialCount** = 6. - **Draw>Z Intensity** = 10. - **Draw>Draw Size** = 60. 1. Create a new layer by pressing **Tool>Layer>New**. 2. Rename it to *RollLayer* by pressing **Tool>Layer>Rename**. 3. Now draw a single line down the side of the column. You can constrain the line if you hold down **Shift** after clicking the mouse/pen but before starting to draw. ### Using Spray and Colorized Spray These two stroke types splatter the model with semi-random copies of the alpha. There are settings to determine how far apart the alpha instances can be, how much they fluctuate in scale, how densely the instances are drawn (just a few scattered, or a lot), and how color is affected. The difference between the two stroke types is specifically in how each deals with color. Spray will cause the value of the currently selected color to fluctuate. Colorized Spray will affect its hue. Since we’re strictly sculpting in this tutorial, the color modifications don’t play a role and so we could use either stroke with exactly the same results. We’ll just use Spray. ![Strokes09](https://help.maxon.net/zbr/en-us/Content/Resources/Images/Strokes09.png) Set: - **Brush>Standard** selected. - **Alpha>Brush 04** (like a puff of cotton) selected. - **Stroke>Spray** selected. - Make sure **LazyMouse** and **Roll** are turned off. - **Transform>Activate Symmetry** off, to deactivate symmetry - **Draw>Z Intensity** = 20. - **Draw>Draw Size** = 30. - **Draw>Zsub** = selected. 1. Create a new layer by pressing **Tool>Layer>New**. 2. Rename it to *SprayLayer* by pressing **Tool>Layer>Rename**. 3. Now simply draw some damaged spots on the column. The **Spray** strokes are a very powerful way to quickly create randomized organic detail. Don’t forget that while we’ve used them strictly in a modeling capacity in this tutorial, they also work quite well with polypainting. That’s where you’ll really put the color features of these stroke types to good use. ### Resetting the Standard brush to its defaults When you have finished experimenting you may want to reset the Standard brush to its original settings. The simplest way to do this is to press the **Reset All Brushes** button at the bottom of the **Brush** palette.